Skip Navigation

[Resolved] the Google Maps autocomplete service

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

No supporters are available to work today on Toolset forum. Feel free to create tickets and we will handle it as soon as we are online. Thank you for your understanding.

Sun Mon Tue Wed Thu Fri Sat
- 10:00 – 13:00 10:00 – 13:00 10:00 – 13:00 10:00 – 13:00 10:00 – 13:00 -
- 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 -

Supporter timezone: Asia/Kolkata (GMT+05:30)

This topic contains 2 replies, has 2 voices.

Last updated by yoshihikoH 5 months, 3 weeks ago.

Assigned support staff: Minesh.

Author
Posts
#2434813
googlemaps setting.png
toolset setting.png
post form-a.png

I run a recruitment website.
When I post the job information, the message "We could not connect to the Google Maps autocomplete service, but you can add an address manually." appears in the post form and the googlemap is not displayed.
Please confirm the attached file.
My settings for googlemaps appear to be correct. The proof is that the first attached file, googlemaps, recognizes the api key and displays the map. For reference, I attached the general setting screen of the toolset setting in the second attachment.

Regards,

Yoshihiko

#2434891

Minesh
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello. Thank you for contacting the Toolset support.

Can you please click on button "Check API" and see if it display the message with red color text or green color text.

Also, Are you based at China? If yes, please check the following Doc:
- https://toolset.com/course-lesson/how-to-use-toolset-maps-plugin-in-china/

Also, can you please make sure that with the API key you generated all APIs are activated:
- Maps JavaScript API
- Geocoding API
- Places API

#2435519

My issue is resolved now. Thank you!