Skip Navigation

[Resolved] Slider seems to have a "blink" when change the current slides

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Sun Mon Tue Wed Thu Fri Sat
- 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 -
- 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 -

Supporter timezone: Asia/Karachi (GMT+05:00)

This topic contains 7 replies, has 3 voices.

Last updated by dianaL-2 1 year, 1 month ago.

Assisted by: Waqar.

Author
Posts
#2590773
Captura de Pantalla 2023-04-10 a la(s) 20.10.39.png
Captura de Pantalla 2023-04-10 a la(s) 20.08.56.png

Tell us what you are trying to do?

I've created a slider using views (not block editor), every time slides changes to next slides, there's some blank space that feels like a blink.

Is there any documentation that you are following?

No, only found for the block editor. Im attaching screen caption on how I've configured my slider

What is the link to your site?

You can review slider behavior in hidden link

Thanks

#2591631

Minesh
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello. Thank you for contacting the Toolset support.

Can you please share admin access details and let me see whats causing the issue.

But before you pass the access details to me:
Could you please try to resolve your issue by deactivating all third-party plugins as well as the default theme to check for any possible conflicts with any of the plugins or themes?
- Do you see any difference?

*** Please make a FULL BACKUP of your database and website.***
I would also eventually need to request temporary access (WP-Admin and FTP) to your site. Preferably to a test site where the problem has been replicated if possible in order to be of better help and check if some configurations might need to be changed.

I have set the next reply to private which means only you and I have access to it.

#2592617

Minesh
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Thank you for sharing admin access details but unfortunately the admin access details you shared is not working at this end. It says there is no user available with the toolsetsupport.

Can you please send me working admin access details.

I have set the next reply to private which means only you and I have access to it.

#2595167

Hi,

Minesh is on vacation so I'll be following up on this ticket.

Thank you for sharing the admin access details. I've checked the view 'Slider propiedad destacada' and noticed that it is set to use the transition effect 'Slide Left'. The blink of empty space appears when the slide transitions from one slide to another so that it looks like 'Slide Left' effect becomes clearer. The duration of this transition can be reduced by reducing the duration of this transition.

I've changed it from 500 milliseconds to 250 milliseconds and you'll notice that the transition has become much smoother.

I hope this helps and please let me know if you need further assistance.

regards,
Waqar

#2595625
Captura de Pantalla 2023-04-17 a la(s) 16.30.11.png
Captura de Pantalla 2023-04-17 a la(s) 16.30.42.png
Captura de Pantalla 2023-04-17 a la(s) 16.30.48.png
Captura de Pantalla 2023-04-17 a la(s) 16.32.49.png
Captura de Pantalla 2023-04-17 a la(s) 16.33.00.png
Captura de Pantalla 2023-04-17 a la(s) 16.33.10.png
Captura de Pantalla 2023-04-17 a la(s) 16.33.29.png
Captura de Pantalla 2023-04-17 a la(s) 16.39.22.png
Captura de Pantalla 2023-04-17 a la(s) 16.38.01.png

Hi Waqar

Thanks for your assistance here.
The fix you are proposing certainly make the transition effect to be less noticed, but the issue remains the same.

Just for you to notice, the issue is more complex. I decided to use side-left transition instead of fade, because using the fade with a duration of 500 ms you can perfectly see that the slides at that point tend to organize one on top of the other (during the transition)
So, the same remains on the side left effect but is less perceptive.

As we are working for a client, what we need is to correct the issue.

possible fix: As is my intention to fix this, I did try (on my production site) to use the block slider which have a very weird behavior and is taken the 100% width (each slide) and positioning one on top of the other, so as you can see, there's no slider at all. Here you can see it: hidden link

If necessary, I can provide access to the current production site.

Please find attach images describing my issue and how I have configured the blocks view slider

So, it may be using the old views or the new block views, but I really really need to correct this ASAP

Hope to hear from you soon

#2597611

Thank you for sharing these details.

Just wanted to let you know that I'm still working on this and will be able to share my recommendation within the next few hours.

Thank you for your patience.

#2598349

Thank you for waiting and here are my findings.

When using the Toolset's view with pagination, the slider loads the next/previous slides/pages, through AJAX calls. All the slides/pages are not loaded at once when the page loads.

Because the slides/pages are loaded each time the transition takes place through an AJAX request, the slight delay in completing that request causes the flicker or blink that you're referencing here.

To overcome this, you'll need to use a slider script that loads all the slides when the page loads and then loops them through the script into a carousel.

Here are some resources where you'll find examples of such carousel scripts/libraries:

hidden link
hidden link
hidden link

If you need further assistance with integrating any of those slider scripts/libraries into a Toolset classic/legacy editor view, please let me know.

#2598905

I decided to use the new block slider and completly had to css manually.
But fortunately, now is working.

Thanks for your assitance here

This ticket is now closed. If you're a Toolset client and need related help, please open a new support ticket.