Skip Navigation

[Resolved] How to build dynamic link using Toolset

This thread is resolved. Here is a description of the problem and solution.

Problem: How to build dynamic link using Toolset

Solution: You can use the anchor tag with either classic editor block or Fields and Text block and add the required HTML with that.

You can find the proposed solution in this case with the following reply: => https://toolset.com/forums/topic/shortcode-not-clickable/#post-2094155

Relevant Documentation:

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by maiS 3 months, 1 week ago.

Assigned support staff: Minesh.

Author
Posts
#2094117

Hi,
You provided me with a shortcode to control the sizes of the images in a view - you guys had some trouble making the image sizes adjust no matter how you changed them, so you solved it with a shortcode. I just realized that the image is not click-able. Is it possible to make the image clickable so you can click your way to the camp through the image as well? All the elements in the view should be clickable.

It is on this site - the view with white background: hidden link

Thanks.

#2094155

Minesh
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello. Thank you for contacting the Toolset support.

To link the image with the current post URL in the loop, you just need to replace your image code with the following code:

<p><a href="[wpv-post-url]">[types field='cover-image' title='%%TITLE%%' alt='%%ALT%%' size='custom' width='600' height='400' resize='crop'][/types]</a></p>
#2094177

Hi Minesh,

It gets me this error: "Validation failed. Please, provide correct values for all fields." when I update the page. Can you help?

#2094281

Minesh
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

I see you have added number of custom fields, can you please check if you miss to setup the value or source for any of your custom fields or try to remove the top view filter and see if that causes the issue?

#2094477

Hi there,

I tried again and now it works - thanks 🙂

#2094479

My issue is resolved now. Thank you!