Skip Navigation

[Resolved] Relationship shearch

This support ticket is created 2 years, 6 months ago. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Sun Mon Tue Wed Thu Fri Sat
9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 - - 9:00 – 13:00
14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 - - 14:00 – 18:00

Supporter timezone: Africa/Casablanca (GMT+01:00)

This topic contains 6 replies, has 2 voices.

Last updated by Jamal 2 years, 6 months ago.

Assisted by: Jamal.

Author
Posts
#2225747
Screenshot 2021-11-20 at 22.27.06.png
Screenshot 2021-11-20 at 22.27.02.png

I am trying to:make search

Link to a page where the issue can be seen:

I expected to see:select box

Instead, I got:not shown

#2226157

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello and thank you for contacting the Toolset support.

I suspect that the posts that the view should return are not connected to any related posts. And that the filter is configured to display only the options that will produce values. Make sure that at least one post that will be returned by the view is connected to a related post that should appear on the filter.

If that does not help, allow me temporary access to your website and I'll check this closely. Your next reply will be private to let you share credentials safely. ** Make a database backup before sharing credentials. **

#2226253

All relationships are made with product and client. I can not show the website because it is in my local computer with localhost.

#2226275

How can i send you the user and password?

#2226587

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Unfortunately, it keeps redirecting me to a private @IP(hidden link) and I can't log in. Can you share a copy of the site using the Duplicator plugin or the All In One Migration plugin? If yes, please exclude the uploads folder to reduce the size of the copy. Your next reply will be private to let you share the download link safely.

#2226595

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

The login page is now styled as it should which was not the case earlier. But, the user/password are not working for me.
Can you double check from your side and update the credentials on your previous reply or on your next one?

#2226701

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Thank you! I was able to login. And I assume you are talking about the view on this page, right? hidden link

I was able to add a relationship field, and I created another client and product to test with, as you can see on the following search, product 1 and product 2 are not part of the results, because we are filtering for products related to client 2: hidden link

I noticed that you are adding a filter on the custom field active. This is a custom field of the intermediary post, it cannot be used for a search of a parent or child post(Clients or Products). It can only be used for views that search within the intermediary post type. I created an example on another page with a relationship field for clients, and a filter for the active custom field. Check this example:
hidden link

I hope this gives you an example on how to use the search in views of custom post type and intermediary post types. Let me know if you have any questions.

This ticket is now closed. If you're a Toolset client and need related help, please open a new support ticket.