Skip Navigation

[Resolved] reference site stops at unpack demo files

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

No supporters are available to work today on Toolset forum. Feel free to create tickets and we will handle it as soon as we are online. Thank you for your understanding.

Sun Mon Tue Wed Thu Fri Sat
- 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 -
- 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 -

Supporter timezone: Asia/Karachi (GMT+05:00)

This topic contains 18 replies, has 3 voices.

Last updated by Waqar 1 year, 6 months ago.

Assigned support staff: Waqar.

Author
Posts
#2090003
Screen Shot 2021-06-16 at 2.29.05 PM.png

Tell us what you are trying to do?
Intalling a demo site
Is there any documentation that you are following?
https://toolset.com/course-lesson/using-framework-installer-to-install-reference-sites/?_ga=2.53967208.1792508066.1623811715-1420457949.1622962038

What is the link to your site?
hidden link

contacted WP to enable zip extension and it is enabled.

Also just changed domain to adventistpages.org and don't know how to change it in the account page.

Thank you!

#2090321

Waqar
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Welcome to Toolset support and I'd be happy to assist.

I just tested the import of the same real estate reference site on my website and it completed successfully.

This suggests that something specific to your website/server is involved.

I'll recommend turning on WordPress debugging and then see if any errors or warnings are recorded in the server's error log, when the import fails.
( ref: https://wordpress.org/support/article/debugging-in-wordpress/ )

Each Toolset site key can only be used on a single WordPress website, whose address was used to generate it. This means that if your website's domain or base address is changed, you'll need to delete the old site key and activate a newly generated one.
( ref: https://toolset.com/faq/how-to-install-and-register-toolset/#migrating-registration-to-a-different-domain )

These will be the steps:

1. Please go to the Toolset's site key management page ( https://toolset.com/account/sites/ ) and delete the existing site key.

2. Next, you'll generate a new one, making sure to use the same address that is set in the website's "Site Address" field.
( at WP Admin -> Settings -> General )

After that, you can activate the new key on your website.

I hope this helps and please let me know if you need any further assistance around this.

regards,
Waqar

#2094003

I don't see any warnings or errors.

#2094005

Sorry I ran it again and here it is:
[21-Jun-2021 02:59:36 UTC] PHP Warning: copy(en_US-default-wp-components.json): failed to open stream: Read-only file system in /srv/htdocs/wp-content/plugins/framework-installer/classes/unpack.class.php on line 146

#2095701

Waqar
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Thanks for the update.

Can you please share temporary admin login details in reply to this message?
( you can use any email address for this temporary user, but please make sure to assign the "administrator" role )

Note: Your next reply will be private and please make a complete backup copy, before sharing the access details.

#2098689

Did you get my last message?

#2101105

Waqar
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

I'm afraid, I haven't received any message from you with the temporary admin access details.
( as requested here: https://toolset.com/forums/topic/reference-site-stops-at-unpack-demo-files/#post-2095701 )

Your next reply will be private, so can you please send them again?

Please note that we only need the username and password for the user with the administrator role on your WordPress website.

#2106447

Waqar
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Thank you for sharing the admin access and your website's settings seem to be correct.

Do I have your permission to download a clone/snapshot of the website to investigate this on a different server?

#2106539

Sure

#2107559

Waqar
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Thank you for the permission.

I tested the clone of your website on my test server and the import of the demo website "C&B Properties", completed without any errors.

To rule out any conflict with the server-specific plugins, please go to WP Admin -> Plugins and deactivate all non-Toolset plugins and then perform the import process again. Once the import is successful, you can activate the disabled plugins again.

I hope this helps and let me know how it goes.

#2108175

Not working! I am starting to get a bit frustrated as it was the plan to use a reference site to save time. And now I'm not moving at all.

[07-Jul-2021 06:23:31 UTC] PHP Warning: copy(en_US-default-wp-components.json): failed to open stream: Read-only file system in /srv/htdocs/wp-content/plugins/framework-installer/classes/unpack.class.php on line 146
[07-Jul-2021 06:23:56 UTC] PHP Warning: copy(en_US-default-wp-components.json): failed to open stream: Read-only file system in /srv/htdocs/wp-content/plugins/framework-installer/classes/unpack.class.php on line 146
[07-Jul-2021 06:24:17 UTC] PHP Warning: copy(en_US-default-wp-components.json): failed to open stream: Read-only file system in /srv/htdocs/wp-content/plugins/framework-installer/classes/unpack.class.php on line 146
[07-Jul-2021 06:24:56 UTC] PHP Notice: Undefined offset: 1 in /wordpress/core/5.7.2/wp-includes/vars.php on line 32

#2108285

Waqar
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Sorry to learn that the issue still persists and I can understand the frustration.

Based on the testing that I've done so far it seems that there is some compatibility issue involved in using the Toolset Framework Installer plugin on a website hosted at WordPress.

I've shared these findings with the concerned team for further review and will keep you updated through this ticket.

For now, you can use any of these two workarounds:

1. You can import the demo and the develop your website on a localhost website and when it is ready, move it to the live server at WordPress.
hidden link
hidden link

OR

2. You can change your live website's hosting to some host other than WordPress.
( Toolset server requirements: https://toolset.com/toolset-requirements/ )

#2109087

Hi for now the two options are not working for me. Would you be able to set it up for me?

#2109989

Waqar
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Thanks for writing back.

I've heard back from the concerned team about the compatibility issue between the framework installer plugin and WordPress hosting.

As their hosting is a restrictive environment and the framework installer plugin seems to work on other hosts, this is something that will need to be investigated by your hosting's support team.

If for some reason, you'd like to stay with your current host, you can raise this matter with their support team.

In case you're open to switching to a different host, then these are the hosts recommended by WordPress for the self-hosted WordPress websites:
https://wordpress.org/hosting/

Note: Since setting up of localhost websites is something that needs to be done on your computer, I'm afraid, it won't be possible for us to set it up for you, remotely.

Apart from the guides that I shared in my last reply, you'll also find a number of step-by-step, tutorial videos on this topic in Youtube:
hidden link

#2110053

Waqar
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Following up on my previous reply, there is another workaround that can be tried with your permission.

I can create a new WordPress website on my server and then import the “C&B Properties” demo website on it. Once it is working, I can then import that new website on your server overwriting your existing website, using the migration plugin "All-in-One WP Migration".
( ref: https://wordpress.org/plugins/all-in-one-wp-migration/ )

Your host "WordPress.com" is available in that plugin's list of supported hosts:
hidden link

If you allow this, I'll need access to the WordPress admin area of your website as the authentication link that you previously shared no longer seems to work.

I'm setting your next reply as private and please make sure to keep the "Secure Sign On" feature from Jetpack disabled, until this migration is completed.
( ref: hidden link )