Skip Navigation

[Resolved] Provider view is limited and does not show all (max) provider

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Our next available supporter will start replying to tickets in about 8.94 hours from now. Thank you for your understanding.

This topic contains 3 replies, has 2 voices.

Last updated by romanF 6 months, 3 weeks ago.

Assigned support staff: Jamal.

Author
Posts
#1967917
kuntforum paginage.jpg

Hey,

I have two issues with my provider (Aktueure) overview page.

First, it does not show the maximum selected providers. This is set to 39 it does only show 15

Second, I added a pagination but this is not shown either.

hidden link

The goal here is to show as many as possible and if not all can be shown at least give a possibility to go through all of them page by page.

Your help is highly appreciated.

#1968853

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello and thank you for contacting the Toolset support.

I am not really sure to understand what do you mean. Please correct me if I am wrong. You have currently 36 posts, the view only displays 15, and the pagination does not appear, right?
If that's the case, I would say that the view is cached, create another post to invalidate the cache, and try again. You can then delete the newly created post.

If that's not the case, please explain again in small steps like:
1. I go to xxx
2. I do xxx
3. I expect to have xxx
4. Instead, I get xxx

If it is possible, allow me temporary access to check this, and add the URL of this page on the backend. Your next reply will be private to let you share credentials safely. ** Make a database backup before sharing credentials. **

#1970905

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

I created a new private page with a new View while debugging this issue. You can remove it if you want to hidden link

The issue with the current view in hidden link was caused by two settings:
- Pagination: You were settings the pagination to 39, that's the total number of posts, so no 2nd page will be generated. Check this screenshot hidden link
- Limit: You were setting a 15 post limit, which means that the view will only display 15 posts. Check this screenshot hidden link

I corrected it by settings pagination of 15 items per page and removing the limit. The pagination now appears under the view's results. Check this screenshot hidden link

The pagination placeholder was wrong. You used "%%Seite%%" instead of "%%PAGE%%". I also fixed it and now it gives the expected results hidden link

#1970929

My issue is resolved now. Thank you!