Skip Navigation

[Resolved] Problem with the display on a custom content type archive page

This thread is resolved. Here is a description of the problem and solution.

Problem:

Style the view's outputs with custom CSS codes

Solution:

It is a custom CSS code issue, see the solution here:

https://toolset.com/forums/topic/problem-with-the-display-on-a-custom-content-type-archive-page/#post-2291559

Relevant Documentation:

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Sun Mon Tue Wed Thu Fri Sat
- 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 -
- 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 -

Supporter timezone: Asia/Hong_Kong (GMT+08:00)

This topic contains 5 replies, has 2 voices.

Last updated by katinaA 9 months, 2 weeks ago.

Assigned support staff: Luo Yang.

Author
Posts
#2291441

I'm trying to set up an archive page and am experiencing very strange results on the page. We're setting up a Partners archive page here:

hidden link

If you go to that page you'll see the display problem. The content from the archive template is overlapping the footer from the theme. I have no idea why it would do that.

I have already set up a View using the same content and layout of everything for a Latest Partners View. I have that displaying on a Test Latest Partners page here:

hidden link

It's all displaying fine there. We have this Latest Partners view set to only show Partners that have been added within the last 60 days. All of them are the same results as what's in the archive page because I've just added all these Partners to test with. But on the Archive page, we want to show all Partners. Note that I could easily set up a new View and page to display all of these that way if I have to. I'm just curious why this archive is doing what it is doing.

One other problem with the archive page is it is not displaying the filter we'd like to have on the page. It should be showing a filter for the region. I set up that filter the same way I've set up other ones successfully, but this one isn't working for reasons unknown. Sorry we're having so many issues requiring assistance. Unfortunately we're likely to have several more as we're going to be setting up a full mapping and filtering by region, activity, and amenity system with these Partners. Your plugin is exceptional, but has a very steep learning curve to it.

#2291559

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

wd-blog-holder.jpg

Hello,

It should be a CSS issue, please try to remove the CSS codes "height: 0px" from HTML div "wd-blog-holder", see my screenshot wd-blog-holder.JPG

#2292033

YOU'RE AWESOME!!!!!! Thanks again. I changed the CSS on the element to use height: auto !important and that work to override the 0px setting.

I also now see that my Region filter is working, but it is displaying below the content. I just didn't see it before because it was among the clutter of the footer region. How do I move it to display above the content?

#2292405

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

For the new question, please check these:
Edit the post view(ID: 9934), in section "Output Editor", make sure those two shortcodes are in below order:

[wpv-filter-meta-html]
[wpv-layout-meta-html]

[wpv-filter-meta-html] is for custom search form, [wpv-layout-meta-html] is for search results.

#2293421

OK, I understand using Output Editor now. This is great!

#2293423

My issue is resolved now. Thank you!