Skip Navigation

[Resolved] Previously working archive view returns "No items found" in front-end

This support ticket is created 2 years, 10 months ago. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Sun Mon Tue Wed Thu Fri Sat
8:00 – 12:00 8:00 – 12:00 8:00 – 12:00 8:00 – 12:00 8:00 – 12:00 - -
13:00 – 17:00 13:00 – 17:00 13:00 – 17:00 13:00 – 17:00 13:00 – 17:00 - -

Supporter timezone: America/New_York (GMT-04:00)

This topic contains 8 replies, has 2 voices.

Last updated by benjaminW-3 2 years, 10 months ago.

Assisted by: Christian Cox.

Author
Posts
#2140991

I am trying to:

Backend shows archive results. Front-end returns NO ITEMS FOUND

Updated WP and Toolset to latest version.

Link to a page where the issue can be seen:

hidden link

I expected to see:

The map with the results underneath. Pins on map are visible.

Instead, I got:

Map with pins, but no search result. Seach results are visible in back-end.

#2141339

Hello, unfortunately the Maps 2.0.9 release introduced a bug in the integration between Map blocks and Views/Archive blocks, and the symptoms you described indicate this is the problem you are experiencing as well. You can see details about the problem and a temporary patch here: https://toolset.com/errata/cannot-specify-view-as-source-of-markers-in-map-block-following-maps-2-0-9-release/

You can follow the instructions in that post to install the temporary patch, which should resolve the issue until our developers can release a more permanent solution in an upcoming plugin release.

#2141359

Hello, Thank you for this patch. Unfortunately it didn't change anything. There's still the no results error. I tried to change some values and re-save the archive but that didn't do anything as well.

Any other idea what I could try?

#2143283

Okay thanks for the update. If the patch did not solve the problem it's possible there is something else going on, or it's also possible the patch was not comprehensive enough to solve every edge case. Is it okay for me to make a clone of this site using the Duplicator or the All-in-One WP Migration plugin so I can ask our developers to investigate in more detail? Please let me know if you approve and I can create that site clone for our developers to review.

#2143609

Hello.

Thank you for taking the time to help us out.

I have created a duplicator archive in the backend. Feel free to download it or create a new one.

Thank you very much.

#2144083
Screen Shot 2021-08-16 at 4.05.37 PM.png

After a bit more investigation, there seems to be a problem with the marker that was previously added to the map block. I am attaching a screenshot here. I have removed this marker from the map block sidebar and placed a similar marker in the loop programmatically using a shortcode:

[wpv-map-marker map_id="dealer-list-1" marker_id="dealer-list-marker-[wpv-post-id]" marker_field="wpcf-address-maps"]<a href='[wpv-post-url]' target='_self'>Zum Händler</a>[/wpv-map-marker]

For now, this seems to resolve the problem - markers are displayed on the map and text results are shown below the map as expected. I am still investigating why the marker attached to the map block was causing a problem. I do not believe it is related to the known issue I originally suspected, because that issue is more related to map blocks not working as expected as opposed to results not appearing as expected. Something else is going on here and I need my 2nd tier team to take a look. I will provide them with the cloned copy of your site for additional investigation and let you know the results.

If you would like to make adjustments to the markers, you can find the shortcode inside the Archive's Loop in a custom HTML block. Let me know if you have questions about that and I'll try to get more answers for you.

#2144479

Thank you for your hard work.

Adding the marker with your shortcode worked, but it would show part of the shortcode on the pin popup in the frontend. I think it has issues with the inner square brackets. Anyway, I destroyed the query trying to only have "Zum Händler" visible on the pin popup. I had to restore the page unfortunately. I tried to add a new map view just as you described. As soon as I activate "View block" it doesn't return results.

Did you change anyhting else but the location marker code? For now I turned off map view.

Thank you

#2144663
Screen Shot 2021-08-17 at 8.42.30 AM.png

Adding the marker with your shortcode worked, but it would show part of the shortcode on the pin popup in the frontend. I think it has issues with the inner square brackets.
Sorry, I see there was a mistake in the code I shared, and the wpv-map-marker shortcode was not closed correctly. I updated the code sample in my previous comment, then I added the correct marker shortcode in a custom HTML block in your archive loop (screenshot attached here), and I deleted the marker you added in the new map block settings. Now the grid of results appears below the map, the markers appear on the map, and the marker popups each show Zum Händler as a link to the post. Feel free to test and make adjustments as needed in the custom HTML block.

My second tier team is still investigating the problem with the marker added in the map block, and I hope to have an update for you soon.

#2144689

Thank you, everything works now!

This ticket is now closed. If you're a Toolset client and need related help, please open a new support ticket.