Skip Navigation

[Resolved] Pages don't show for logged-out users.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by Waqar 1 month, 4 weeks ago.

Assigned support staff: Waqar.

Author
Posts
#2150625

Refer this ticket to Waqar.

hidden link
hidden link

Both pages above don't show for logged out users. However we didn't apply any access restrictions for them.

What is the issue here?

#2151091

Waqar
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

I tried to view the pages that you've shared, but neither the front-end nor the admin area of the website is loading.

Loading of all the pages just fails with timeout and it looks like the server is going through some maintenance activity.

Can you get in touch with your hosting support team to resolve this and let me know once the website is back online?

regards,
Waqar

#2151119

Both are back online.

#2152513

Waqar,

Didn't hear back from you?

Can you fix this issue today asap?

Thanks.

#2152747

Waqar
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Thanks for the update and sorry about the delay in getting back on this.

During troubleshooting, I noticed that although guests (non-logged-in users) do have access to both these pages, the forms on the pages are showing "not authorized message".

Please go to WP Admin -> Toolset -> Access Control -> Toolset Forms and you'll see all the post forms under the "Post Forms Frontend Access" heading.

To allow the guests (non-logged-in users) to use these forms "Vakexpert toevoegen" and "Project toevoegen", make sure that the checkbox for the "Guest" role is checked, in their column.
( example screenshot: hidden link )

#2152787

We've selected both forms for guests in the "Post Forms Frontend Access" section. However we still don't have access rights for both pages being logged-out. We've cleared the cache.

#2152791

Did what you've described, however the "not authorized message" is still showing for both pages. Cleared the cache first.

#2152813

Waqar
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Thanks for writing back, this does seem to be related to cache.

I do see the forms as guests, if I visit the same pages with some extra URL parameter e.g. "?no-cache=true".
hidden link
hidden link

The extra URL parameter makes the system think that this is a new page and it serves the newly generated copy of the page and not the cached version.

Please make sure to clear cache from all levels like server, CDN, plugins, and browser.