Skip Navigation

[Resolved] Page Attributes "Template" Not saving if not using a Layout

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Our next available supporter will start replying to tickets in about 0.99 hours from now. Thank you for your understanding.

This topic contains 23 replies, has 2 voices.

Last updated by Christian Cox 4 months ago.

Assigned support staff: Christian Cox.

Author
Posts
#1231126

I am trying to: Create a new page using Gutenberg. I do not want to use a Layout from Toolset, but instead use one of the built in templates in my theme which are normally set under Page Attributes > Template. However, with the Toolset Layouts plugin activated, my Page Attributes > Template field is not saving. I have the Content Template set to

Link to a page where the issue can be seen: N/A

I expected to see: My template dropdown save after I click "Update" when editing the page.

Instead, I got: it not to save

#1231140

Christian Cox
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Please provide login credentials in the private reply fields here so I can see what's going on in wp-admin. If the site isn't live, you can use the Duplicator plugin to create a site clone (exclude the wp-uploads folder please). Then upload that clone and post a link where I can download the files.

#1231148

To provide you access to our dev site, we will need the IP address(es) you will be access it from so we can whitelist you.

#1232367

Just checking on the status of this. We will need the IP address(es) you will be visiting our site from to be able to provide you access. - PLEASE DISREGARD, your last message just showed up.... will review and reply shortly.

#1232372

Unfortunately, I do not see a way to post a private reply. Please advise.

#1233054

Any update? I need to provide my login details, but do not see anyway to submit a private reply on this forum at the moment.

#1233535

Christian Cox
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Hi, I have reactivated private reply fields here.

#1234680

Christian Cox
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Okay I just edited this post in wp-admin:
hidden link
I modified the selection in Page Attributes > Template and saved it, then repeated the process with Layouts active. Both times, the change was saved as expected. I must not understand the problem completely, can you help?

#1234764

Please try post id 15505 (/wp-admin/post.php?post=15505&action=edit) and try to change the Page Attributes > Template. Note that the Layouts is set to "Don't use a layout" since we want to use the built in theme templates. In my example, I want to use the template "Full Width No Container".

#1235062

Christian Cox
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Okay thanks, I'm able to see the issue now. I'd like to create a clone of your site using the Duplicator plugin so I can run some additional tests locally. Let me know if you approve and I will get started.

#1235091

Yes, please proceed.

#1235255

Christian Cox
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Okay I can't upload the Duplicator plugin without FTP info and the All-in-One WP Migration plugin won't make an export for me. It looks like it doesn't have write permissions. How would you like to proceed?

#1236410

Can you please enable the ability to do a private reply again so I can send you details on how to get a backup?

#1236660

Christian Cox
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Sure, private reply fields are enabled here.

#1237834

The new IP has been whitelisted. Please try again.