[Resolved] Maps has stopped displaying on older iOS devices

We have one known recurring issue with WordPress 5.3.1 --> Dynamic Source no longer provides the feature image data. We are aware of it and a fix will be released for it soon.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 12 replies, has 3 voices.

Last updated by Beda 1 year, 2 months ago.

Assigned support staff: Beda.

Author
Posts
#1074270

I have just noticed that maps has stopped displaying on older iOS devices.

Blank white space where the map should be displaying is visible but the map itself is not displayed.

I have found this problem on:-

- an iPad 2 with the latest software version supported for that device (which is V9.3.5)

- a iPhone 4S with the latest software version supported for that device (which is also V9.3.5)

A current iPhone model is displaying maps correctly.

A page with a map display can be seen at hidden link

I have the same problem with the live version of my site.

There are still a lot of these older Apple devices out there and so I need to report this as a possible issue with the latest version of Toolset plugins.

All I can be sure of is that:-

I have not updated the software of these two Apple devices for over a year (V9.3.5 is the final version released by Apple for these older devices).

Maps displayed correctly at the beginning of June this year on the Apple devises (when I created both the dev and live versions of this website).

I would be grateful for your support on this issue.

Regards

Robert

#1074687

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

Dear Robert,

In order to debug such kind of browser problem, please provide below details:
1) In case it is a compatibility problem, please deactivate other plugins, and switch to wordpress default theme 2017, and test again

2) In order to see the the problem, which kind of device are you using? iPad 2 or iPhone 4S?
which version IOS are you using? IOS 9.3.5?

#1075137

Dear Luo

1) I deactivated all non-toolset plugins and switched to default theme 2017. Maps is still not displaying on iPad 2.
You can browse to hidden link to see the issue.

2) You can see the problem on an iPad 2 running IOS 9.3.5
This was the final software version released by Apple for the iPad 2.

Regards

Robert

#1076025

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

Since I don't have a iPad 2 device, I will need to escalate this thread, in the meantime, please provide a database dump file of your website, in case we need to check your website settings.
https://toolset.com/faq/provide-supporters-copy-site/

#1077281

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

Thanks for the details, I have escalated this thread to our 2nd tier supporters, will update here if there is anything news

#1078270

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

Here is the feedback from our 2nd tier supporters:

This might be due to the outdated iOS versions or else, please create a test site check these:
1. remmove toolset
2. Create map https://www.wordpress.org/plugins/wp-google-maps/
3. look if that works using iPad 2 running IOS 9.3.5
4. or test with some other Google Map plugins.

If it works with others, and toolset not, then try with a extreme minimal Map of toolset:
(no marker, for now, no attributes, etc)

#1078625

Dear Luo

Okay I installed wp-google-maps and it displays correctly on the iPad2. I have uploaded an image to show you.

I then deactivated that plug-in and reactivated Toolset maps. Then I removed all attributes from the stylesheet leaving only the basic map display. This does not display on iPad2. I have uploaded an image to show you.

So I have spent a lot of time providing information for what I believe may be a core Toolset issue.

I would kindly ask that this is now properly investigated. There are millions of iPad2's still being used in the world (and older iPhones as well).

You have not yet confirmed that anyone at Toolset has replicated the problem. Why is that so difficult?

So I am not very happy at the moment. Please refer this thread to Amir and ask him to respond please.

Regards

Robert

#1079441

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

Thanks for the feedback, I have forwarded the feedback and your requests to our 2nd tier supporters, will update this thread if there is anything news.

#1079462

Beda
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: Asia/Ho_Chi_Minh (GMT+07:00)

Hi Robert, this is Beda, I'll handle this problem for you.

We have confirmed that Toolset Maps does not display the map on the iOS version you mention.
We have not been able to confirm this earlier, because we do not all own an iPad with that iOS or a iPhone with.

I do own a SE iPhone, there the things work.

I am quite sure, if you download Toolset Maps version lower than 1.5 from here:
https://toolset.com/download/toolset-maps/#changelog > Download version 1.4.2 it would solve the issue.

If not, then that would mean the maps never worked on those devices - but according your statement it did this year in June, so it was Maps 1.5 breaking it.

Maps 1.5 introduced thing that could break support for older devices - I am not sure about this exactly, and I will put everything in line to make tests with the older Maps version, then the new, and then let a Developer look at this, because, even if Apple deprecated the device and iOS version, if only Toolset Maps and no other Maps software breaks on it, then I agree that we have to solve this.

This may however not be possible as fast as a generic BUG fix because this is a very particular compatibility issue with a device that is not actively supported anymore by it's own creator.

This is like you need to find parts to fix your car, but the manufacturer long ago stopped producing those parts.

The person I know in our company who owns such device is back next week.
I will however inform our Testing Department to look out for a device or maybe they have one around, so to test the both maps versions, and then, according that, react and fix if possible.

I will feedback here when we have more news.

#1079802

Hi Beda

Reverting to maps V1.4.2 fixed the problem. Maps are now displaying correctly on the iPad2.

So now you know where to start in sorting the issue.

I have a fairly serious request. There are millions of iPad2 and iPhones with the same iOS still out there in use.

I want Toolset to put out an announcement stating that there is this problem with Maps after V1.4.2 and that users should consider reverting to V1.4.2 if they want maps to display on these millions of older Apple devices.

That way the issue is acknowledged.

I test all my websites with older Apple devices as part of my professional due diligence. I humbly suggest that Toolset should do the same. Could you put this to Amir please and ask him to respond.

I'll wait to hear when this issue is sorted.

Best regards

Robert

#1080201

Beda
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: Asia/Ho_Chi_Minh (GMT+07:00)

Thank you for confirming this - I did not expect you to do that for me.
I mentioned this as I suspected the new features in Toolset Maps are not compatible with the specific iOS - which seems to be confirmed

I do unfortunately not own such device.
It is as well part of my own professional due diligence to test the issues I report to the developers and prepare testing cases, as well a proper debug report.
Then, their duty is to see if they can fix this, how to fix this, and after, it requires such testing in a Quality Control process.
I am aware that Apple's retired Device is still used, however, Apple itself would not fix any issue on it if reported.
Reporting this directly to Amir will not expedite this, as the process I outlined above, requires to be done in any case.

The issue you reported in is escalated to the Developers already, all the required steps are taken to let the developers have a look.
As I earlier mentioned I did put everything in move I can to find person with such device, let it debug, fix and release if possible.

This requires it's time. Meanwhile (Monday) the developers will after an evaluation of this issue file an erratum here:
https://toolset.com/known-issues/

The current solution as you confirm, should be to revert - however I need this analyzed and debugged by the developers to publish such statement.

We will take care of this issue, and as with all other problems see what we can do, and fix it.

I apologize if this stops your development, however, I can not speed the process more up than I did.

If you personally know Amir and want to inform him about this and request such actions as reply to a Support Forum ticket, I suggest that you contact him personally.

I cannot involve my CEO on a Support Ticket, this would be out of scope.
The issue is in the best hands it can be and Monday we will have first news I hope, not a fix of course in such short time.

I am away until Thursday, so I will inform my Team leader to update you here in case there are things to share or other news we need to communicate.

The erratum will be published as soon the developers had their first look at this.

Thanks

#1108722

Beda
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: Asia/Ho_Chi_Minh (GMT+07:00)

#1114833

Beda
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: Asia/Ho_Chi_Minh (GMT+07:00)

The erratum has been updated.

Unfortunately, Toolset cannot fix the conflict between the deprecated OS and newish JS libraries.