Skip Navigation

[Resolved] Incompatibility with Elementor after WordPress 5.5 upgrade

This thread is resolved. Here is a description of the problem and solution.

Problem:
The user had issues after plugins' updates.

Solution:
It turns out that Elementor Pro was not fully installed. After removing it and installing it again, the issues were resolved.

This support ticket is created 3 years, 9 months ago. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Sun Mon Tue Wed Thu Fri Sat
9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 - - 9:00 – 13:00
14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 - - 14:00 – 18:00

Supporter timezone: Africa/Casablanca (GMT+01:00)

This topic contains 9 replies, has 2 voices.

Last updated by nicolaT-2 3 years, 9 months ago.

Assisted by: Jamal.

Author
Posts
#1764935

Hi, the website hidden link is a multisite network that's built with Toolset. The network uses a child theme of Twenty Seventeen and the plugin Toolset Twenty Seventeen Integration.

In the multisite network there's one domain hidden link that doesn't use Toolset and that has Elementor PRO plugin (it uses alto a different Twenty Seventeen child theme). After WordPress 5.5 upgrade I had problems with Elementor (the editor wasn't loading). I debugged the website and found that there is a compatibility issue with the plugin Toolset Twenty Seventeen Integration. This is the only Toolset plugin activated in this domain: all the other Toolset pluigns are enabled site-by-site, Twenty Seventeen Integration is network-enabled instead.

I added this code to the file functions of the domain info.centrodimedicina.com (this domain uses a dedicated child theme, so any change in its file functions affects just this website):

/*start*/
add_filter('site_option_active_sitewide_plugins', 'modify_sitewide_plugins');
function modify_sitewide_plugins($value) {
global $current_blog;
deactivate_plugins('layouts-twentyseventeen/2017-integration.php');
return $value;
}
/*end*/

This code is used to disable a network-enabled plugin in one website. This fixed the problem in the backend but the frontend started giving a connection error.

At this point I:
1) deleted the new code in functions.php,
2) removed the network-activation of Twenty Seventeen Integration and activated it manually in all the subdomains except info.centrodimedicina.com.

Unfortunately this didn't solved my issues, I still can't work with Elementor editor, it's like the plugin is somehow still active in the subdomain. In fact, if I put again the abovementioned code in the file functions the editor works but the frontend brakes, again.

I need your help to:
Find a way to deactivate Toolset Twenty Seventeen Integration plugin in hidden link

or

Solve compatibility issues with Elementor PRO.

Thanks,
Nicola

P.S.
I can't provide debug info since in the domain hidden link Toolset is (officially) disabled.
I'm giving you login info, please note that this is the published website, by the moment I ask you to use them to look at the backend, please inform me if you want to make any intervention.

#1765207

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello and thank you for contacting the Toolset support.

I tried to login to your website and check these issues closely, but the website is not stable yet. Check this screenshot hidden link

What do you mean that the frontend breaks when you use your custom code? Can you elaborate more, or provide a URL where we can see the issue?

To investigate this issue, I would suggest, activating PHP debugging and trying to reproduce the issue, there may be some logs that will point us in a good direction.
https://toolset.com/documentation/programmer-reference/debugging-sites-built-with-toolset/#php-debugging

I also suggest that we provide you with test site on our platform and let you upload your child theme and Elementor PRO on it. If the issue is reproduced, we can fix it there and then port the solution to your live site.

#1765377

Hi Jamal, thank you for your reply.
I noticed that I gave you an incorrect login URL, I'm sorry, can I send you the correct one via private message?

When I say that the frontend breaks I mean that the browser shows a blank page with an error 500 message ("The page doesn't work. info.centrodimedicina.com is currently unable to handle the request.")

I turned on the debug mode and I got the message:
Notice: Constant WP_POST_REVISIONS already defined in /www/wp-content/plugins/perfmatters/inc/functions.php on line 267 Warning: "continue" targeting switch is equivalent to "break". Did you mean to use "continue 2"? in /www/wp-content/plugins/weepie-framework/src/settings/WpiePluginSettingsProcessor.php on line 446

I have disabled both Perfmatters and Weepie but that didn't solve my problem (now Weepie is again on).

The test site on your platform could be a good idea, anyway, can you give a look at the original site again first?

Thanks,
Nicola

#1765457

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

This logline is only a Notice and should not cause 500 errors. There is probably a different cause out there.

I activated the private reply for you. Please provide FTP access too to let me activate PHP debugging if needed.

#1765497
#1765583

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Thank you Nicola, I was able to login, but I could not reproduce the issue of the frontend crashing or the Elementor editor not working. Would you tell me on which URLs can I see these issues? Or If I need to disable/enable plugins in site/network level to be able to check these issues?

#1765617

Hi Jamal,
at the moment the frontend is working, is Elementor's Editor that is not working. If you try to create a new page hidden link and then select "Edit with Elementor" the page remains blank. After 30 seconds at the right bottom of the screen appears the message "Cannot edit? Enable safe mode" (or similar, in italian it says "Non è possibile modificare? Abilita la modalità provvisoria"). If you click on the green "Enable safe mode" button the page is still unable to load the editor.

If you don't want to create a new page you can open any existing page (you can choose an unpublished page like hidden link).

You don't need to do anything to see this error.

Cheers,
Nicola

#1766015

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Thank you Nicola, I can see the issue now. I also notice some Javascript errors on the console, but I am not sure if that's the cause of this issue. hidden link

We should check if this is not a general bug with both plugins. Please log in to this test site with the following URL hidden link
Then, install Elementor plugins and the TwentySeventeen integration plugin and check if the issue is reproduced. If reproduced, I'll escalate this issue to our 2nd Tier for another evaluation before escalating to our developers.

If the issue is not reproduced, we'll assume that it only happens on your website and we'll need to take a copy of your multisite installation for further analysis. I can temporarily install our version of Duplicator Premium who can take multisite copies.

#1766417

Hi Jamal,
thanks for your assistance, I have been waiting a while to get back to you as we were debugging on multiple fronts. We identified an update issue in Elementor PRO (which was marked as updated even if it wasn't). We replaced the plugin folder by hand and the site started working correctly.

Thank you very much for your kindness, I'm sorry to have bothered you but really all the clues were leading to a compatibility problem between Elementor and Toolset. However, I must say that your test site was fundamental, because when I saw that we could not reproduce the problem I noticed that there was something wrong with the version of Elementor PRO.

Thanks again for your time.
Nicola

#1766745

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello Nicola and thank you for your kind feedback. I am glad, you got this fixed and that I could be of help.

As you no longer need assistance with this issue, I'll have to kindly ask you to mark this ticket as resolved. Feel free to open a new ticket for any other question or issue.

Best regards,
Jamal

#1767841

My issue is resolved now. Thank you!

This ticket is now closed. If you're a Toolset client and need related help, please open a new support ticket.