Skip Navigation

[Resolved] I can’t update the plugin. Says not registered. Error mentions elegant themes(?)

This thread is resolved. Here is a description of the problem and solution.

Problem:
I can't update the plugin. Says not registered. Error mentions elegant themes(?)

Solution:
You should try to update Toolset plugins manully.

You can find the proposed solution, in this case with the following reply:
https://toolset.com/forums/topic/i-cant-update-the-plugin-says-not-registered-error-mentions-elegant-themes/#post-1227797

Relevant Documentation:
=> https://toolset.com/faq/how-to-install-and-register-toolset/#automatic-installation-once-you-have-types-plugin-installed

This support ticket is created 3 years, 7 months ago. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Sun Mon Tue Wed Thu Fri Sat
- 10:00 – 13:00 10:00 – 13:00 10:00 – 13:00 10:00 – 13:00 10:00 – 13:00 -
- 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 -

Supporter timezone: Asia/Kolkata (GMT+05:30)

This topic contains 4 replies, has 2 voices.

Last updated by cantonB 3 years, 7 months ago.

Assigned support staff: Minesh.

Author
Posts
#1227486
Screenshot 2019-04-08 17.36.36.png
Screenshot 2019-04-08 17.36.48.png

I tried unregistering and re-registering my toolset.

When I go to my list of plugins, I see "You must have a valid subscription in order to get upgrades or support for this plugin"

When I go to the toolset plugin management page at hidden link

I see a message " Toolset is registered on this site. Your Lifetime account gives you updates for life." which seems to be in conflict with what i see when I look at my list of plugins.

Mysteriously, if I check the boxes from that management page at hidden link and try to download and update the plugins, I get this error message:

"failed!log in to your Elegant Themes account and navigate to the Account > API Key page. Learn more here. If you still get this message, please make sure that your Username and API Key have been entered correctly ()">"

I wonder if there's a conflict with this updater and the Divi theme I use by elegant themes.

#1227797

Minesh
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello. Thank you for contacting the Toolset support.

First of all - After checking to debug information you shared with us, I found that you are using outdated Toolset plugins. We always recommend running your site with latest stable release plugin version.

*** Please make a FULL BACKUP of your database and website.***
Could you please update ALL Toolset plugins to it's latest official released version. You can download the latest plugin release from your accounts page:
=> https://toolset.com/account/downloads/

We publish the Types 3.0 with the new many to many relationships and we have added the number of new features to this major release almost a year ago.

Please check the following blog:
=> https://toolset.com/2018/05/toolset-post-relationships-release/
=> https://toolset.com/2018/05/when-if-to-migrate-relationships-in-old-toolset-sites/

Before you update the Toolset plugins to latest official release version:
*** Please make a FULL BACKUP of your database and website.***

I suggest you should update ALL Toolset plugins manually for now.
- Deactivate and Delete all Toolset plugins from the plugins page
- Download ALL the latest Toolset plugins you require from your accounts page:
=> https://toolset.com/account/downloads/
- Upload and activate first Types plugin and then you are free to install and activate all other Toolset plugins.

Here is the Doc:
=> https://toolset.com/faq/how-to-install-and-register-toolset/

#1227955

"After checking to debug information you shared with us, I found that you are using outdated Toolset plugins."

🙂 Yes, and did you notice my subject line was "I can't update the plugin."

Not to state the obvious, but of course my toolset plugins are out of date. That is why I am trying to update them.

I think what you are telling me is that the old plugin is buggy and cannot update itself through WordPress, so I will have to manually delete the plugin and just download the installers from my toolset account and use those instead. Correct?

#1227960

Minesh
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

I think what you are telling me is that the old plugin is buggy and cannot update itself through WordPress, so I will have to manually delete the plugin and just download the installers from my toolset account and use those instead. Correct?
==> Its not buggy but the Types plugin you are using currently will not have the latest installer.

Please try to follow the following steps.
- Deactivate and Delete all Toolset plugins from the plugins page
- Download the latest Toolset Types plugins from your accounts page:
=> https://toolset.com/account/downloads/
- Upload and activate first Types plugin using plugins page

Then, as you installed the latest Types plugin, you will be able to install other plugins using installer. Please check the following Doc:
=> https://toolset.com/faq/how-to-install-and-register-toolset/#automatic-installation-once-you-have-types-plugin-installed

#1227973

My issue is resolved now. Thank you!