Skip Navigation

[Resolved] How can I hide the CPT metadata?

This thread is resolved. Here is a description of the problem and solution.

Problem:

The issue here was that the customer wanted to hide the Post meta on his CPTs

Solution:
The solution to this is to inspect the page using the google chrome or your browsers page inspection too to find the html that is displaying the post meta.

Then you will just set it using css to display: none;

So e.g you will add this custom css to your site.

.someclass{
display: none;
}

Relevant Documentation:

0% of people find this useful.

This support ticket is created 6 years, 4 months ago. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Sun Mon Tue Wed Thu Fri Sat
- 9:00 – 12:00 9:00 – 12:00 9:00 – 12:00 9:00 – 12:00 9:00 – 12:00 -
- 13:00 – 18:00 13:00 – 18:00 13:00 – 18:00 14:00 – 18:00 13:00 – 18:00 -

Supporter timezone: America/Jamaica (GMT-05:00)

This topic contains 30 replies, has 3 voices.

Last updated by Francisco Ramón Molina Busquiel 6 years, 3 months ago.

Assisted by: Shane.

Author
Posts
#582397
2017-10-26_16-18-38.jpg
2017-10-26_16-22-49.jpg

With Views I can disable the CPT title, but the metadata is still displayed (Author, Date, Category).
How can I hide the metadata?

Look at the screenshots.

Thanks for your help.

Best regards,
Francisco R.

#582500

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Francisco,

Thank you for contacting our support forum.

Usually you would need to remove the reference from the theme itself , however you can try using this plugin below.
https://wordpress.org/plugins/wp-meta-and-date-remover/

Thanks,
Shane

#582607

I installed this plugin, I tried several configurations, but it does not work, it removes the metadata from my post, but it does not remove them from my new CPT.
Look at the following link:
hidden link

#582833

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Francisco,

Would you mind providing me with admin access to the website so that I can remove the meta data for you ?

The private fields will be enabled for your next response.

Thanks,
Shane

#582842

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Francisco,

Thank you for the credentials however they dont seem to work.

Could you check on this and let me know if it works for you.

Thanks,
Shane

#582846

Sorry, is
hidden link

#582877

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Francisco,

Try commenting out this line in your theme and let me know if the issue still remains.
$show_default_title = get_post_meta( get_the_ID(), '_et_pb_show_title', true );

Thanks,
Shnae

#582941

Although I comment that line in single.php my CPT still shows the metadata, so I've put it back as it was.

#583552

Please, some help with this problem.

#583688

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Francisco,

It seems that we will need to hide it with ssome css. Add this css to your website.

.et_post_meta_wrapper{
display:none;
}

Please try this and let me know if it helps.

Thanks,
Shane

#584409

Shane,
Indeed, this code hides the metadata, but it has a big problem, it also hides the title, the metadata and the featured image of all posts on my site.
This is incorrect. This code can not be used. 🙁

#584587

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Francisco,

I see the issue.

I wrote the css to be more specific and this one should work.

#left-area .post-meta{
display:none;
}

Please let me know if there are any issues.

Thanks,
Shane

#584599

This code is not useful either, since it also hides the metadata of the posts. I just want him to hide the metadata from my new CPT "Historial Versiones".

#584760

Please, I need to solve this problem. The days are passing and it is not solved. 🙁
Thanks for your help.

#586012

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Francisco,

What you're saying is that you only want this CPT to not have the Meta?

Are you using a content template for this cpt ?

Please let me know.
Thanks,
Shane

This ticket is now closed. If you're a WPML client and need related help, please open a new support ticket.