Skip Navigation

[Resolved] forms don't show on mobile when toolset access is active

This support ticket is created 2 years, 11 months ago. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

No supporters are available to work today on Toolset forum. Feel free to create tickets and we will handle it as soon as we are online. Thank you for your understanding.

Sun Mon Tue Wed Thu Fri Sat
- 10:00 – 13:00 10:00 – 13:00 10:00 – 13:00 10:00 – 13:00 10:00 – 13:00 -
- 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 -

Supporter timezone: Asia/Kolkata (GMT+05:30)

Tagged: 

This topic contains 5 replies, has 3 voices.

Last updated by davidZ-4 2 years, 11 months ago.

Assisted by: Minesh.

Author
Posts
#2071887

I am trying to: Display a form on ta page

Link to a page where the issue can be seen: hidden link

I expected to see: on mobile device see the form

Instead, I got: on desktop I can see the form on the page. however when I test the page on my iphone 8 (tried various browsers) the form don't display.
Change the them to default 2021
I deactivated all the plugins and activated only toolset plugins.
found that toolset access plugin is the one that cause this behavior.

#2071907

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Screenshot_20210530-101911_Chrome.jpg

Hello and thank you for contacting Toolset support.

On my Samsung device, I can see the same form as on the desktop. Check the attached image.

Let me see if someone else within the theme has an iPhone to test with and get back to you.

#2072877
2.PNG
1.PNG

Hi Jamal,
The reason you see the form working correctly is because I deactivated the toolset access plugin.
here are a couple of images taken from my phone:
#1 with the plugin activated - the form does not display
#2 with the plugin deactivated - the form display
Please let me know if you need anything from me or can you test it on your testing environment.
Thanks,
David

#2073499

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello David,

I suspected that. Please allow us temporary access to your website so we can test with and without Toolset Access. Personally, I don't have an Apple device, but my teammate has tried with an iPad and he could get the form, most probably because Access is active. Your next reply will be private to let you share credentials safely. ** Make a database backup before sharing credentials. **

#2079205

Minesh
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Jamal is on Vacation. This is Minesh here and I'll take care of this ticket. Hope this is OK.

I see when Toolset Access plugin is active you did not assign the permission to Guest users so that they can access the form.

I've granted the permission to Guest user for the post form you created so that now Guest users also have access to the form.
=> hidden link

More info:
=> https://toolset.com/course-lesson/controlling-access-to-front-end-forms/

#2079669

My issue is resolved now. Thank you!

This ticket is now closed. If you're a Toolset client and need related help, please open a new support ticket.