Skip Navigation

[Resolved] Fatal error with Toolset types version 3.4.1

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Our next available supporter will start replying to tickets in about 6.22 hours from now. Thank you for your understanding.

This topic contains 6 replies, has 3 voices.

Last updated by Luo Yang 1 month, 3 weeks ago.

Assigned support staff: Luo Yang.

Author
Posts
#1800697

I am trying to: upgrade the plugin from 3.4 to 3.41.

Link to a page where the issue can be seen:
Plugin section error displayed
Warning: require_once(/home/divorcecanada/public_html/wp-content/plugins/types/application/bootstrap.php): failed to open stream: No such file or directory in /home/divorcecanada/public_html/wp-content/plugins/types/wpcf.php on line 75

Fatal error: require_once(): Failed opening required '/home/divorcecanada/public_html/wp-content/plugins/types/application/bootstrap.php' (include_path='.:/opt/alt/php74/usr/share/pear') in /home/divorcecanada/public_html/wp-content/plugins/types/wpcf.php on line 75

I expected to see: nothing!

Instead, I got: error message - I reversed to 3.4 and issue is gone... The debug info below is coming from toolset 3.4 not 3.4.1 since 3.4.1 can't be activated without the error abvoe.

#1800723

Christian Cox
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

Hi, it looks like there may have been a problem during the upgrade and some files didn't get copied correctly. As a test, can you please download a copy of Types 3.4.1 from https://toolset.com/account/downloads, then deactivate and delete Types 3.4 from your wp-admin > Plugins area. Then upload the fresh copy of Types 3.4.1, activate it, and test once more. If this doesn't solve the problem, I'll need to take a closer look.

#1802183

Oke after some more digging i found out that it is a combination of the new Toolset blocks and the new Toolset types that gives the error.

If i disable the newest Toolset blocks then i have no error with the newest Toolset types. If i enable the newest Toolset blocks then i can not enable/have the newest types enabled and have to revert to version 3.4 for Toolset types to work.

#1802315

Christian Cox
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

Okay that is unusual. I will be glad to take a closer look if you will provide login credentials and FTP access in the private reply fields here. I will try reinstalling the plugins first, then if the problem is not resolved I can make a clone of your site with the Duplicator plugin and run some additional tests locally without breaking your live site. Let me know if that is okay and I will get started.

#1809423

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

Hello,

I have checked it in your website:
Dashboard-> Plugins-> Add new-> Commercial
hidden link

It works fine, both Toolset Types and Toolset Blocks are the latest version, and there isn't any PHP errors you mentioned above, is this problem resolved?
Please let me know if you need more assistance for it, thanks

#1810125

Hi Luo Yang

I have no idea what Christian did but all seems to work now.

Thanks
Guido

#1810719

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

Christian is sick, you can create new ticket if there is any other issue.