Skip Navigation

[Resolved] Fatal Error when trying to update Access, etc.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 4 replies, has 3 voices.

Last updated by smileBeda 11 months, 3 weeks ago.

Assigned support staff: Shane.

Author
Posts
#1725865

I am trying to:
Update to most current versions of toolset plugins.

I first tried to update all Toolset plugins. Site crashed. WordPress emailed error below. I then restored a backup. Tried updating one at a time. Started with Views. Crashed again. I then restored.

Error Details
=============
An error of type E_COMPILE_ERROR was caused in line 10 of the file /xxx/xxx/xxx/public_html/wp-content/plugins/cred-frontend-editor/application/controllers/compatibility/wpml/integration/forms_translation/legacy.php. Error message: Declaration of OTGS\Toolset\CRED\Controller\Compatibility\Wpml\Integration\FormsTranslation\Legacy::register_strings($form, $form_data) must be compatible with OTGS\Toolset\CRED\Controller\Compatibility\Wpml\Integration\FormsTranslation\Base::register_strings(WP_Post $form, $form_data)

#1726075

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Marge,

From what I see on your site you are using the latest versions of our stable release.

The only update that is available is for an update to the Beta plugins which I do not recommend being used on a live production environment.

At this point there is no need to update your Toolset plugins.

Thanks,
Shane

#1726123

My issue is resolved now. Thank you!

#1790277

This error still happens in the latest release, it should have been investigated, when reported by @margep6083
Now it brought down all sites where Toolset updated automatically or where people updated CRED and Access.

#1792717