Skip Navigation

[Resolved] Fatal error: Uncaught Error: Class after login

This support ticket is created 3 years, 3 months ago. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Sun Mon Tue Wed Thu Fri Sat
- 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 -
- 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 -

Supporter timezone: Asia/Karachi (GMT+05:00)

This topic contains 2 replies, has 2 voices.

Last updated by danB-8 3 years, 3 months ago.

Assisted by: Waqar.

Author
Posts
#2012507

Tell us what you are trying to do?
I am creating a website where people can submit a cabin listing. After registering as a user, when trying to log in, there is an error message.

Fatal error: Uncaught Error: Class 'OTGS\Toolset\Access\Controllers\UploadPermissions' not found in /home/customer/www/cabincritic.co/public_html/wp-content/plugins/types-access/application/models/capabilities.php:613 Stack trace: #0 /home/customer/www/cabincritic.co/public_html/wp-content/plugins/types-access/application/controllers/filters/backend_filters.php(534): OTGS\Toolset\Access\Models\Capabilities->get_capabilities_by_user_permissions(Array, Array, Array, Object(WP_User)) #1 /home/customer/www/cabincritic.co/public_html/wp-includes/class-wp-hook.php(292): OTGS\Toolset\Access\Controllers\Filters\BackendFilters->toolset_access_has_cap_filter(Array, Array, Array, Object(WP_User)) #2 /home/customer/www/cabincritic.co/public_html/wp-includes/plugin.php(212): WP_Hook->apply_filters(Array, Array) #3 /home/customer/www/cabincritic.co/public_html/wp-includes/class-wp-user.php(783): apply_filters('user_has_cap', Array, Array, Array, Object(WP_User)) #4 /home/customer/www/cabincritic.co/public_html/wp-includes/capabilities. in /home/customer/www/cabincritic.co/public_html/wp-content/plugins/types-access/application/models/capabilities.php on line 613

Is there any documentation that you are following?
Been following the video class

Is there a similar example that we can see?
Try to log in at hidden link

What is the link to your site?
hidden link

#2012991

Hi,

Welcome to Toolset support and I'd be happy to assist.

We've seen one other report about this error from a customer whose website was also hosted at SiteGround.
( ref: https://toolset.com/forums/topic/redirection-to-a-404-page-when-limited-access-not-working )

It turned out something related to the server environment and I'll recommend testing this after clearing all involved caches and optimizations at the server and the CDN level.

In case the issue still persists, you're welcome to share a clone/snapshot of the website so that it can be investigated on a different server.
( ref: https://toolset.com/faq/provide-supporters-copy-site/ )

Please let me know how it goes and I've set your next reply as private.

regards,
Waqar

#2015047

My issue is resolved now. Thank you! I think it was just a cache issue.

This ticket is now closed. If you're a Toolset client and need related help, please open a new support ticket.