Skip Navigation

[Closed] Error upon trying to use block editor

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Sun Mon Tue Wed Thu Fri Sat
- 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 -
- 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 -

Supporter timezone: Asia/Karachi (GMT+05:00)

This topic contains 6 replies, has 3 voices.

Last updated by Waqar 1 year, 2 months ago.

Assisted by: Waqar.

Author
Posts
#2505977
Screenshot 2022-11-29 102223.png

Trying to use block editor while editing Views

#2506133

Nigel
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/London (GMT+00:00)

Hi there

Do you have any details about what triggers the error?

Visiting a settings page or editing a post on the back end? View content on the front end?

The "error" you shared is a PHP warning, not the error itself that seems to have occurred.

#2506135
Screenshot 2022-11-29 132824.png

When i try and use the block editor for views from the backend, wordpress gives the error i provided earlier. See screenshot.

#2506149

Nigel
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/London (GMT+00:00)

And you did use the block editor to design that content template?

(I see you have the Disable Gutenberg plugin installed, which would prevent you from editing the template with the block editor.)

What happens if you disable that plugin?

#2506159
Screenshot 2022-11-29 140426.png

Used the view interface and tried to make use of the block editor below it

#2506243

Still get the same error

#2506671

Waqar
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for sharing this update.

I've performed some quick tests on the website and the issue of the content template editing seems to be limited only to this particular template ( 'Loop item in Repository List' ). When I created a new content template using the blocks editor and tried to edit it, that worked as expected.

As a quick fix, you can create a new view with its own content template. If the issue is not faced on the new content template you can delete the old view and content template.

In case, the issue persists, I'll need your permission to download a clone/snapshot of the website, to investigate this on a different server.

I hope this helps and please let me know how it goes.

regards,
Waqar

The topic ‘[Closed] Error upon trying to use block editor’ is closed to new replies.