Skip Navigation

[Resolved] error special characters in the address field and title

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Our next available supporter will start replying to tickets in about 6.61 hours from now. Thank you for your understanding.

This topic contains 9 replies, has 2 voices.

Last updated by federicoA 1 month, 2 weeks ago.

Assigned support staff: Jamal.

Author
Posts
#2190785

Hi,

I have a problem with the map field (address).
when in the address there is a special character (in this case the appostrophes) the map is not stored correctly (Via Contessa Beretta, 19, 34072 Farra D'isonzo GO).
Here is a video that tries to explain the problem.
hidden link
The address is stored correctly but then after updating the page the map no longer appears correctly. even on the site it is not displayed correctly.

I also have a similar problem with the title of a post. if it contains an accent it is not displayed.
thanks
Federico

#2191539

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello Federico and thank you for contacting Toolset support.

I tried to reproduce these issues on a clean install and everything worked as expected. You can log in to my test site with the following URL hidden link
- I was able to add an address with an apostrophe without issues. hidden link
- I was able to add a title with an accent without issues. hidden link

Maybe it is caused, on your website, because of a compatibility conflict, or an encoding issue.

To exclude any possible conflicts, please check if this issue appears when:
- Only Toolset plugins are activated. It will tell us if there is an interaction issue with another plugin.
- The theme is set to a WordPress default like Twenty-Twenty. It will tell us if there is an interaction issue with your theme.
If the problem disappears, start activating one at a time to track where the incompatibility is produced.

If it is an encoding issue, please check if the solution discussed here helps hidden link

If nothing helps find the cause of the issue, I'll need to take a copy of your website, so I can debug it locally or on our online platform without impacting your live users. Let me know if that's fine with you.

#2192747

Hi,

I copied the site to a test area (no media).
hidden link
I deactivated plugin (no toolset), set the default theme and set wp-config.php
be so:
// define ('DB_CHARSET', 'utf8');
// define ('DB_COLLATE', ");
that like this:
define ('DB_CHARSET', ");
define ('DB_COLLATE', ");

but the result hasn't changed.

the address is stored correctly but if I reload the page the map is not displayed correctly:
hidden link

if you want I can give you access to this test area.

thanks
federico

#2192945

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Can I log into this test site and check this closely? Your next reply will be private to let you share credentials safely.

In this last video, you are using the blocks editor. Is it about the same custom post type "Cantine" or another post type?

#2194027

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Because this site is served from the /temp/ folder, I assumed that it is a test site, and I updated the Toolset plugins on it. Please test with the used plugins and themes before applying this update on the production site.

The update did not resolve the issue. And I noticed an error on the Javascript console regarding the Google Maps API key. Check this screenshot hidden link

Geocoding Service: This API project is not authorized to use this API.  For more information on authentication and Google Maps JavaScript API services please see: <em><u>hidden link</u></em>

So, I temporarily registered our own key on the site and the issue was not reproduced. The error was not triggered on the Javascript console.
It seems that you have a missing API in the Google Console dashboard. Toolset Maps plugin requires Maps JavaScript API, Geocoding API, and Places API. Make sure they are all activated on the Google Console dashboard.
https://toolset.com/course-lesson/creating-a-maps-api-key/

Once again, make sure to test your website with all the used plugins and themes before updating the production site. This test site has only Toolset plugins enabled and multiple other plugins disabled.

I hope this helps. Let me know what you will get after updating Maps apis.

#2194839
Schermata 2021-10-13 alle 11.41.11.png
Schermata 2021-10-13 alle 15.20.58.png

hi,
I was able to fix the problem.

I wanted to add the "Application Restrictions" service, setting the HTTP Referrer (websites). If I add the domain as shown in the screen shot, I have the error as shown in the attached photo.
The api key only works if I don't set any referrer.
why do i have this error?

#2196959

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello and my apologies for the late reply, but I do not work on Wednesdays and Thursdays as you may check on my profile page https://toolset.com/forums/users/jamal-b/

The restrictions' setting seems right to me. Maybe it was just not propagated on the network yet. It takes a couple of minutes for a Google Console configuration update to be propagated on Google's network.

I checked one Cantine post and one Location post and the issue seems resolved. Can you check from your side and confirm.

If the issue persists somewhere, please share a direct URL to it, or the steps I should follow to see the issue.

#2196967

Hi,
as I said: if I don't set any http referrer the api key works. When i set urls the api key has problems. I tried to set the url in various ways and also to set the server ip and the api key doesn't work (i also tried to wait many minutes).

I tried to contact google support and they would have advised me to try to enter a second api key. But I also wanted to understand from you what you recommend.
thanks

#2197035

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Well, we do suggest using a second API key as a server-side API on the settings hidden link

Honestly, I do not know what's causing this primary API key to work for your server. The HTTP referrers seem correct to me. But, you seem to use more APIs than the one required for Toolset. I am keen to think that one of those API requires more restrictions or a second API key.

I am sorry, I am not giving you a solution as per se. Google support is the best placed to help you with the restrictions errors. Just keep in mind, that the secondary API key to be used with Toolset, needs to be a server-side API key.

I'll remain at your disposal.

#2197197

My issue is resolved now. Thank you!