Skip Navigation

[Resolved] Editor can’t edit posts even when access is given

This thread is resolved. Here is a description of the problem and solution.

Problem:

Please refer to screenshot, on the left you can see Editor is given full access, but look at the browser on the right, editor was logged in but couldn't edit any post (including custom post types)

If I unchecked "Managed by Access" the editor will be able to edit.

https://toolset.com/forums/topic/editor-cant-edit-posts-even-when-access-is-given/#post-1208871

Solution:

It should be an exception of client's website.

To fix it, please try these:

1) Backup your website database

2) Dashboard-> Toolset-> Export / Import-> Access, import below setting file:

https://drive.google.com/drive/folders/1hkp2EXGUMo-55KLIsPu1qQeci3SQ4DKS?usp=sharing

See screenshot:

https://cdn.toolset.com/wp-content/uploads/2019/03/1209788-import_access_settings.jpg?x83333

This setting file is export from my localhost using a fresh wordpress installation, it should be able to reset the access settings.

Relevant Documentation:

0% of people find this useful.

This support ticket is created 3 years, 9 months ago. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Sun Mon Tue Wed Thu Fri Sat
- 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 -
- 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 -

Supporter timezone: Asia/Hong_Kong (GMT+08:00)

This topic contains 8 replies, has 2 voices.

Last updated by deanL 3 years, 8 months ago.

Assigned support staff: Luo Yang.

Author
Posts
#1208871
Image 2019-03-02 at 21.04.17.png

Please refer to screenshot, on the left you can see Editor is given full access, but look at the browser on the right, editor was logged in but couldn't edit any post (including custom post types)

If I unchecked "Managed by Access" the editor will be able to edit.

What am I missing?

#1209265

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

Hello,

Please try this:
Login as "Editor" user, create a new post, then test again, check if you can edit posts created by other users.

#1209269
Image 2019-03-04 at 16.43.07.png

Hi Luo Yang, I logged in as "Editor", created a new post. I can edit my own post, but all the other existing posts, I still can't edit (see screenshot)

#1209278

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

The problem is abnormal, please check these:
1) In case it is a compatibility problem, please deactivate other plugins, and switch to wordpress default theme 2019, and test again

2) If the problem still persists, please provide database dump file(ZIP file) of your website, also point out the problem page/post URL, I need to test and debug it in my localhost, thanks
https://toolset.com/faq/provide-supporters-copy-site/

#1209628

Hi Luo Yang, I can create a staging copy and grant you administrator access so you can check on it right away. Will that be easier? If yes please activate the private fields so I can enter the login credentials.

#1209777

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

Please provide the credentials and ftp access of your staging site in below private message box, thanks

#1209785

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

Thanks for the details, I can login into your website, will update here if there is anything found.

#1209788

Luo Yang
Supporter

Languages: English (English ) Chinese (Simplified) (简体中文 )

Timezone: Asia/Hong_Kong (GMT+08:00)

editor-role.JPG
import-access-settings.JPG

It is very strange, I can see the problem in your website, and I have tried the same setting in my localhost with a fresh wordpress installation, but there isn't the same problem.

So it should be an exception of your website.

To fix it, please try these:
1) Backup your website database

2) Dashboard-> Toolset-> Export / Import-> Access, import below setting file:
hidden link
See screenshot: import-access-settings.JPG

This setting file is export from my localhost using a fresh wordpress installation, it should be able to reset the access settings.

3) I have tried it in your test site, it works fine, see screenshot: editor-role.JPG

#1209797

Yes! Luo Yang! The problem is fixed now! I'm puzzled how it became a problem, but I'm happy that it's working now! Thank you for being amazing!