Skip Navigation

[Resolved] Download failed. (Forbidden)

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Sun Mon Tue Wed Thu Fri Sat
- 9:00 – 12:00 9:00 – 12:00 9:00 – 12:00 9:00 – 12:00 9:00 – 12:00 -
- 13:00 – 18:00 13:00 – 18:00 13:00 – 18:00 13:00 – 18:00 13:00 – 18:00 -

Supporter timezone: America/Sao_Paulo (GMT-03:00)

This topic contains 17 replies, has 3 voices.

Last updated by Stephen Vaughan 1 year ago.

Assisted by: Mateus Getulio.

Author
Posts
#2583025

I have been having issues with updating Toolset plugins on a number of sites that are all on the same hosting. They seem to be timing out with the message : Download failed. (Forbidden)

This has been happening for over a year now and recently I had my host SIteGround have a look at this and they suggested bouncing it back to Toolset support.

I can do a plugin upload overwrite but it is cumbersome and time consuming with our slow internet here.

Has there been a fix for this and can you help?

#2583055

Nigel
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/London (GMT+01:00)

Hi Stephen

Can you check the installer log for one of these sites to see if it has more details?

Go to Toolset > Settings and click the Toolset Debug Information and Troubleshooting link at the bottom.

On the resulting page click the Installer Support link.

(Or you can access the page directly at wp-admin/admin.php?page=otgs-installer-support.)

There's a button to test the connection as well as a log of previous connection attempts.

#2583081

Hi Nigel,

The connection test passes, so all good there. The log shows that subscription-fetching is working ok but that the attempts to download with the arguments, download/link/key/domain are failing (forbidden).

I also tried the updates with all plugins off and the default TwentyTwentyThree theme applied and still no joy.

#2583313

Mateus Getulio
Supporter

Languages: English (English )

Timezone: America/Sao_Paulo (GMT-03:00)

Hey there,

Thanks for your reply.

I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://toolset.com/privacy-policy-and-gdpr-compliance/#data-shared-with-our-support
**IMPORTANT**

- Please make a backup of site files and database before providing us access.
- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

Please, let me know if you need any additional details. Have a nice day.

#2583675

Mateus Getulio
Supporter

Languages: English (English )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi Stephen,

Thank you for providing the website credentials.

We have enabled the debug mode and checked some logs related to the compatibility between Toolset and php 8:

PHP Deprecated:  Return type of WPV_Settings::offsetExists($offset) should either be compatible with ArrayAccess::offsetExists(mixed $offset): bool, or the #[\ReturnTypeWillChange] attribute should be used to temporarily suppress the notice in /home/customer/www/vaughanprint.com/public_html/wp-content/plugins/toolset-blocks/embedded/inc/wpv-settings.class.php on line 375

We've thought that by updating Blocks manually, the issue would be solved, but unfortunately it didn't happen. Then, we also updated Types manually - still the 'forbbiden' message appears if we try to install another Toolset plugin.

My suspicion is that it could be server related. Therefore, do you allow us to migrate the website to a copy version hosted in our servers? Further, if you're able to get the http server error logs with the SG support, it would be very helpful.

Please let us know about these matters. Thank you.

#2583701

Thanks Mateus,

Go ahead and make a clone. I'll see if I can get those error logs from SiteGround.

I spotted my Chid Theme wasn't activated, stalling was a bit off. Activated now.

Cheers.

#2583729

Hi Mateus,

The only errors in the SG dashboard are the following but I don't think that they relate to Toolset. I had a chat with support and they pointed me to the php_errorlog file in public_html. I am not sure if that is any good to you but you should be able to access it.

Would it have anything to do with php variables, memory, timeout etc?

2023-03-27 15:39:53 UTC [apache][authz_core:error] [pid 15477] [client 144.91.75.156:12136] AH01630: client denied by server configuration: /home/customer/www/vaughanprint.com/public_html/wp-content/index.php

2023-03-26 02:57:08 UTC [apache][authz_core:error] [pid 9743] [client 192.9.143.134:12136] AH01630: client denied by server configuration: /home/customer/www/vaughanprint.com/public_html/wp-content/index.php

2023-03-24 10:42:59 UTC [apache][authz_core:error] [pid 22652] [client 2a05:e880:1000::87a:45f9:12136] AH01630: client denied by server configuration: /home/customer/www/vaughanprint.com/public_html/wp-content/uploads/2022/08/index.php, referer hidden link

2023-03-24 10:42:59 UTC [apache][authz_core:error] [pid 22652] [client 2a05:e880:1000::87a:45f9:12136] AH01630: client denied by server configuration: /home/customer/www/vaughanprint.com/public_html/wp-content/uploads/2022/08/Index.php, referer hidden link

2023-03-24 04:49:59 UTC [apache][authz_core:error] [pid 96381] [client 138.2.237.251:12136] AH01630: client denied by server configuration: /home/customer/www/vaughanprint.com/public_html/wp-content/index.php

#2583985

Hi Mateus,

In case you come to log in to my site this morning and haven't taken a duplicate yet, apologies. I had to intervene and roll back my site to two days ago. I had an issue where any item in my custom post type for Prints was not rendering the featured image, past mid 2016. As an artist, it is crucial that these images in my catalogue are viewable to the public.

This happened before, a number of months ago. I am not 100% sure what cause this. It could be Cloudflare related? SiteGround used to integrate a free Cluoldflare subscription up until six months ago and then removed this in favour of their own CDN. They left us the option to keep the connection to Cloudflare but with responsibility left to us… Some suspicion there.

But…

I just replied the Types update again and the same thing happened, all posts after mid 2016, the featured image doesn't render? I can't remember if this coincided with updates; Toolset, other plugins or WordPress updates?

If you have any insight into this, much appreciated.

#2584005

Ok, I've rolled back again and restored back to everything up to date sans latest Toolset plugins. I'll leave for a few days and see if the issue reoccurs, apply updates to see if it triggers the same thing again.

#2584115

Mateus Getulio
Supporter

Languages: English (English )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello Stephen,

Thank you for the updates.

Indeed, the logs do not seem related to Toolset, perhaps they have something to do with the last issue you brought (about the featured images). But honestly, I can't tell for sure, we would have to debug it further.

About the original problem of this ticket, should we also wait for your feedback, or can we continue checking it? I'm marking your next answer as private again, if you want to provide a new login info.

Please keep us posted. Thanks!

#2584227

Just so you know I have the site installed here locally as well and am working on it as well so I will keep you posted if I find anything as well.

#2584239

I'm seeing the same issues on the local install, no featured images for many of the posts of type print. Possibly related to the WordPress. 6.2 update?

#2584241

I'm going to rollback now for the weekend and relook at this next week. I'll set up to share again with the site in a stable state.

#2584351

Mateus Getulio
Supporter

Languages: English (English )

Timezone: America/Sao_Paulo (GMT-03:00)

Hey there,

In order for us to take a closer look at this issue, I'd like your help creating a package of your website and sending it to us.

Please use the plugin Duplicator(hidden link) to create a full copy of your website so we can take a look at it and see what's causing the issue with the large table.

Please check our tutorial on how to create a Duplicator package here: https://wpml.org/faq/provide-supporters-copy-site/

If you come across problems while creating it, please feel free to ignore(exclude from the backup) both uploads and cache folders.

I'm enabling the proper field for your to share this copy, you'll see it on your next response.

Alternatively, you may use any file sharing service that you prefer and share the link in the ticket(your next response is being marked as private, only you and I have access to it).

Thank you, please let me know.

#2584705

Hi Mateus,

I got to the bottom of my featured images disappearing on most of my posts.

A bit of a shooting oneself in the foot situation here. A while ago I set up a subscriber user for testing a feature. For the life of me I don't know how I managed it (or even why WordPress allowed it to happen) but the new user had the exact profile as my main admin account. Anyway the upshot is when I went to prepare your user access I decided that I should get rid of the subscriber and opted not to merge in content attached to it. Because it was using the same profile as admin, it obviously decided to delete a fair amount of the featured images. I went back again to a known working backup and this time merged the deleted users content into my own admin account. Sorted.

Apologies again for the confusion.

At this stage I have updated everything on my site.

A few things regarding the the issue updating Toolset plugins. On the local install they did update through the normal procedure. Duplicator installer did flag some files to remove, prior to this, which I duly removed on the local install. I am not sure these have had anything to do with preventing updates. These files were as follows:

In wp-contents • .htacces .php.ini
In wp-includes. • .htaccess

I am not sure about the .htaccess files but from comparing with other installs of WordPress the php.ini file in wp-content looks like it might be out of place.

Ultimately if it isn't any of the above I think the problem is hosting/server related and I might nee to get onto SiteGround support again.

I won't do the Duplicator package as our internet her is dreadfully slow for update but if you want to open a private message again next Monday to gain access and use my install of Duplicator to get a backup of the site to examine locally, please do so.

This ticket is now closed. If you're a WPML client and need related help, please open a new support ticket.