Skip Navigation

[Resolved] CRED Post Expiration: Expiration Time Changes When Custom Post Field is Amended

This thread is resolved. Here is a description of the problem and solution.

Problem: On the Post Edit page (back-end), Post expiration date and time is automatically updated when we update the post data OR simply press UPDATE button without changing the post data.

Solution: It is a bug that appeared in CRED v1.8.8 - As of today, this issue will be fixed in CRED v1.9 which means that all future versions starting from CRED v1.9 and later will not have this problem.

If you see this type of issue, please make sure to update your all Toolset plugins to latest versions.

Relevant Documentation: https://toolset.com/faq/how-to-install/

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Tagged: 

This topic contains 5 replies, has 2 voices.

Last updated by julieP 4 years ago.

Assigned support staff: Noman.

Author
Posts
#509743

I have post expiry activated. I've noticed that if the value of a custom field in the post is then amended, the expiry time moves forward 2 hours (without intervention from me).

Please advise

#509774

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi Julie,

Thank you for getting in touch with us. Please make sure you are using all latest Toolset plugins.

1. Can you please share your Debug Information with us so we can see it? I have enabled debug info box for your next reply:
https://toolset.com/faq/provide-debug-information-faster-support/

2. Can you please provide step by step details to reproduce this issue? Preferably with back-end OR front-end screenshots (where you have noticed this issue)

Looking forward to help you.
Thank you

#509790
Image 2.JPG
Image 1.JPG

Hi Noman

All plugins are up to date. This is the site I use to test upgrades prior to live implementation elsewhere. It contains the absolute bare minimum of posts etc and only Toolset plugins.

As already explained, this issue happens when I go to my custom post and change the value of a custom field. I've done this in the backend. Not tried it in the front. Image 1 shows expiry box before I changed the custom field value and Image 2 shows it after updating post.

Thanks

#509854

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hello Julie,

Thank you for providing more details. I am able to reproduce this issue at my end. I have escalated this issue to our 2nd tier support for further review and we will get back to you with an update.

Thank you for your co-operation and patience as we strive hard to resolve this.

#514121

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi Julie,

Hope you are doing great. Just want to send an update. Our development team has fixed this issue and it will be included in the upcoming version of CRED v1.9

Thank you

#514250

Hi Noman

That's excellent news! Really appreciate the update, thank you.

I'll close this ticket now even though CRED 1.9 is yet to be released.