Skip Navigation

[Resolved] Contact Form Submitted to User Accounts in Directory Part 2

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by nicoleR-3 1 month, 1 week ago.

Assigned support staff: Waqar.

Author
Posts
#2163861

Tell us what you are trying to do?
I previously got help creating a CRED contact form and linking it to user accounts. I tried to duplicate the process used for "Trainers" for the custom post type "Stallions" but it did not work. In total, I need to send emails to three different groups of members (Trainers, Stallions, Breeders). I've tried editing only the parts of the PHP code that I was initially told to edit but that gave me a fatal error, so then I replaced all the relevant elements, but the emails are not reaching the designated member email. The email post is being generated when info is entered on the Stallion page, though, as I see can see it under the custom post type I created for the form, it's just not reaching its the email for the user.

Is there any documentation that you are following?
https://toolset.com/forums/topic/contact-form-submitted-to-user-accounts-in-directory/

Is there a similar example that we can see?
See the working form here: hidden link
See form where it is not working here: hidden link
And I have one other category where I need to add a contact form, but haven't set up that page yet.

What is the link to your site?
hidden link

#2164169

Waqar
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting us and I'd be happy to assist.

To troubleshoot this, I'll need to see how the form and the email notifications are set up.

Can you please share temporary admin login details, in reply to this message?

Note: Your next reply will be private and please make a complete backup copy, before sharing the access details.

regards,
Waqar

#2169753

Waqar
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Thank you for sharing these details.

During troubleshooting, I noticed that in the form "Stallion Owner Contact Form", the notification name is set as "Stallion Owner Email Notifications".
( screenshot: hidden link )

But, in the code snippet "stallion-owner-contact-form-notification", the notification name "Stallion Owner Contact Form Notification" is being used.
( screenshot: hidden link )

Please make sure that the same notification name is used in both these locations and then test the form again.

#2170485

My issue is resolved now. Thank you!