Skip Navigation

[Resolved] Avada integration doesn’t work correctly with Avada 6.0.1

This thread is resolved. Here is a description of the problem and solution.

Problem: I see duplicate header areas when using the Avada Integration plugin with Avada 6.0.1

Solution: The Avada Integration plugin has been retired and is no longer under development, so new issues arising from its use will probably not be addressed.

This support ticket is created 4 years, 8 months ago. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Our next available supporter will start replying to tickets in about 0.17 hours from now. Thank you for your understanding.

Sun Mon Tue Wed Thu Fri Sat
8:00 – 12:00 8:00 – 12:00 8:00 – 12:00 8:00 – 12:00 8:00 – 12:00 - -
13:00 – 17:00 13:00 – 17:00 13:00 – 17:00 13:00 – 17:00 13:00 – 17:00 - -

Supporter timezone: America/New_York (GMT-04:00)

This topic contains 11 replies, has 3 voices.

Last updated by markM-7 4 years, 7 months ago.

Assisted by: Christian Cox.

Author
Posts
#1316373
Screenshot at Aug 14 14-15-11.png

Since updating to Avada 6.0 we have seen a fault where the navigation menu on some pages is duplicated. This has been traced to Toolset Avada integration (1.5.3).

You can see that this fault is only on some pages. e.g. hidden link

Disabling the plugin is not an option as the site relies on this.

Can you advise if you are aware of this and do you have a fix planned? I have checked a number of closed support tasks and it seems something similar happened at the last main update of Avada when it went to version 5.0.

#1316397

Hi, I'm not aware of any similar open issues at the moment with the Avada Integration plugin so I'd like to report this to my 2nd tier team. Is it okay for me to create a clone of the site using the Duplicator plugin? That will allow me to run tests locally without causing more problems on the live site.

#1316399

Yes, please do.

I disabled plugins to confirm this was the issue.

Thanks

#1316445

Okay thanks, I'm actually able to replicate the issue on my local environment now that I see how it was set up on your site. The Avada Header Area cell in Layouts seems to be displaying duplicate content. I'm escalating this to my second tier support team for additional investigation. If a workaround is available, I'll let you know ASAP.

#1318607

Okay I have some additional information to share after discussion with the team. The Avada Integration plugin you have implemented has been officially deprecated for some time now and is no longer supported. We wrote about how we updated the scope of Layouts integration with popular page-builder themes like Divi and Avada in our blog back in 2017: https://toolset.com/2017/10/views-2-5-and-layouts-2-1-offer-tight-integration-with-popular-themes/

With that in mind, as Avada's system continues to evolve and diverge from previous versions, more and more compatibility issues will arise with the old integration plugin. Our developers will most likely not continue to address those issues in a plugin that is no longer officially supported. As the problem you've noticed arises when Avada is updated to 6+, the best solution available right now is to downgrade to a previous version of Avada if you want to continue to use the Avada Integration plugin with Layouts.

Let me know if you have questions about this.

#1318765

Thank you for the reply.

Restoring an earlier version of Avada is not possible as the update makes changes to the database.

I wish I could just disable the plugin but that causes another issue and if there is no fix for the Avada Integration plugin then we will have to try to address the other issue. To see this issue, if you still have the copy to work on, please disable the Avada Integration plugin and then take a look at the shop results. Whenever you click on a category or use a tag, the first page of results is blank. Only clicking to go to the next page will show some results. Perhaps you could give me some pointers on how to fix this?

What are my other alternatives? Do I need to rebuild the theme ?

Thanks

Mark

#1319513

On my local copy I was able to fix this by editing the Layout "Layout for Products Listing (original Avada)", to disconnect this Layout from the Product Category and Product Tag Archives. Can you try the same on your live site?

#1320865

Thank you Christian.

Could you give me a little more information on how you did this? I have had a good look at the layouts and don't follow.

Thanks

#1321443

Sure, go to Toolset > Layouts > Templates for Archives tab and edit the Layout "Layout for Products Listing (original Avada)". Click the button "Change how this layout is used" and uncheck "Product categories" and "Product tags" to disassociate this Layout from those archives.

#1322305

Hi guys,

I'm facing the same problem for few days now, since the Avada update from 5.9.1 to 6.0.2.

My setup configuration:
- Avada 6.0.2,
- Toolset Types + Layouts + Views
- Toolset Avada Integration 1.5.2

My website has 3 custom post types using Toolset + Tollset Avada Integration:
hidden link
hidden link
hidden link

The problem is: on these pages, the headers appears twice.

I've already tried some things: disabling the child theme, replacing the header.php on child theme, disabling Avada Integration and trying to manage these custom themes without using header and footer on my parent layout..) But noting has worked..

So I'm here to collaborate and help to find a solution to this problem.
I suppose we need a new version of Toolset Avada Integration.. But I can't find where / if already exists.
Thanks!

#1322759

Thank you Christian. That seems to have worked. I appreciate the time taken on this.

Hey, gustavoF. If you follow the steps in Christian's answer this should work. I, like you, didn't know that work on the Avada plugin had stopped. I'm actually glad that this will be for easier going forward.

#1322761

My issue is resolved now. Thank you!

This ticket is now closed. If you're a WPML client and need related help, please open a new support ticket.