Skip Navigation

[Resolved] wpcf_ added to all images.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 9 replies, has 3 voices.

Last updated by thomasS-11 1 year, 10 months ago.

Assigned support staff: Shane.

Author
Posts
#1111573

Hi Toolset.

I keep getting wpcf_ prefix to all image sizes when i am inserting images in a view.
I read different places in this forum, that this happens when i am using an external image, or if im using a custom image size.

I am not using an external image, nor a custom image size. I'm simply using the default "medium" size, and it is loaded locally from the same site that is is viewed on.

I even chose "Do not keep image proportional" because i don't want Views/Types to interfere with the image, and just simply load it as it is commanded to.

In settings i have disallowed Types to "Allow resizing of remote images" even though they are not even remote.

Either way, it's doing what it is not suppose to. If it is not allowed to resize remote images, it shouldnt do it. And if the image is not remote it shouldnt do it either. So...

#1111716

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Thomas,

Thank you for contacting our support forum.

Were these images added using a custom field ? Also could you send me a screenshot of the issue so that I can know exactly what you are referring to ?

Thanks,
Shane

#1111760

Hi Shane.

The fields are rendered through a View.
I have a view that shows Types Image field. But i keep getting the wpcf version of the image.

#1112220

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Thomas,

Could you send a screenshot of the issue ?

Thanks,
Shane

#1120697

My issue is resolved now. Thank you!

#1138193

This issue is still not resolved.

Views is SO frustrating when it is living its own life. I am using a image with a custom image size "slider" it keeps adding the wpcf_ prefix to the image path. It is not an external image. I just want to show the image in the specified image size without views interference.

#1145841

+1 Having the same problem. Double checked guid of attachments in the database and they match the site url. Image resize settings are unchecked.

#1145874

If outputting the image url via a shortcode, be sure both you have both url=true and output=raw.

#1491207

Thanks for the solution eSaner.

Why is this not documented anywhere? And why even add it in the first place, when i disabled this option in Toolset's settings page?
What good is it even good for, to have the suffix to all images?

#1491391

I'm back at it.. The suggested fix will return the full image size path and not the resized path..
Can't believe i have to re-open a ticket about this issue for the 3rd time now.