Skip Navigation

[Resolved] Woocommerce views prevents sidebars from showing

This support ticket is created 5 years, 6 months ago. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Sun Mon Tue Wed Thu Fri Sat
8:00 – 12:00 8:00 – 12:00 8:00 – 12:00 8:00 – 12:00 8:00 – 12:00 - -
13:00 – 17:00 13:00 – 17:00 13:00 – 17:00 13:00 – 17:00 13:00 – 17:00 - -

Supporter timezone: America/New_York (GMT-04:00)

This topic contains 9 replies, has 3 voices.

Last updated by markM-7 5 years, 5 months ago.

Assisted by: Christian Cox.

Author
Posts
#1149110

I have been working with a client over last year using Avada theme and toolset. Recently, perhaps after an update, the sidebars stopped showing. I have disabled all the plugins and discovered that it is woocommerce views that causes the problem.

Have you had other instances of this happening and if so what is the solution?

Can you advise or take a look please?

#1149311

Hi, can you tell me more about the missing sidebars?
- Which pages are missing sidebars when you activate WC Views? All pages, all product posts, just specific archives, etc?
- If you deactivate all plugins except Toolset and WooCommerce, are the missing sidebars appearing as expected?

#1149761

Hello Christian,

The shop sidebars are missing on all shop pages. Enabling WC Views also stops the header from showing (left side) on shop pages.

If you take a look at hidden link you will see the title DMF Sidebar when WC Views is Deactivated and gone when Active. This is the same for all shop pages.

I have deactivated all plugins and confirmed that it is only when WC views is active and this is not a combination of plugins. I did this by deactivating all plugins less Toolset and then the Toolset plugins until I found the one causing the issue. I then re-activated all plugins and switch on and off WC views to confirm.

Thanks

Mark

#1150115

Thank you, let me ask my 2nd tier support team for some further information about the Avada Integration plugin. I was under the impression that it is no longer necessary, but if I deactivate it several Layouts cells are no longer available. Stand by and I will let you know what I find out.

#1151173

Hello, this is Beda, I had a look at the issue which Christian escalated, and have some feedback.
Since he is off today, I thought I expedite the process, so you do not have to wait until he's back.

- If you disable WooCommerce Views(WCV) (or any other Toolset element needed), the Layouts won’t apply anymore to WooCommerce things. (Same is with Content Templates). You need WCV active, to style or alter WooCommerce things with Toolset.
- If WCV is active and Layouts is active (along with the rest of the required Toolset), then The Layout with ID 1325 is applied to the archive in question (I duplicated the package received from Christian), and that Layout has one cell only:
"WC Products Listing (Integration Plugin) Cell."
That cell does not show sidebars, it shows products, as styled or determined by AVADA, and it will work only if the integration plugin is active as well. It will not produce sidebars.

I tried with the older toolset, namely pre-3.0 release, and there, it does not work any different, as per my knowledge, it never did show sidebars.

Summarizing,
1. On the Duplicate I see the Layout applied to the Archives rendering perfectly fine its contents after steps of replication
2. If you require Sidebars or any other element such as widgets, you can and should use the Widget Area or Widget Cell (or any other cell), or Avada’s Cell “Sidebar/Widgets Area”, in that Layout.

May I ask, if you try to add such cell to the Layout in question on your site, the issue is solved?

Note that disabling Layouts or WCV will just render the theme’s whole default template, which is this case (of fully/legacy integrated AVADA), is completely taken over by Layouts (from header to footer) if applied and active, and that works, as far I see, on the copy.

It might be, that by disabling a plugin, the cells got removed (Specially Widget cells, if you change the Theme, might break).
So that might be the reason, why you assumed the update to be the culprit, instead, the issue would be that the cell (unwantedly) got removed from that Layout?

This is how I fixed it locally, I just added the cell back.

If this does not match the issue you face, I apologise my misunderstanding of the problem and of course will immediately re-iterate according to eventual feedback from you.
Note that the ticket stays in Christian's queue, so my (or his) answer might not be immediate.

#1152636

Hi, I see Beda was able to add some information in my absence. Let me know when you are ready to proceed.

#1153740

Guys,

Thank you both for the input. I couldn't follow Beda's notes and am still a little stuck with this. Beda refers to layout 1325 which we don't have. There is a 1327 which is the layout for pages but the main area is the layout for products which is 18793.

The thing is, this was working up until two weeks ago and has been for some time whilst the client added their products.

Going on to look at the side bar settings and it is for the shop categories that this is most important, we have set up and used the Avada sidebar as suggested but it simply doesn't show unless we disable the WC Views. This design also makes use of the header fixed to the left and this also is removed on the shop pages. Clearly that is less than satisfactory as we lose the search and key information.

Beda suggested that the fix might be as simple as adding the 'cell' back. Perhaps you could let me know where I should be looking to do this and I'll give it a try.

Thanks

#1153979
templates-for-archives.png

Beda refers to layout 1325 which we don't have.
hidden link
It's under the Templates for Archives tab. Screenshot attached here.

Beda suggested that the fix might be as simple as adding the 'cell' back. Perhaps you could let me know where I should be looking to do this and I'll give it a try.
See above for the direct link.

#1155317

Thank you for the information.

I created a clone of the site and worked on that but realised that the clone worked where the original site didn't. I therefore didn't have to make any changes.

As you made a clone of our site I suspect you didn't see the issue we had on our site. Anyway, enough time spent on this and as the clone is working, we can move on from here. We will have to leave this as a mystery.

Thanks for your help. The steps did broaden my understanding of the product and how to fault find.

#1155319

My issue is resolved now. Thank you!

This ticket is now closed. If you're a Toolset client and need related help, please open a new support ticket.