Skip Navigation

[Resolved] Users are not redirected to account page after subscription

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Author
Posts
#1942387

The issue (https://toolset.com/forums/topic/getting-redirected-to-wp-admin-logging-in/#post-1942331) is not solved. We just created a new user (different role from administrator) and again we are not redirected to the account page!

#1943227

Minesh
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello. Thank you for contacting the Toolset support.

Can you please tell me what user you created using what role and also send me access details for admin user as well as the access details for the different user you created for which you claim that redirection is not working.

I have set the next reply to private which means only you and I have access to it.

#1943619

Minesh
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

I'm not sure whats going on at your end.

I loggedin as "mvda" admin user and changed the password for the user "_testaccount_7".

Then I tried to login using "_testaccount_7" in different browser and when I submit the username and password it successfully redirect me to /account-pagina/ page.

Please check the following recorded video: hidden link

#1943701

That's not the issue!

Please refer again to this support ticket: https://toolset.com/forums/topic/getting-redirected-to-wp-admin-logging-in/#post-1942331.
The issue occurs when a logged-out user clicks "inloggen" on this page: hidden link OR clicks the "inloggen" link in the email notification.

#1948853

Minesh
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Do you mean that if a Guest user visits the following page: hidden link

The thing is that, Guest users have to login first to be redirected on their account page. That is why if a Guest user click on "inloggen" button, as the user is not logged in, it offers the login box to login first.

I see in the previous ticket as well, you never mentioned the issue about email notification "inloggen" link.

I hope you understand how the flow works for loggedin and not loggedin user.

#1951103

I understand how the flow works for logged in and non logged in users.
But I guess you don't understand the issue.
New subscribers are still being redirected to the wp-admin page instead of the account page.
I have recorded my action so that you will better understand.
What email address can I send it to because the extension isn't allowed here?
I expect this issue is being reolved by today.

#1951107

Minesh
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

What you can do is you can add your file to any file sharing service like dropbox/google drive and send me the link to download/see it.

And please share new subscriber user login details.

I have set the next reply to private which means only you and I have access to it.

#1951223

Minesh
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

You will require to grant me access to google drive link you shared in your previous private reply.

Can you please grant me permissions so that I can access the drive link you shared.

#1951451

Minesh
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

I checked with the user you shared: _testaccount_2

And when I try to login by clicking on the button "inloggen" on this page: hidden link
- Once I logged in it redirect me on the /account-pagina/ page.

Please check the following video:
- hidden link

The video you shared is it seems for different user and asking for using the strong password as WordPress seems its not strong password. Can you please try to set strong password for your user which you are using for login and check if that helps.

#1951453

You have been granted permission.
The same issue occurs while logging out.
See this recording: hidden link.

#1951455

Minesh
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

The last google drive link you shared, I do not have access to it. Please grant access to it so I can check what you shared.

#1951481

Minesh
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

I suggest better you go with the following plugin and set login and logout redirect URLs:
=> https://wordpress.org/plugins/login-and-logout-redirect/

#1951483

That's because this user has already been successfully redirected to the account page!

1. Create a new user
2. Click "inloggen" on hidden link
3. See that you are redirected to wp-admin instead of the account page
4. Click "uitloggen" (in drop down - account pagina)
5 See that you are redirected to wp-admin instead of the account page

How difficult can it be?!?

#1951557

Minesh
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

This is not related to Toolset at all but the plugin you added "iThemes Security".

On the following page: hidden link
- you will fine section called "Password Requirements" under its settings I disabled the "Strong Password" setting.

See the following screenshot: hidden link

I can able to login now without strong password with newly created user.

#1958265

My issue is resolved now.