Skip Navigation

[Resolved] Unable to change author of CPT as no author dropdown appears.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Our next available supporter will start replying to tickets in about 0.76 hours from now. Thank you for your understanding.

Tagged: 

This topic contains 8 replies, has 2 voices.

Last updated by Shane 7 months, 3 weeks ago.

Assigned support staff: Shane.

Author
Posts
#1477207

I am trying to:
Change the author of CPT posts. I've edited the CPT and made sure the section for author is checked but I still don't see any select change the author when viewing the post?

#1477299

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Jim,

Thank you for getting in touch.

It seems that you may not have enabled the authors on your CPT. If you go to Toolset -> Post Type and edit your CPT.

Go to the section that says "Sections to display when editing XYZ" and enable Authors. Once you have done this you should now see your author options appearing under the "Status and Visibility" section.

Thanks,
Shane

#1477355

Shane, as I said in my original post, I've already done that and it still doesn't appear under Status and Visibility?

#1480901

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Jim,

I'm not able to replicate the issue on my end. Whenever I enable the authors option it shows up.

Would you mind allowing me to have admin access to the website to check on the CPT ?

The private fields have been enabled for your next response.

Thanks,
Shane

#1481383

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Jim,

Thank you for the credentials.

Could you let me know which role this is? Also you are changing the authors of these posts to the users of these roles?

Thanks,
Shane

#1481509

The two users are eagleshores & ncctech - both have the business & member role assigned. I created their cpt for businesses under my admin login. So I'm just trying to get their business cpt posts set so that they are the author of their own posts.

#1483031

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Jim,

I believe with this authors box is that wordpress is looking for user's who are either admin or Authors.

If you add the role of an Author to the users then they will show up.

What seems to work is that I assigned an author role to one of the user and it shows up. Once I removed the author role the user still showed up.

Thanks,
Shane

#1485367

Thanks Shane.

Turns out that rather then give them an additional role Author - I just needed to add Edit Posts and Edit Published Posts rights to the Member role as that is what rights Authors have. Then the user could be assigned as author.

#1486903

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Jim,

I suspected as much. I tried this and it didn't work for me but it could be due to caching on your server that is causing the role information to be updated immediately.

So long as the user retains these privileges then they should show up.

Secondly a good practice that I have is to start with a wordpress default role as a base. This means when I create a new role I copy the privileges from a default wordpress role that I want and expand on it from there.

Perhaps you can try this in the future 🙂

Hope I was able to assist you with resolving this one.

Thanks,
Shane