Skip Navigation

[Resolved] Trying and failing to use Relationships to create Hierarchical dropdowns.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Sun Mon Tue Wed Thu Fri Sat
- 9:00 – 12:00 9:00 – 12:00 9:00 – 12:00 9:00 – 12:00 9:00 – 12:00 -
- 13:00 – 18:00 13:00 – 18:00 13:00 – 18:00 14:00 – 18:00 13:00 – 18:00 -

Supporter timezone: America/Jamaica (GMT-05:00)

This topic contains 7 replies, has 2 voices.

Last updated by Diego Walter Ricciardi 8 months, 2 weeks ago.

Assigned support staff: Shane.

Author
Posts
#2323967

I had a ticket opened about this same issue and I marked it resolved since I could actually use it in a different site.
This dev site has since stopped working too so I tried reopening it didnt let me.
I'll copy:
https://toolset.com/forums/topic/trying-and-failing-to-use-relationships-to-create-hierarchical-dropdowns/

I have the Duplicated site.

#2324259

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Diego,

Would you mind allowing me to have admin access to the website so that I can have a more detailed look at this for you ?

Please where applicable please provide me with a link to an example page where I can see the issue.

I've enabled the private fields for your next response.

Thanks,
Shane

#2325221

I didn't clarify, but it's the archive page, where I'm trying to make a hierarchical search by relationships.

#2325273

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Deigo,

I was able to log into the site but not sure where to look next. I see you mentioned about the archive but can you setup the archive how you want it and then I can go in to attempt to setup the relationship filters?

Thanks,
Shane

#2325279
rel-versiones.jpg

The relationships are as follows:

Fabs (one to many) > Modelos (one to many) > Versiones
then
Products (one to many) > Versiones.

In the block editor if you check the first custom search in the search archive you'll see a custom search by relationships that says Versiones.

It says "no further ancestors are defined" but before in this very site, it let me put the other relationships in a stepped / hierarchical order.
So Fabs > Modelos > Versiones.

#2325303

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Diego,

Thank you for the clarity.

Here is how the relationship filter works.

Which post type do you want the archive to be displaying ? Also which Ancestor filters you want to display ?

It won't be possible to build an archive that encompasses multiple post types and have the ancestor filter. The archive must be specific to one post type that is in the relationship. That's when you can add the ancestor filters for the relationships that are connected to this specific post.

Here is an example below.
hidden link

As you can see on this archive i'm displaying the Modelos post type but i've added the relationship filters for Versiones and Products.

Thanks,
Shane

#2325307

Ok,
I get it. Strange that it worked before.
Thing is, is there a work around you can think of? Because the only one I can see would be to make multiple archives which idk if it's efficient? Perhaps it is and it's even better.
When you say post type what do you mean by that exactly? Do attributes and taxonomies count as post types?

#2325309

My issue is resolved now. Thank you!
I'm sorry I started checking it appears its about custom post archives so I guess it's not that bad!