Skip Navigation

[Resolved] Translating checkbox value

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by matthewC-9 1 year, 2 months ago.

Assigned support staff: Minesh.

Author
Posts
#2107881
wpml-checkbox-not-translated.PNG
wpml-checkbox-setup.PNG
wpml-checkbox-string-translation.PNG

Hi! I have a set of checkboxes I'm trying to translate with WPML. See the attached screenshot for how each of them is set up in the field group. Then they're used in the content template like this: [types field='drive-up-book-drop'][/types].

On the WPML String Translation page, I see the values showing up as a string to translate, in this case

  • Drive-up book drop
  • - see the attached screenshot showing the translation in place.

    It seems like that should handle the translation, but what's showing up on the translated page is still the English version, as in the screenshot with the Servicios header - that's what's there after I've put in the translation shown. What do I need to do differently to get the translated version to show instead?

    #2108177

    Minesh
    Supporter

    Languages: English (English )

    Timezone: Asia/Kolkata (GMT+05:30)

    Hello. Thank you for contacting the Toolset support.

    It should display the translated label but can you please make sure that you added the translation for the correct selected option lable.

    Make sure every label you added is translated. To check this further I will require problem URL and admin access details.

    *** Please make a FULL BACKUP of your database and website.***
    I would also eventually need to request temporary access (WP-Admin and FTP) to your site. Preferably to a test site where the problem has been replicated if possible in order to be of better help and check if some configurations might need to be changed.

    I have set the next reply to private which means only you and I have access to it.

    #2109031

    Minesh
    Supporter

    Languages: English (English )

    Timezone: Asia/Kolkata (GMT+05:30)

    I've followed the below steps to fix the issue:

    1) Copy the following code in WPML->Settings -> Custom XML configuration

    <wpml-config>
        <admin-texts>
            <key name="bcn_options">
                <key name="Hhome_template"/>
                <key name="Hhome_template_no_anchor"/></key>
            <key name="wpcf-fields">
                <key name="*">
                    <key name="data">
                        <key name="display_value_selected"/></key>
                </key>
            </key>
        </admin-texts>
    </wpml-config>
    

    The code is modified and already includes the one added config.

    2)
    Once you place the code there, go to WPML -> Settings -> Multilingual content setup and refresh the page.

    3)
    Now go to WPML->String translation and translate the strings:
    - https://wpml.org/documentation/getting-started-guide/string-translation/
    the domain of strings will be : admin_texts_wpcf-fields and name will be something like this: [wpcf-fields][bookable-rooms][data]display_value_selected

    If there are still issues translating the content follow the below steps:
    - Go to WPML->String Translations
    - At the bottom of the String Translation table, click on “Translate link in admin screens”
    - Search for the strings there and see if you can find it.
    - If you are able to find it, select it and add it using “Add to string translation” button
    - Click on “Return to String Translations”
    - Translate it

    More info:
    => https://wpml.org/documentation/getting-started-guide/string-translation/

    Can you please confirm it works as expected now: hidden link

    #2109253

    Hooray, that worked! Thanks so much for your help.