Skip Navigation

[Resolved] Toolset settings screen not loading

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Tagged: 

This topic contains 11 replies, has 2 voices.

Last updated by Directory 1 month, 1 week ago.

Assigned support staff: Christian Cox.

Author
Posts
#2165017

When ever i load try to click the settings tab within toolset it just shows a blank grey screen. The only way i can view the settings page is if i deactivate toolset blocks and use only toolset types

#2165215

Hello, it sounds like there could be a conflict between Toolset Blocks and another component of the site (like a 3rd-party plugin or theme or custom code snippet), or there could be a server-side error like a low memory problem, or something else unexpected.

Let's try a few troubleshooting steps first:
- Temporarily deactivate all 3rd-party plugins except Toolset Types
- Temporarily activate a default theme like Twenty Twenty One
- Temporarily deactivate any custom code snippets in Toolset > Settings > Custom Code
- Activate Toolset Blocks and test the settings page again.
If the problem has not returned, reactivate your code snippets, theme, and other plugins one by one, testing each time until the problem returns. Let me know if you are able to determine one component responsible for the conflict.
If the problem is still present, let's check for server-side errors by activating server logs. If you are not familiar with PHP logs I can show you how to activate one temporarily during this testing.

Go in your wp-config.php file and look for

define('WP_DEBUG', false);

Change it to:

define('WP_DEBUG', true);

Then add these lines, just after the WP_DEBUG line:

define('WP_DEBUG_LOG', dirname(__FILE__) . 'https://cdn.toolset.com/error_log.txt');
define( 'WP_DEBUG_DISPLAY', false );
@ini_set( 'display_errors', 0 );
define('WP_DISABLE_FATAL_ERROR_HANDLER',true);

Save these changes and use FTP to upload the wp-config.php file back to your server. Test the Toolset > Settings page once again. If any server-side errors are triggered during this process, it will create an error_log.txt file in your site's root directory. Use FTP to look for this file in the same directory as wp-config.php. You may need to click "Refresh" in your FTP browser to see a new file appear. Please download this file to your computer, open it in any text editing software, and copy its contents. Paste those in your next reply for me to review. Once that is done, you can revert the changes you made to wp-config.php and delete the log file using FTP.

#2165879

not sure if this is the right code but fingers crossed it is . . .

<?xml version="1.0" encoding="UTF-8"?>
<FileZilla3 version="3.55.1" platform="windows">
<Queue>
<Server>
<Host>35.214.11.148</Host>
<Port>21</Port>
<Protocol>0</Protocol>
<Type>0</Type>
<User>tester@blurbsearch.com</User>
<Logontype>2</Logontype>
<PasvMode>MODE_DEFAULT</PasvMode>
<EncodingType>Auto</EncodingType>
<BypassProxy>0</BypassProxy>
<File>
<LocalFile>C:\Users\MOP\AppData\Local\Temp\fz3temp-2\wp-config.php</LocalFile>
<RemoteFile>wp-config.php</RemoteFile>
<RemotePath>1 0 15 blurbsearch.com 11 public_html</RemotePath>
<Flags>32784</Flags>
<Size>3072</Size>
<Priority>3</Priority>
</File>
<File>
<LocalFile>C:\Users\MOP\AppData\Local\Temp\fz3temp-2\wp-config.php</LocalFile>
<RemoteFile>wp-config.php</RemoteFile>
<RemotePath>1 0 15 blurbsearch.com 11 public_html</RemotePath>
<Flags>32768</Flags>
<Size>3369</Size>
<Priority>3</Priority>
</File>
<File>
<LocalFile>C:\Users\MOP\AppData\Local\Temp\fz3temp-2\blurbsearch.com-2021-08-12.gz</LocalFile>
<RemoteFile>blurbsearch.com-2021-08-12.gz</RemoteFile>
<RemotePath>1 0 15 blurbsearch.com 4 logs</RemotePath>
<Flags>16</Flags>
<Size>36236</Size>
<Priority>3</Priority>
</File>
<File>
<LocalFile>C:\Users\MOP\blurbsearch.com-2021-08-12.gz</LocalFile>
<RemoteFile>blurbsearch.com-2021-08-12.gz</RemoteFile>
<RemotePath>1 0 15 blurbsearch.com 4 logs</RemotePath>
<Flags>16</Flags>
<Size>36236</Size>
</File>
</Server>
</Queue>
</FileZilla3>

#2165881

<?xml version="1.0" encoding="UTF-8"?>
<FileZilla3 version="3.55.1" platform="windows">
	<Queue>
		<Server>
			<Host>35.214.11.148</Host>
			<Port>21</Port>
			<Protocol>0</Protocol>
			<Type>0</Type>
			<User>tester@blurbsearch.com</User>
			<Logontype>2</Logontype>
			<PasvMode>MODE_DEFAULT</PasvMode>
			<EncodingType>Auto</EncodingType>
			<BypassProxy>0</BypassProxy>
			<File>
				<LocalFile>C:\Users\MOP\AppData\Local\Temp\fz3temp-2\wp-config.php</LocalFile>
				<RemoteFile>wp-config.php</RemoteFile>
				<RemotePath>1 0 15 blurbsearch.com 11 public_html</RemotePath>
				<Flags>32784</Flags>
				<Size>3072</Size>
				<Priority>3</Priority>
			</File>
			<File>
				<LocalFile>C:\Users\MOP\AppData\Local\Temp\fz3temp-2\wp-config.php</LocalFile>
				<RemoteFile>wp-config.php</RemoteFile>
				<RemotePath>1 0 15 blurbsearch.com 11 public_html</RemotePath>
				<Flags>32768</Flags>
				<Size>3369</Size>
				<Priority>3</Priority>
			</File>
			<File>
				<LocalFile>C:\Users\MOP\AppData\Local\Temp\fz3temp-2\blurbsearch.com-2021-08-12.gz</LocalFile>
				<RemoteFile>blurbsearch.com-2021-08-12.gz</RemoteFile>
				<RemotePath>1 0 15 blurbsearch.com 4 logs</RemotePath>
				<Flags>16</Flags>
				<Size>36236</Size>
				<Priority>3</Priority>
			</File>
			<File>
				<LocalFile>C:\Users\MOP\blurbsearch.com-2021-08-12.gz</LocalFile>
				<RemoteFile>blurbsearch.com-2021-08-12.gz</RemoteFile>
				<RemotePath>1 0 15 blurbsearch.com 4 logs</RemotePath>
				<Flags>16</Flags>
				<Size>36236</Size>
			</File>
		</Server>
	</Queue>
</FileZilla3>

#2165917

also the define('WP_DEBUG', false); line wasnt in the wp-configure.php file so i added it

#2166445

This is what my wp-config.php file looks like . . .

<?php
/**
 * A pseudo-cron daemon for scheduling WordPress tasks.
 *
 * WP-Cron is triggered when the site receives a visit. In the scenario
 * where a site may not receive enough visits to execute scheduled tasks
 * in a timely manner, this file can be called directly or via a server
 * cron daemon for X number of times.
 *
 * Defining DISABLE_WP_CRON as true and calling this file directly are
 * mutually exclusive and the latter does not rely on the former to work.
 *
 * The HTTP request to this file will not slow down the visitor who happens to
 * visit when a scheduled cron event runs.
 *
 * @package WordPress
 */

ignore_user_abort( true );

/* Don't make the request block till we finish, if possible. */
if ( function_exists( 'fastcgi_finish_request' ) && version_compare( phpversion(), '7.0.16', '>=' ) ) {
	if ( ! headers_sent() ) {
		header( 'Expires: Wed, 11 Jan 1984 05:00:00 GMT' );
		header( 'Cache-Control: no-cache, must-revalidate, max-age=0' );
	}

	fastcgi_finish_request();
}

if ( ! empty( $_POST ) || defined( 'DOING_AJAX' ) || defined( 'DOING_CRON' ) ) {
	die();
}

/**
 * Tell WordPress we are doing the cron task.
 *
 * @var bool
 */
define( 'DOING_CRON', true );

if ( ! defined( 'ABSPATH' ) ) {
	/** Set up WordPress environment */
	require_once __DIR__ . '/wp-load.php';
}

/**
 * Retrieves the cron lock.
 *
 * Returns the uncached `doing_cron` transient.
 *
 * @ignore
 * @since 3.3.0
 *
 * @global wpdb $wpdb WordPress database abstraction object.
 *
 * @return string|false Value of the `doing_cron` transient, 0|false otherwise.
 */
function _get_cron_lock() {
	global $wpdb;

	$value = 0;
	if ( wp_using_ext_object_cache() ) {
		/*
		 * Skip local cache and force re-fetch of doing_cron transient
		 * in case another process updated the cache.
		 */
		$value = wp_cache_get( 'doing_cron', 'transient', true );
	} else {
		$row = $wpdb->get_row( $wpdb->prepare( "SELECT option_value FROM $wpdb->options WHERE option_name = %s LIMIT 1", '_transient_doing_cron' ) );
		if ( is_object( $row ) ) {
			$value = $row->option_value;
		}
	}

	return $value;
}

$crons = wp_get_ready_cron_jobs();
if ( empty( $crons ) ) {
	die();
}

$gmt_time = microtime( true );

// The cron lock: a unix timestamp from when the cron was spawned.
$doing_cron_transient = get_transient( 'doing_cron' );

// Use global $doing_wp_cron lock, otherwise use the GET lock. If no lock, try to grab a new lock.
if ( empty( $doing_wp_cron ) ) {
	if ( empty( $_GET['doing_wp_cron'] ) ) {
		// Called from external script/job. Try setting a lock.
		if ( $doing_cron_transient && ( $doing_cron_transient + WP_CRON_LOCK_TIMEOUT > $gmt_time ) ) {
			return;
		}
		$doing_wp_cron        = sprintf( '%.22F', microtime( true ) );
		$doing_cron_transient = $doing_wp_cron;
		set_transient( 'doing_cron', $doing_wp_cron );
	} else {
		$doing_wp_cron = $_GET['doing_wp_cron'];
	}
}

/*
 * The cron lock (a unix timestamp set when the cron was spawned),
 * must match $doing_wp_cron (the "key").
 */
if ( $doing_cron_transient !== $doing_wp_cron ) {
	return;
}

foreach ( $crons as $timestamp => $cronhooks ) {
	if ( $timestamp > $gmt_time ) {
		break;
	}

	foreach ( $cronhooks as $hook => $keys ) {

		foreach ( $keys as $k => $v ) {

			$schedule = $v['schedule'];

			if ( $schedule ) {
				wp_reschedule_event( $timestamp, $schedule, $hook, $v['args'] );
			}

			wp_unschedule_event( $timestamp, $hook, $v['args'] );

			/**
			 * Fires scheduled events.
			 *
			 * @ignore
			 * @since 2.1.0
			 *
			 * @param string $hook Name of the hook that was scheduled to be fired.
			 * @param array  $args The arguments to be passed to the hook.
			 */
			do_action_ref_array( $hook, $v['args'] );

			// If the hook ran too long and another cron process stole the lock, quit.
			if ( _get_cron_lock() !== $doing_wp_cron ) {
				return;
			}
		}
	}
}

if ( _get_cron_lock() === $doing_wp_cron ) {
	delete_transient( 'doing_cron' );
}

die();

#2167145

Could this be the error logs we need ?

2021-09-12 12:19:08 UTC [nginx][error] 5062#0: *32595186 openat() "/home/u1019-ja8zfkhjcmks/www/blurbsearch.com/public_html/.well-known/pki-validation/ca3-e62bba999ed542859872264615b41e4d.txt" failed (2: No such file or directory), client: 172.70.9.14, server: blurbsearch.com, request: "GET /.well-known/pki-validation/ca3-e62bba999ed542859872264615b41e4d.txt HTTP/1.1", host: "blurbsearch.com"
‮
2021-09-12 12:19:08 UTC [nginx][error] 5060#0: *32595187 openat() "/home/u1019-ja8zfkhjcmks/www/blurbsearch.com/public_html/.well-known/pki-validation/ca3-e62bba999ed542859872264615b41e4d.txt" failed (2: No such file or directory), client: 172.70.9.14, server: blurbsearch.com, request: "GET /.well-known/pki-validation/ca3-e62bba999ed542859872264615b41e4d.txt HTTP/1.1", host: "blurbsearch.com"
‮
2021-09-12 12:19:08 UTC [nginx][error] 5062#0: *32595189 openat() "/home/u1019-ja8zfkhjcmks/www/blurbsearch.com/public_html/.well-known/pki-validation/ca3-e62bba999ed542859872264615b41e4d.txt" failed (2: No such file or directory), client: 172.70.9.14, server: blurbsearch.com, request: "GET /.well-known/pki-validation/ca3-e62bba999ed542859872264615b41e4d.txt HTTP/1.1", host: "blurbsearch.com"
‮
2021-09-12 08:18:43 UTC [nginx][error] 88455#0: *32285687 openat() "/home/u1019-ja8zfkhjcmks/www/blurbsearch.com/public_html/.well-known/pki-validation/ca3-e62bba999ed542859872264615b41e4d.txt" failed (2: No such file or directory), client: 172.70.9.76, server: blurbsearch.com, request: "GET /.well-known/pki-validation/ca3-e62bba999ed542859872264615b41e4d.txt HTTP/1.1", host: "blurbsearch.com"
‮
2021-09-12 08:18:43 UTC [nginx][error] 88453#0: *32285688 openat() "/home/u1019-ja8zfkhjcmks/www/blurbsearch.com/public_html/.well-known/pki-validation/ca3-e62bba999ed542859872264615b41e4d.txt" failed (2: No such file or directory), client: 172.70.9.76, server: blurbsearch.com, request: "GET /.well-known/pki-validation/ca3-e62bba999ed542859872264615b41e4d.txt HTTP/1.1", host: "blurbsearch.com"
‮
2021-09-12 08:18:43 UTC [nginx][error] 88456#0: *32285694 openat() "/home/u1019-ja8zfkhjcmks/www/blurbsearch.com/public_html/.well-known/pki-validation/ca3-e62bba999ed542859872264615b41e4d.txt" failed (2: No such file or directory), client: 172.70.9.76, server: blurbsearch.com, request: "GET /.well-known/pki-validation/ca3-e62bba999ed542859872264615b41e4d.txt HTTP/1.1", host: "blurbsearch.com"
‮
2021-09-10 02:23:30 UTC [apache][authz_core:error] [pid 56734] [client 20.109.124.185:12136] AH01630: client denied by server configuration: /home/customer/www/blurbsearch.com/public_html/wp-content/index.php
‮
2021-09-10 02:23:30 UTC [apache][authz_core:error] [pid 56734] [client 20.109.124.185:12136] AH01630: client denied by server configuration: /home/customer/www/blurbsearch.com/public_html/wp-content/Index.php
‮
2021-09-09 21:31:30 UTC [apache][access_compat:error] [pid 93352] [client 23.250.4.85:12136] AH01797: client denied by server configuration: /home/customer/www/blurbsearch.com/public_html/xmlrpc.php, referer <em><u>hidden link</u></em>
‮
2021-09-09 21:31:29 UTC [apache][access_compat:error] [pid 93352] [client 104.144.6.231:12136] AH01797: client denied by server configuration: /home/customer/www/blurbsearch.com/public_html/xmlrpc.php, referer <em><u>hidden link</u></em>
‮
2021-09-09 21:31:27 UTC [apache][access_compat:error] [pid 93352] [client 107.152.200.251:12136] AH01797: client denied by server configuration: /home/customer/www/blurbsearch.com/public_html/xmlrpc.php, referer <em><u>hidden link</u></em>
‮
2021-09-09 21:31:26 UTC [apache][access_compat:error] [pid 93352] [client 192.241.96.14:12136] AH01797: client denied by server configuration: /home/customer/www/blurbsearch.com/public_html/xmlrpc.php, referer <em><u>hidden link</u></em>
‮
2021-09-09 20:48:56 UTC [apache][access_compat:error] [pid 86130] [client 104.227.65.144:12136] AH01797: client denied by server configuration: /home/customer/www/blurbsearch.com/public_html/xmlrpc.php, referer <em><u>hidden link</u></em>
‮
2021-09-09 20:48:55 UTC [apache][access_compat:error] [pid 86130] [client 192.198.105.151:12136] AH01797: client denied by server configuration: /home/customer/www/blurbsearch.com/public_html/xmlrpc.php, referer <em><u>hidden link</u></em>
‮
2021-09-09 20:48:54 UTC [apache][access_compat:error] [pid 86130] [client 104.144.169.149:12136] AH01797: client denied by server configuration: /home/customer/www/blurbsearch.com/public_html/xmlrpc.php, referer <em><u>hidden link</u></em>
‮
2021-09-09 20:48:53 UTC [apache][access_compat:error] [pid 86130] [client 104.144.171.55:12136] AH01797: client denied by server configuration: /home/customer/www/blurbsearch.com/public_html/xmlrpc.php, referer <em><u>hidden link</u></em>
‮
2021-09-09 09:34:20 UTC [apache][access_compat:error] [pid 14009] [client 35.214.83.158:12136] AH01797: client denied by server configuration: /home/customer/www/blurbsearch.com/public_html/wp-content/uploads/woocommerce_uploads/, referer <em><u>hidden link</u></em>
‮
2021-09-09 05:08:06 UTC [apache][access_compat:error] [pid 19815] [client 104.144.185.254:12136] AH01797: client denied by server configuration: /home/customer/www/blurbsearch.com/public_html/xmlrpc.php, referer <em><u>hidden link</u></em>
‮
2021-09-09 05:08:05 UTC [apache][access_compat:error] [pid 19815] [client 104.227.6.6:12136] AH01797: client denied by server configuration: /home/customer/www/blurbsearch.com/public_html/xmlrpc.php, referer <em><u>hidden link</u></em>
‮
2021-09-09 05:08:04 UTC [apache][access_compat:error] [pid 19815] [client 198.20.174.114:12136] AH01797: client denied by server configuration: /home/customer/www/blurbsearch.com/public_html/xmlrpc.php, referer <em><u>hidden link</u></em>
‮
2021-09-09 05:08:02 UTC [apache][access_compat:error] [pid 19815] [client 107.175.1.238:12136] AH01797: client denied by server configuration: /home/customer/www/blurbsearch.com/public_html/xmlrpc.php, referer <em><u>hidden link</u></em>
#2167159

2021-09-10 02:23:30 UTC [apache][authz_core:error] [pid 56734] [client 20.109.124.185:12136] AH01630: client denied by server configuration: /home/customer/www/blurbsearch.com/public_html/wp-content/index.php

2021-09-09 05:08:06 UTC [apache][access_compat:error] [pid 19815] [client 104.144.185.254:12136] AH01797: client denied by server configuration: /home/customer/www/blurbsearch.com/public_html/xmlrpc.php, referer hidden link

#2167407

not sure if this is the right code but fingers crossed it is . . .
Not quite, these are FTP logs showing file transfer protocol (FTP) traffic on the server.
Could this be the error logs we need ?
Not quite, these are Apache error log messages but I'm looking for a PHP error log. If you share FTP credentials in the private fields here, I can take a closer look.

This is what my wp-config.php file looks like . . .
Actually this looks like wp-cron.php. Any changes you made in this file should be reverted. Here's the original file contents for the latest WP version: hidden link

A template file for generating wp-config.php is included with the WordPress download package, and it's called wp-config-sample.php:
https://github.com/WordPress/WordPress/blob/master/wp-config-sample.php
You'll see the WP_DEBUG line in the template. Normally you would copy the contents of wp-config-sample.php, paste them in a new file, make changes as needed, and save it as wp-config.php when you are installing WordPress. Then it's uploaded to the server so WordPress knows where to look for the active database.

#2167955

Okay thanks for the update, I see the error message you found in the logs. It is essentially the same as the error message noted in another ticket: https://toolset.com/forums/topic/your-site-is-experiencing-a-technical-issue-toolset-types-502-gateway-errors/
That ticket also involves SiteGround hosting, and it seems that the problem was resolved by disabling Siteground's Ultrafast PHP option. See the final comment from the client in that other ticket:
"It appears that Toolset types is not compatible with Siteground's Ultrafast PHP option.
When I turned this off and used Standard PHP, the site has performed normally."

Can you disable Ultrafast PHP temporarily in the SiteGround hosting control panel and let me know if the problem is resolved?

The other Toolset User experienced other symptoms, like 502 server errors and PHP Fatal Errors. If the only problem you have experienced is in Toolset Settings, I suppose another option is to temporarily disable Siteground's Ultrafast PHP when you need to use Toolset's Settings pages, and re-enable Ultrafast PHP when you're finished adjusting Toolset Settings. I don't have much information available about how Siteground's Ultrafast PHP works from a technical perspective, nor do I have a Siteground site available to test with, so I can only speculate about the effectiveness of this temporary solution. If you'd like to test it out, I can help with any additional troubleshooting necessary. Otherwise, disabling the Ultrafast PHP option for this site may be necessary long-term when using Toolset.

"The Ultrafast PHP setup is enabled by default for all new websites created in hosting accounts with Site Tools. The setup of existing websites can be changed easily from Site Tools > Devs > PHP Manager > PHP Setup."
- From the SiteGround knowledgebase, here:
https://www.siteground.com/kb/ultrafast-php-enable/

Please let me know if you have questions about this and I can try to find more information for you.

#2170053

something seems to have worked plus there was a new update. The ultrafast PHP is still active too.

#2170155

My issue is resolved now. Thank you!