Skip Navigation

[Resolved] Toolset Access interferes with ManageWP's One Click Login

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Sun Mon Tue Wed Thu Fri Sat
- 7:00 – 14:00 7:00 – 14:00 7:00 – 14:00 7:00 – 14:00 7:00 – 14:00 -
- 15:00 – 16:00 15:00 – 16:00 15:00 – 16:00 15:00 – 16:00 15:00 – 16:00 -

Supporter timezone: Europe/London (GMT+00:00)

This topic contains 8 replies, has 2 voices.

Last updated by Alok Sharma 1 year ago.

Assigned support staff: Nigel.

Author
Posts
#2233733
2021-12-01_11-29-10_ManageWP_—_Mozilla_Firefox.jpg

Hi,

I am using MangeWP to manage all my WP sites.

From the past few days, I observed that whenever I click "One Click Login" button in ManageWP dashboard for a particular WP site, I get a layer pop-up with the following message:

The user XXXXXXXXXXX is no longer an administrator of the website. Please select an alternative administrator:

Even though I get this message, I am still logged in to the respective WP site.

I contacted ManageWP support and after some debugging, they asked "Do you perhaps used any plugins that would modify user permissions?".

To debug this problem, I deactivated Toolset Access and the layer pop-up no longer appeared. I then reactivated Toolset Access and started getting the layer pop-up again.

I tried the above on my sandbox site and faced similar issues.

To replicate this issue:

- Add a WP site to ManageWP dashboard.
- At this point, do not install Toolset Access plugin.
- Click "One Click Login" button, and you will be logged in to the WP site.
- Now close or logout of the WP site.
- Install & activate Toolset Access plugin. You can do it right from the ManageWP dashboard.
- Once again, click "One Click Login" button, and you will get the layer pop-up but at the same time you will be logged in to the WP site.
- Now deactivate Toolset Access plugin and repeat the above step. Now you won't get the layer pop-up any more.

#2233791

Nigel
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/London (GMT+00:00)

Screenshot 2021-12-01 at 07.44.17.png

Hi there

First, I couldn't reproduce this.

I just signed up with ManageWP, then added an online site to it.

I found the button shown in the screenshot, and pressing it opens my website dashboard in a new browser tab. I assume that's the action you are talking about.

So I then activated Access on that website, returned to ManageWP and repeated the step of opening the site dashboard, and it worked fine.

I wonder if you made any changes to the normal admin user that you connected to ManageWP, or created that admin user in some way other than through the normal WP UI?

In any case, there is no way that we can debug this, because ManageWP is a hosted online service, it is not a plugin that I can install locally and analyse its code with the normal debugging tools. The only people that can do that are ManageWP themselves.

You are welcome to invite ManageWP to contact us so they can get a copy of Access and we can collaborate with them.

Feel free to give them my email address and I will organise things on this end: nigel.a@onthegosystems.com

#2233801

Nigel
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/London (GMT+00:00)

[updating status]

#2233811
2021-12-01_13-49-31_ManageWP_—_Mozilla_Firefox.jpg
2021-12-01_13-40-50_ManageWP_—_Mozilla_Firefox.jpg

Hi Nigel,

Yes, that is the same button.

I may have forgotten a step or two in between.

After activating Toolset Access, please click the refresh button. It is in the top right corner of the screen, just before your name. Alternatively, it is also located beneath the WP Admin button, next to the Dashboard, the green icon. The only difference between the two is that the 1st method will refresh all the sites and the 2nd method will refresh only the current site.

You have to repeat this step every time you activate or deactivate Toolset Access plugin.

Thereafter, you can click the WP Admin button.

If you are still unable to replicate this issue, then I will pass-on your email address to ManageWP support.

#2234095

Nigel
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/London (GMT+00:00)

I just tried that and it didn't make any difference, I was still able to go from ManageWP dashboard to the site dashboard without seeing the issue.

But as I said above, it doesn't really make any difference whether I can reproduce it or not, inasmuch as it is literally impossible for me to debug problems with ManageWP's hosted service, only they can do that.

So, by all means pass on my email address to ManageWP.

#2234229

Hi Nigel,

It's strange that you are unable to reproduce this issue, and it is happening at my end only for sites where Toolset Access is active.

I have passed on your email address to ManageWP and will let you know as soon as I hear from them.

#2235299

ManageWP's reply:

Our system is configured to work with the default WordPress roles and I had to check with our developers if they would explore working with the custom roles WordPress plugin. As much as we would like to make our system compatible with custom roles, at this moment at least, this isn't on the agenda.

If something changes in the future, we'll make sure to contact you or Nigel regarding this. I apologize for not being able to help more and please let me know if there is anything else we can do for you.

The concern is that this problem is happening at my end but not at your end. If you want, I can provide access to my sandbox site so that you can add it to ManageWP at your end and see if you are able to replicate the issue.

Alternatively, we can ignore this issue for now until more users report this issue.

#2235895

Nigel
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/London (GMT+00:00)

Sorry to sound unhelpful, but as I said above, because this is a hosted Saas service there is absolutely nothing I can do to debug the issue, the only people that can do that are ManageWP themselves, so whether I can replicate the issue or not is purely academic.

All I can suggest is that you ensure the admin users of the site are actual admin users and not some custom role that you have granted admin privileges to.

#2236791

Hi Nigel,

I did a fresh WP installation and encountered the same issue, and I did not even touch any Toolset settings or altered any users in Access or such.

But again, it is strange that you weren't able to replicate the problem at your end, so it is difficult to figure out where exactly the problem is.