Skip Navigation

[Resolved] This page can't load Google Maps correctly.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by Shane 4 months, 3 weeks ago.

Assigned support staff: Shane.

Author
Posts
#2107795

I'm showcasing custom post types on Google Map. It worked till yesterday, now we are getting this error message:
This page can't load Google Maps correctly.

What is the link to your site?
hidden link

Google API key work, it is tested again
hidden link

Also, we are getting this error message in browser console
jquery.min.js?ver=3.5.1:2 Uncaught TypeError: Cannot read property 'Autocomplete' of undefined
at GeoComplete.initGeocoder (jquery.geocomplete.min.js?ver=1.7.0:8)
at GeoComplete.init (jquery.geocomplete.min.js?ver=1.7.0:8)
at new GeoComplete (jquery.geocomplete.min.js?ver=1.7.0:8)
at HTMLInputElement.<anonymous> (jquery.geocomplete.min.js?ver=1.7.0:8)
at Function.each (jquery.min.js?ver=3.5.1:2)
at s.fn.init.each (jquery.min.js?ver=3.5.1:2)
at s.fn.init.$.fn.geocomplete (jquery.geocomplete.min.js?ver=1.7.0:8)
at WPViews.DistanceFilterFrontend.self.initFormFunctionality (views_filter_distance_frontend.js?ver=2.0.8:123)
at WPViews.DistanceFilterFrontend.self.init (views_filter_distance_frontend.js?ver=2.0.8:72)
at new WPViews.DistanceFilterFrontend (views_filter_distance_frontend.js?ver=2.0.8:221)

Can you please advise

Best regards
Sasa Vidakovic

#2107851

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Screenshot 2021-07-06 at 3.02.03 PM.png

Hi Sasa,

Thank you for getting in touch.

I took a look at the link you've provided but the map is loading fine. I'm not seeing the message "This page can't load Google Maps correctly." See Screenshot

Thanks,
Shane

#2107865

Hi Shane, sorry, I fixed the issue. Soon as I turned off the caching option in our hosting environment (wpengine) map started working.

Again, apologies for my late response and thanks for your quick feedback.

You can close this ticket, my issue is solved.

Best regards

Sasa Vidakovic
Deal Studio

#2107867

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Sasa,

Thanks for confirming.