Skip Navigation

[Escalated to 2nd Tier] The Toolset Gutenberg block "Fields and Text" doesn't work correctly

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 13 replies, has 3 voices.

Last updated by Guido 1 year, 4 months ago.

Assigned support staff: Nigel.

Author
Posts
#1542291
toolset-gutenberg-2.jpg
toolset-gutenberg-1.jpg

I am trying to:
Insert the Fields and Text block with lots of text and adding a link to the last part of the text. (word)

Link to a page where the issue can be seen:
Only in the back-end.

I expected to see:
That i am able to select a piece of text and add a link.

Instead, I got:
No option to put in a link or click on the button to add a link.

In the first picture (toolset-gutenberg-1.jpg) you will see that i have an option to input a link if i hover over the insert link.

The section picture (toolset-gutenberg-2.jpg) i have scrolled down to the end of the text and try to hover the insert link. Nothing happens. No option to insert a link.

#1542969

I can insert a link on all lines no matter how long my Fields and Text Block is.
I mean, even it the block is longer than my screen is tall, I can click on insert link, scroll back down to my highlighted word and insert the link

I suggest making sure this as well happens without other plugins and theme twenty-twenty, just to exclude any interference from other plugins or themes

If it persists, can you either provide precise steps about how to replicate the issue you mention, or let me have a look at a duplicate where we can see the issue?
https://toolset.com/faq/provide-supporters-copy-site/

#1545585

Oh that's starnge. I have it on a couple of sites.

I will try a clean install with just toolset and standard theme to see if the issue still exists.

Thanks
Guido

#1546467

It is suspicious that you can see this on many sites, this means I probably miss some simple step, or eventually, you use the same (other) plugin on all those sites, which could cause a conflict resulting in the issue?

Could you share access to such a site, or maybe add a copy of one, so I can see the setup and try to replicate and report the problem, or update you with a resolution?
You can see here how to create a duplicate of a site https://toolset.com/faq/provide-supporters-copy-site/

I can also take a look online, it is however oftentimes easier to do this locally, it also avoids any risk for the online site.

#1549341

I do not seem to have administrative capabilities on the site you shared.
Could you update the user shared to "Administrator" as a role?

Thanks!

#1550231

I am sorry about that.

I changed it to admin for you.

Thanks
Guido

#1550485

Thanks, I was now able to access as Administrator.

I confirmed the issue in the test post.
I can't click any quick tag.
All quick tags are broken, not just the links.

I've deactivated all plugins but Toolset and the issue was not resolved.
I've changed the theme, and also nothing resolved.

What I noticed was, it happens only when you scroll exactly enough to let the quick tag bar "stick" on the top of the screen.
Now, this was not what happened locally! in my previous tests.
Locally, the quick tag bar did not stick and I needed to scroll back up to click the quick tags, which then worked.

I am not sure why this was different than in my install as it is exactly as you outline on my own test sites as well, in this very moment.

Maybe this depends on some setting I am not aware of, or else, but I can now confirm the issue as well in my local install.

I've escalated the problem to the Developers so we can fix it.

Thanks for your patience and help spotting this issue.

#1550617

Oke great!

Happy to hear you could replicate it and the dev team will fix it.

No problem. I love toolset! And will help in any way resolving bugs.

Thanks
Guido

#1612475

Nigel
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/London (GMT+01:00)

Hi there

Today's releases of Views/Blocks should have fixed the issue. Please let me know if you still have problems after updating.

#1615181

Oke great! Thanks!

Guido

#1615327

Nigel
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/London (GMT+01:00)

Great it works? Or Great you will let me know?

#1615347
2.jpg
1.jpg

Tested it our straight away 😉

Yes my problem is solved but still not working correctly..

Before scrolling: See picture 1.

After scrolling: See picture 2.

It hides the first few boxes of the toolbar. So if you scroll down and want to make some text bold for example then you have to select the text, scroll up, click B to make bold.

The top bar should not overlap the bottom bar.

Thanks
Guido

#1616487

Nigel
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/London (GMT+01:00)

OK, thanks for the details. I've sent that to the developers (also, some of the icons are out of alignment I notice).

I'll keep you posted.

#1617407

Oke, great thanks!