[Resolved] Slider not visible on the front end

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 14 replies, has 2 voices.

Last updated by Beda 2 weeks ago.

Assigned support staff: Beda.

Author
Posts
#1465157

I am trying to: design posts loop in view. I'm using blocks to design the view. I used "Repeating field/ gallery" to add a slider on top of the loop. The image attached shows the edit view page and would help you to understand how the loop is designed.

Link to a page where the issue can be seen: hidden link

I expected to see: slider on the front end.

Instead, I got: Except for the slider, the view is working fine on the front end.

#1465169

I further experimented and came to know that the slider is working outside the container field and so it might be not working. The slider is working outside the container!!

#1465297

Beda
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: Asia/Ho_Chi_Minh (GMT+07:00)

That page is edited with Elementor, where a View is inserted to, which is edited here hidden link.

But there is no slider with repeating Images in hat Content Template.
Only single images are used.

Can you share with me the precise backend URL of where you add this repeating fields gallery, and where it displays (or should) in the front end?
Very likely this is a compatibility issue with some other Plugin - because I use the slider with repeating fields as well locally and online without issues, so it could be something caused by another plugin.
You can check this, by (on a staging site or after a good backup) disabling other plugins unless Views and also enabling another theme (for example Twenty-Twenty)

Please let me know the results if you have a chance to test this.

Thank you!

#1465569

Hi Beda,

This is the precise backend URL of the repeating fields gallery: hidden link

This is the URL (See "Our Latest Listings" section) where it displays in the front-end: hidden link

#1465647

Beda
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: Asia/Ho_Chi_Minh (GMT+07:00)

That's the Content Template I linked earlier, however, I see now the gallery, created with the "Repeating Field / Gallery" block.

The front end now also looks much different, I assume the gallery was not there before?
It seems something breaks the layout, there is lots of unexpected white space.

I see that View queries Products, and looking at some samples I see they have repeating field content:
hidden link

You mention that if this is outside a container it works, and I can confirm moving the gallery outside the container solves the layout issue, but the gallery is still not shown.
I can't export those Views for local testing, as those are Block Views.
Can you maybe create a copy of the site, so I can debug this locally without destroying your live site?

You may have found a bug here that appears only in specific templates, so having a local copy of the exact breaking example will help us greatly in replicating, and then fixing the issue in a timely manner.

I have activated a private reply, so you can if possible add such a copy, following the instructions here https://toolset.com/faq/provide-supporters-copy-site/

Thanks!

#1465877
#1465879

Beda
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: Asia/Ho_Chi_Minh (GMT+07:00)

Thanks.

As the document explains, you can just use the Duplicator plugin.

I'm downloading now the package and will see if I can feedback to you some news today already, otherwise it'll be next Tuesday the earliest.

#1465883

Beda
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: Asia/Ho_Chi_Minh (GMT+07:00)

I experience several issues with this site, from performance issues on the gallery and not working gallery altogether.

Seemingly, on this install it simply won't work, despite such galleries working fine elsewhere and on my own online sites.
I also cannot yet spot the culprit, it doesn't seem related to the other plugins or theme

I will have to investigate this in-depth and will feedback as soon as I have better news.

#1465885

I tried to use the slider on localhost and was able to replicate the issue. I will be waiting for your feedback.

#1465889

Beda
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: Asia/Ho_Chi_Minh (GMT+07:00)

You mean, you are able to replicate this issue on a fresh install with just Toolset?
I am trying exactly this - do you have steps for it?

#1465993

No, this is not a fresh install.

I have the same set of plugins on localhost. Before taking this site live, I tried Toolset on localhost with Elementor and other plugins to test its compatibility. I was not able to replicate the issue 100% as it is on the live website. On the localhost, the slider is visible in the frontend but it looks like its broken (see attached).

#1470923

Beda
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: Asia/Ho_Chi_Minh (GMT+07:00)

I think I was able to replicate the issue, or at least, an issue with the Slider.

Something's off with the list it creates - it seems it loses the styles.

I'll update you soon about the further process
It seems to me any other output but the slider works - the slider, however, will present a broken layout.

#1470975

Yes, please look into the matter. Thanks!!

#1473927

Hello Beda,

Was there something you were able to find out?

#1474483

Beda
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: Asia/Ho_Chi_Minh (GMT+07:00)

Yes, I replicated the issue here https://toolset.com/forums/topic/slider-not-visible-on-the-front-end/#post-1470923 and escalated it.
Unfortunately, I could not figure out a solution yet other than not use the slider.

I've added an erratum here for the issue and I'll update you on any progress.
https://toolset.com/errata/slider-output-of-repeating-fields-in-a-blocks-view-is-not-working/