Skip Navigation

[Resolved] Settings missing in WooCommerce Views/Blocks + Views/Blocks

This thread is resolved. Here is a description of the problem and solution.


The issue here is that the user was unsure where the Woocommerce blocks settings were.


The Woocommerce blocks plugin settings can be found at Toolset -> Woocommerce Blocks.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.


This topic contains 2 replies, has 2 voices.

Last updated by Stephen Vaughan 7 months ago.

Assigned support staff: Shane.

Screenshot 2021-02-23 at 11.12.46.png
Screenshot 2021-02-23 at 11.12.11.png

Today I had a bit of a frustrating experience with Toolset WooCommerce Views/Blocks, Blocks and View, or whatever it’s called now. I hope that this is as confusing for you as it certainly was for me!

My story revolves around the small matter of a price field and using the shorcode:


Last year I built this site with a Divi Theme Builder based template for these products:

hidden link the view into like products I hand built it with html/css, the traditional Toolset way.

hidden link

To present the price range I had to install WooCommerce Views so that I could use the shortcode:


Great that works: 

BUT! Anytime WooCommerce Views is enabled, it overrides the view I created with something very generic and Ugly. So, after a bit of digging around, I find the settings panel where there are settings that can be made to kill these overrides. 

The attached screenshot illustrates this. NOTE: I had to go online and search for this image. The settings in the image are NOT necessarily what I am using in case you start making assumptions on what you are seeing.

Although not ideal (every time you disable/enable WooCommerce Views for troubleshooting conflicts, you need to reset these settings again), at least you can go and adjust the settings again.

Fast forward a bit and plugins on the above site get updated to the block versions and everything seems fine. 

Fast forward to today and I am setting up a similar scenario on a new site using the Divi Theme Templates and wanting to use the price shortcode [wpv-woo-product-price] so WooCommerce Blocks is installed and activated. 

BUT! Now I see the template, which should look like screenshot attached: 

Looks like other screenshot attached:

Ok, so off to that settings panel to make adjustments. Thing is, I can’t find it anymore? It seems to have been removed.

Now, I can forgo WooCommerce Views and that shortcode on this new site and find another solution, the only problem is the Leiko Felt site. It seems things are fine for the moment, the settings are holding, obviously somewhere hidden now in the updated plugin.

BUT! What happens if I ever disable WooCommerce Blocks for some reason and then enable it again? I can’t easily go to that settings panel any more because it is gone!!!

I even went and installed the legacy Views plugin, and an older version of WooCommerce Views to see if I could resurrect that settings panel. No luck! It seems it got removed at some stage in the last year.

If there is some custom function I can apply so that I can fix this, it would be much appreciated.



Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Screenshot 2021-02-23 at 9.26.30 AM.png

Hi Stephen,

Thank you for getting in touch.

The settings you are looking have not been removed I can assure you of that. Doing a quick scan on my test site with the latest version of Woocommerce Blocks I can actually see the settings at Toolset -> Woocommerce Blocks. See Screenshot

However you are not seeing this so the normal use case scenario is not being applied for you. Would it be possible to take a look at the site ? As well as to grab a copy of it so that I can test locally in order to identify the issue ?

I've enabled the private fields for your next response.



My issue is resolved now. Thank you!