Skip Navigation

[Resolved] Setting up a new view

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Sun Mon Tue Wed Thu Fri Sat
- 9:00 – 18:00 9:00 – 18:00 9:00 – 18:00 9:00 – 18:00 9:00 – 18:00 -
- - - - - - -

Supporter timezone: Asia/Karachi (GMT+05:00)

This topic contains 15 replies, has 2 voices.

Last updated by Waqas 2 months, 2 weeks ago.

Assigned support staff: Waqas.

Author
Posts
#2463507

Waqas
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for your patience on this. I was able to fix the issue by following this errata https://toolset.com/errata/checkboxes-that-save-0-are-interpreted-as-checked-by-views/.

As you see, it suggests to set Checkboxes field's "Save option" to:
- When unchecked, don't save anything to the database

Instead of:
- When unchecked, save 0 to the database

So I edited the field group and changed that for the Partner Awards field. After that I simply added a few new Partners while selecting only one value (i.e. for 2021 or 2022) and now I can see these being displayed correctly on their corresponding pages.

Now you need to update all your posts so to reflect the new settings of the custom field (i.e. open one by one, select only one value and save). Or you can search for a 3rd party tool or script to do this for you.

However, as a trick, for all the Partners in 2021, you may not need to open these and save. Or in other words, for the partners which have both values selected, will always be displayed in 2021 list. Because checkboxes fields are serialized and very complex and 2021 option comes before 2022 and is saved that way. So conditional finds 2021 and exits the condition and doesn't even look for 2022.

Considering this in mind, you 'll only need to edit partners having 2022 selected as an option. Here you only need to select one option (i.e. 2022) and keep this point in mind for next year and the years to come.

I hope the issue is resolved now, please check and confirm.

Have a great weekend!