Skip Navigation

[Resolved] RE: CPT URL does not include categories

This support ticket is created 2 years, 3 months ago. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

No supporters are available to work today on Toolset forum. Feel free to create tickets and we will handle it as soon as we are online. Thank you for your understanding.

Sun Mon Tue Wed Thu Fri Sat
- 10:00 – 13:00 10:00 – 13:00 10:00 – 13:00 10:00 – 13:00 10:00 – 13:00 -
- 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 -

Supporter timezone: Asia/Kolkata (GMT+05:30)

This topic contains 1 reply, has 2 voices.

Last updated by Minesh 2 years, 3 months ago.

Assisted by: Minesh.

Author
Posts
#2326603

Hi there,

I have a CPT of of Explore with a taxonomy assigned to it > Explore > Nature > Post

However, I can't get the category to show in the URL. It just shows CPT > Post

When adding a normal WordPress post, it shows the full URL including the categories the post is in, in order, before the actual post name

I've tried adding /%category%/%postname%/ in the WordPress > Permalink settings

Is there some reason why it's not working?

Many thanks

#2326633

Minesh
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello. Thank you for contacting the Toolset support.

There is no such feature offered by Toolset to build such pretty permalinks.

You should try to use the following plugin that will help you to resolve your issue:
- https://wordpress.org/plugins/custom-post-type-permalinks/

Following post may help you as well.
- hidden link

This ticket is now closed. If you're a Toolset client and need related help, please open a new support ticket.