Skip Navigation

[Resolved] Product links are missing when Woocommerce Views is enabled.

This thread is resolved. Here is a description of the problem and solution.

Problem: All Links to Products are broken, if you activate WooCommerce Views.

Solution: This was a BUG in WooCommerce Views and is solved as for WooCommerce Views 2.6.4

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Our next available supporter will start replying to tickets in about 0.42 hours from now. Thank you for your understanding.

This topic contains 5 replies, has 2 voices.

Last updated by erwinH 4 years, 4 months ago.

Assigned support staff: Beda.

Author
Posts
#405324

I am trying to: Make product links work.

I visited this URL: hidden link

I expected to see: Working product links.

Instead, I got: Missing A HREF Tags.

Hello,

I encountered a strange problem where all the product links are missing on product archive pages. They have worked before. I'm not using a custom template, but the default WooCommerce Plugin Default Archive Template, without modifications. Please compare the screenshots.

#405373

This should be addressed already in our upcoming WooCommerce Views release.
We fixed the BUG recently.

To confirm it, I would like to test this on your site as well, as the more tests, the safer the release will be.

Could you send me a sites snapshot if possible.
We usually recommend the free Plugin "Duplicator" for this porpoise.

If you already know how Duplicator works
(http://wordpress.org/plugins/duplicator/),
please skip the following steps and just send me the installer file and the zipped package you downloaded.

★ Duplicator Instructions
hidden link
Send me both files (you probably want to use DropBox, Google Drive, or similar services, as the snapshot file will be quite big)

❌ IMPORTANT ❌
Remember to create or keep an admin account for me before creating the snapshot, or I won't be able to login. You may delete the new admin account once the snapshot has been built.

I will enable your next answer as private so you can provide me the information securely.

#405381

I do not need the duplicator anymore.
Please test the new WooCommerce Views downloadable here:
https://toolset.com/account/downloads/

As always please first backup your Site or test on a Development Server.

Let me know if it's fixed.

#405391

Testing new version now.

#405392

Please let me know if it's solved for you too.
Thank you.

#405393

Problem solved with new Woocommerce version. Thanks!