Skip Navigation

[Resolved] Product image not appearing in Product category view (woo. prod. cat.)

This support ticket is created 5 years, 8 months ago. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Sun Mon Tue Wed Thu Fri Sat
- 7:00 – 14:00 7:00 – 14:00 7:00 – 14:00 7:00 – 14:00 7:00 – 14:00 -
- 15:00 – 16:00 15:00 – 16:00 15:00 – 16:00 15:00 – 16:00 15:00 – 16:00 -

Supporter timezone: Europe/London (GMT+00:00)

This topic contains 1 reply, has 2 voices.

Last updated by Nigel 5 years, 8 months ago.

Assigned support staff: Nigel.

Author
Posts
#524072
image-not-showing.JPG
image of code.JPG

This site was presenting everything correctly. Then I updated the WP-TOOLS plugins and WordPress to 4.7.
All still works except for the Product image is not showing on the WooCommerce pages. You can click and view the larger image, but the product image cannot be see on the page.

Insight as to what happened and how to fix would be great.
Thanks.

#524141

Nigel
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/London (GMT+00:00)

Hi Daniel

I think you must also have updated WooCommerce to version 3.x, too.

Version 3 was a major change and it introduced a number of breaking changes, one of which is that the product images had an initial opacity of 0 (so that they were on the page but invisible).

We have made updates to our WooCommerce Views plugin to reflect these changes, and released a new version on Friday (2.7.2) which should have fixed this issue.

Can you make sure you have updated to this latest version, and then re-test?

If you are still having problems, let me know.