Skip Navigation

[Resolved] PHP error in the WordPress admin area

The Toolset Community Forum is closed, for technical support questions, please head on to our Toolset Professional Support (for paid clients), with any pre-sale or admin question please contact us here.
This support ticket is created 5 years, 10 months ago. There's a good chance that you are reading advice that it now obsolete.
This is the community support forum for Types plugin, which is part of Toolset. Toolset is a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients and people who registered for Types community support can post in it.

Sun Mon Tue Wed Thu Fri Sat
- 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 -
- 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 -

Supporter timezone: Asia/Hong_Kong (GMT+08:00)

Tagged: 

This topic contains 5 replies, has 2 voices.

Last updated by mattM-11 5 years, 10 months ago.

Assisted by: Luo Yang.

Author
Posts
#631474

When I'm on the updates page in the WordPress admin area, I see the following error repeated probably a hundred times:

Warning: Invalid argument supplied for foreach() in /full/path/tol/wp-content/plugins/types/plus/installer/includes/installer.class.php on line 1585

On another site that also uses the plugin, I get the same error (on the same page, repeated a hundred times, but with a different line number):

Warning: Invalid argument supplied for foreach() in /homepages/2/d524139772/htdocs/domains/humancapitallab.org/wp-content/plugins/types/plus/installer/includes/installer.class.php on line 1585

This seems to have popped up as a result of the latest WordPress update. I did not see the last time I updated.

#631791

Hello,

According to the debug logs you provided above, there should be some connection problem between your web server and Toolset server, I suggest try these:

1) Upgrade the Types plugin manually

2) Disable the automatic update feature of Types plugin by this:
Add below line in your wp-config.php:

define("OTGS_DISABLE_AUTO_UPDATES", true);
#631977

I added that code to my wp-config.php file. I still get the error messages.

#632163

Please try these:
1) You are using an outdated version of Types plugin 1.6.6.2 with the latest version of WordPress 4.9.5, that will conduct some unexpected problem, you can download the latest version of Types plugin 2.2.22 here:
https://toolset.com/home/types-manage-post-types-taxonomy-and-custom-fields/

Backup your website, update Types plugin, and test again.

2) If the problem still persists, please provide a test site with same problem, we need a live website to test and debug. thanks

#637896

In case it is a compatibility problem of your website, please check these:

1) deactivate other plugins and switch to wordpress default theme, and test again

2) If the problem still persists, please provide a copy of your website, also point out the problem page URL
https://toolset.com/faq/provide-supporters-copy-site/
You can put it into your own google drive disk, and share the link in the "private detail box", I need to duplicate same problem and debug it in my localhost, thanks

#648995

Deactivating all plugins except Types and switching to a default WordPress theme didn't change anything. The errors still show up on the admin page that lists the plugins. I've already stated that I cannot provide access to this site for security reasons. Since you can't fix this without access to our site, I added code to suppress the error messages for now.

The forum ‘Types Community Support’ is closed to new topics and replies.

This ticket is now closed. If you're a WPML client and need related help, please open a new support ticket.