Skip Navigation

[Resolved] More control over displaying a Content Template needed

This support ticket is created 2 years, 7 months ago. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Sun Mon Tue Wed Thu Fri Sat
- 9:00 – 12:00 9:00 – 12:00 9:00 – 12:00 9:00 – 12:00 9:00 – 12:00 -
- 13:00 – 18:00 13:00 – 18:00 13:00 – 18:00 14:00 – 18:00 13:00 – 18:00 -

Supporter timezone: America/Jamaica (GMT-05:00)

Tagged: 

This topic contains 9 replies, has 2 voices.

Last updated by russellH-3 2 years, 7 months ago.

Assigned support staff: Shane.

Author
Posts
#1592879

Tell us what you are trying to do?
I created a Content Template that I want to only use on certain Pages to achieve a particular layout. In the Usage section for this I chose Pages, but I didn't press 'Apply to all Pages'.

In practice what I'm finding is that some of my Pages, which I never intended to change, are suddenly using this new Content Template. I have to go through and manually change the Content Template to None which is kind of a pain on a large site like ours. It's like a game of whack-a-mole. Is there any way I can have more control over the Content Template sot that it doesn't appear on *every* Page?

Is there any documentation that you are following?
No

Is there a similar example that we can see?

I've had to make me Content Template a draft so it's stop applying itself to Pages on my site. But here are some screengrabs of my setup:

hidden link

What is the link to your site?

cartoonstudies.org

#1592903

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Russell,

Thank you for getting in touch.

One workaround to this is that you can delete the content template completely. This will remove it from all your pages. Then you can re-create that exact content template.

When you're creating a content template ensure that you DO NOT select a post type that it should be applied to.

This will in turn allow you to go to your individual posts and allow you to apply the template to only the posts you want it to be applied to.

What this will do is to alleviate any accidental applying of the template to all your posts.

Please let me know if this helps.
Thanks,
Shane

#1593037

Hey Shane:

Thanks for that, very helpful. I didn't think to just untick Pages from the Usage options — whoops!

That's solved my issue. Now how do I choose my Content Template for those Pages I *do* want to apply it to? Now that I've un-ticked Pages from Usage, a Content Template dropdown no longer appears in my sidebar when I make a new Page.

Thanks for your help.

Cheers, Russell

#1593117

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Screenshot 2020-04-20 at 1.31.04 PM.png

Hi Russell,

Not sure why you're not seeing this in the side pane like I am in my screenshot.

This appears for me even there is no template available.

Would it be possible for me to get admin access to see what is happening here ?

Thanks,
Shane

#1594479

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Russel,

I'm not sure which template was attached to this post.

Could you check where the trash of your Content templates?

Unless the page is exactly as it i in your screenshot then i'm not able to fully say what the issue is or point in the direction to resolve it.

I also see that you have our Layouts plugin installed so could you check the trash for layouts as well ?

Thanks,
Shane

#1594485
Screenshot 2020-04-21 at 16.20.24.png

Hey Shane:

I managed to get back to the Content Template editing screen in my browser history. I then published the Content Template seen in the attached pic. That's the one I'd like assigned to this page: hidden link

I went back into the Page (hidden link) and I still don't see Content Template as an option in the sidebar. 🤷‍♀️

Does that help at all?

R

#1594537

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Russell,

Given that this is a content template we are working you will need to disable the Layouts plugin, which i've already done.

Whenever you have Layouts enabled you won't be able to select the content templates as Layouts overwrites this.

Please let me know if this helps.

Thanks,
Shane

#1594621

Hi Shane:

I see. Thanks for resolving that and letting me know. I can now see the Content Template selector in the sidebar.

So what does this mean for pages (we have a fair few) that were build in the old Layouts method. If we want to do any significant editing of these we'll have to rebuild them? Or can we momentarily re-activate the Layouts plugin, or will that cause other problems?

Cheers, R

#1594819

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Russel,

"So what does this mean for pages (we have a fair few) that were build in the old Layouts method. If we want to do any significant editing of these we'll have to rebuild them? Or can we momentarily re-activate the Layouts plugin, or will that cause other problems?"

Currently if you have Layouts enabled you won't be able to select your content templates. However if you already have a content template assigned to a post then activating layouts would not interfere with that post, however the option to assign a content template to a post will no longer be available.

So yes you can momentarily activate the Layouts plugin if you so choose to. However I will highly recommend remaking your layouts as content templates.

Thanks,
Shane

#1595471

Hey Shane:

OK, that makes sense, thanks. Hopefully we can phase out these old Layout pages with time anyhow. I appreciate your help on all this.

Kind regards, Russell