Skip Navigation

[Resolved] mobile menu button not working with twentysixteen integration

This support ticket is created 7 years, 1 month ago. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Sun Mon Tue Wed Thu Fri Sat
- 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 -
- 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 -

Supporter timezone: America/Toronto (GMT-04:00)

This topic contains 8 replies, has 3 voices.

Last updated by COOP2016 7 years, 1 month ago.

Assisted by: Meagan Hanes.

Author
Posts
#514605

I am trying to: access the menu button when in mobile screen size

I visited this URL: hidden link

I expected to see: a menu button that works and expands when clicked on when the screen is narrow

Instead, I got: it does nothing - if I deactivate the twentysixteen theme layout the button works fine but of course none of my layouts that I set up will work.

I'm using all the latest plugins and this is the only plugin that causes it work when deactivating it.

thanks
Eric

#514929

Hi there! Sorry to hear you're experiencing this issue.

I've enabled Debug Information for this thread - if you could please follow the instructions here (https://toolset.com/faq/provide-debug-information-faster-support/) this will give me more information about your WordPress setup etc.

I attempted to visit the site but was met with a DNS issue - this is confirmed by hidden link which reports your site is currently down. Please let me know when it is back up and we can proceed with troubleshooting.

Thanks,
Meagan

#514971

I've attached the debug information but the site is not down I spelled it incorrectly when it gave it to you before. The correct link is hidden link

cheers,
eric

#515344

Thanks for the corrected link Eric!

I've had a look at the site and can confirm that the problem exists - the Menu button does not toggle the dropdown menu correctly.

However, it's strange that this would occur - as I've built many sites with Toolset and Twenty Sixteen before, without having this problem. Thus, I believe one of your other plugins might be causing the conflict.

Could you please disable all non-Toolset plugins and see if the problem still occurs? If the problem persists, I'll open a private reply for your website login details so that I can take a closer look myself. Otherwise, simply re-enable each plugin one by one and test the menu button - you'll see which plugin is causing the problem. Once we know that, we can begin working on a solution.

Thanks for your help in figuring this problem out!
Meagan

#515375

I've tried disabling all other plugins and still the same problem, it's only when I disable the twentysixteen integration plugin that it works and as soon as I reenable it it doesn't work.

i'm just going to remove that plugin as I don't have time to wait, I have it working on another site without a problem so I know it can work, and will probably redesign that other website to not use it as well as I can't afford for it to stop working as well.

thanks

#515406

Aha! So it's the Toolset TwentySixteen plugin that is causing the issue, gotcha! I'll talk with the developers right now.

Since the WordPress code ecosystem changes so fast, we do our best to stay on top of things like this, and always recommend using Staging servers for testing updates and development etc so that the client's site is never jeopardized.

Disabling Toolset is certainly an option, but not one I would personally recommend in this case. However, you do as you see fit 🙂

I'll reply back here with an update regarding this bug once I'm able to find out more about it. Since I'm hearing you won't be using Toolset on your site, would you be able to make me a copy using the Duplicator plugin (hidden link) before you disable it? I'll open a private reply where you can share a Dropbox URL of the site backup. This will let our dev team find the error much easier.

Thanks,
Meagan

#515415

I think I mentioned it was the twentysixteen integration plugin at the start - and i'm not removing toolset as have too much entrenched in it, just removing the twentysixteen integration but I see without that not much of your layout stuff works either without it so i'm sort of stuck at this point.

I've reactivated it to make you a copy but not sure exactly how to run the duplicator software or where to answer your personal reply.

#515815

Don't bother I've now switched to twentyseventeen theme where the button seems to work.

#597742

Hi there I have the same issue and rather than raise a new ticket, I was wondering if there had been any update on this issue for twenty sixteen. My menu button does not toggle.

This ticket is now closed. If you're a Toolset client and need related help, please open a new support ticket.