Skip Navigation

[Resolved] Layouts Admin Page Blank

This support ticket is created 6 years, 2 months ago. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Sun Mon Tue Wed Thu Fri Sat
- - 14:00 – 20:00 14:00 – 20:00 14:00 – 20:00 14:00 – 20:00 14:00 – 20:00
- - - - - - -

Supporter timezone: Asia/Ho_Chi_Minh (GMT+07:00)

This topic contains 10 replies, has 4 voices.

Last updated by Beda 5 years, 9 months ago.

Assisted by: Beda.


I am trying to: edit layouts

Link to a page where the issue can be seen: /wp-admin/admin.php?page=dd_layouts

I expected to see: something I could edit

Instead, I got: nothing!


Please update all Plugins, WordPress and the Theme, after performing a backup of your site.

if then the issue still persist, please let us know, and if possible tell us what you see if you enable WP Debug in the wp-config.php file as well:

Eventually the issue is due to a PHP error that we can then see.


I tried earlier and lots of things "broke" so rolled back 🙁 I know is well out of date, but not got the time to sort it out properly at the moment.


I tried just to update Layouts and got the following issue:

Could not copy file. layouts/vendor/toolset/toolset-common/res/css/toolset-admin-notices.css


I have now managed to update plugins, but the issue persists



Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)


As Beda mentioned could you enable the wordpress debugging by following the instructions in the link below

This way we can know the exact errors that are being displayed on this page.



Ok.... Got the following Fatal error:

Call to undefined method WPDD_layout_tabs_cell_factory::build() in /home/h2mcouk/public_html/wp-content/plugins/layouts/classes-auto/cells/wpddl-layout-cell-types.php on line 116



Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)


Would it be possible to get FTP access to the site ?

I've enabled the private fields once more.



I'm having the same issue. Enabling debugging produces the following:

WordPress database error: [Duplicate entry '21067e486719b89ae2cb92ddb618ec9b' for key 'uc_domain_name_context_md5']
INSERT INTO `fq_wp_icl_strings` (`language`, `context`, `gettext_context`, `domain_name_context_md5`, `name`, `value`, `status`) VALUES ('en', 'Formats', '', '21067e486719b89ae2cb92ddb618ec9b', 'Date Format', 'F j, Y', '0')

Fatal error: Uncaught exception 'Exception' with message 'Could not add String with arguments: value: F j, Y allow_empty_value: language: en' in /home/frenchqu/public_html/wp-content/plugins/wpml-string-translation/classes/filters/class-wpml-register-string-filter.php:167 Stack trace: #0 /home/frenchqu/public_html/wp-content/plugins/wpml-string-translation/classes/filters/class-wpml-register-string-filter.php(141): WPML_Register_String_Filter->save_string('F j, Y', false, 'en', 'Formats', '', 'Date Format') #1 /home/frenchqu/public_html/wp-content/plugins/wpml-string-translation/inc/functions.php(210): WPML_Register_String_Filter->register_string('Formats', 'Date Format', 'F j, Y', false, '') #2 /home/frenchqu/public_html/wp-content/themes/fq/functions.php(113): icl_register_string('Formats', 'Date Format', 'F j, Y') #3 [internal function]: translate_date_format('F j, Y') #4 /home/frenchqu/public_html/wp-includes/class-wp-hook.php(288): call_user_func_array('translate_date_...', Array) #5 /home/frenchqu/public_html/wp-inc in /home/frenchqu/public_html/wp-content/plugins/wpml-string-translation/classes/filters/class-wpml-register-string-filter.php on line 167

I have attempted repeatedly to delete the "Date Format" string under Formats in WPML String Translation. I have also tried to remove this row from the database manually. However, it consistently gets recreated after every deletion. Rolling back to version 2.7.2 of the WPML String Translations plugin fixes the issue. I will cross-post under WPML support as well.


@kasiag I do not see how the error you report is related to the one handled in this thread:

Please open a new ticket with your issue:
- Add a step by step description how we can replicate the issue
- If possible, add a copy of your site:

@pickup Shane will re-open this ticket and interact with you ASAP.


@pickup I am still waiting for your data

The website you shared still has 17 updates to perform and within them are Toolset.
I am not sure if you cannot update because of the issue you reported here, or if that is resolved?
You cannot update one Plugin, of Toolset, but not another.

That will break things, logically, as those are connected.
Please always update all Toolset Plugins which are available to update.

I can still see the issue on the site now, but its outdated.
If it's outdated, we cannot resolve the issue.

If that still happens when you update (you may try on a staging site) please let m know and possibly, add a copy of the site (or allow me to grab one)

This ticket is now closed. If you're a WPML client and need related help, please open a new support ticket.