Skip Navigation

[Resolved] Issues between GeneratePress and Toolset integration

This support ticket is created 5 years, 2 months ago. There's a good chance that you are reading advice that it now obsolete.

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Sun Mon Tue Wed Thu Fri Sat
- - 14:00 – 20:00 14:00 – 20:00 14:00 – 20:00 14:00 – 20:00 14:00 – 20:00
- - - - - - -

Supporter timezone: Asia/Ho_Chi_Minh (GMT+07:00)

Tagged: 

This topic contains 13 replies, has 5 voices.

Last updated by Beda 5 years ago.

Assigned support staff: Beda.

Author
Posts
#572083

Amir
Supporter

Please tell us here what issues you found or missing features in the integration between GeneratePress theme and Toolset.

If you are talking about GP addons, remember to explain which addon (and link to it). Include screenshots of the settings that you want Toolset to control and explain how you will use these settings in the sites that you build.

This explanation will help us build it exactly like you need. Thanks!

#572148

How about toolset , GP and elementor ?

#572204

I tried installing the beta on my localhost, DesketopServer, however it is running on PHP Version is 5.5.24, but the beta isn't Activating. I talked to Noman about it who told me, "It worked for me when I tested on WP site running on PHP version 5.6.30".

I talked to DesktopServer and they said there isn't anyway to upgrade to a later version of PHP. I have to wait until their next major release which will have PHP 7.1.3 and MariaDB.

Can you suggest another way to test the GP beta? Noman mentioned I could try it on a live server. I know I can add a subdomain on my live server for testing purposes. Can you give me some suggestions about how to set up a testing subdomain? I might be interested in doing this for other projects as well so I have a live environment to work in. Do I need a domain name for that? Would a 'testing doamain name' be helpful? Any video links on this subject would be appreciated.

#572609

Hey Amir - Please disregard my previous post. I have set up something on a live server for testing purposes, loaded the views and layouts betas, and have GP premium installed. I will test them out over the next few days and get back to you.

#572772

On my live site I'm unable to Activate wp-views.2.5-b2 and layouts.2.1-b3

Noman suggested I need at least PHP version 5.6.30. Is that in fact true?

I have tried installing and activating the plugns 3 different ways.
1 - through the wp installer
2 - extracted the zip, then ftp to the plugins folder
3 - upload zip through cPanel, then extracted the zip in the plugins

Each of these methods works for the stable version of these plugins. Its only the beta versions that aren't Activating properly. They install but don't Activate.

Is it correct that I need PHP version 5.6.30 or higher?

I will give you admin privileges in needed.

-----------------------------------

{"core":{"Wordpress":{"Multisite":"No","SiteURL":"http:\/\/www.marksgardens.ca","HomeURL":"http:\/\/www.marksgardens.ca","Version":"4.8.2","PermalinkStructure":"\/%postname%\/","PostTypes":"post, page, attachment, revision, nav_menu_item, custom_css, customize_changeset, wp-types-group, wp-types-user-group, wp-types-term-group, generate_page_header, plant","PostSatus":"publish, future, draft, pending, private, trash, auto-draft, inherit"},"Server":{"jQueryVersion":"1.12.4","PHPVersion":"5.5.36","MySQLVersion":"5.5.50","ServerSoftware":"Apache"},"PHP":{"MemoryLimit":"256M","UploadMax":"128M","PostMax":"128M","TimeLimit":"30","MaxInputVars":"1000"}},"plugins":{"active_plugins":{"aceide\/AceIDE.php":{"Name":"AceIDE","PluginURI":"https:\/\/github.com\/AceIDE\/AceIDE","Version":"2.5.5","Author":"AceIDE","AuthorURI":"","TextDomain":"aceide","DomainPath":"","Network":false,"Title":"AceIDE","AuthorName":"AceIDE"},"gp-premium\/gp-premium.php":{"Name":"GP Premium","PluginURI":"https:\/\/generatepress.com","Version":"1.4.3","Author":"Tom Usborne","AuthorURI":"https:\/\/tomusborne.com","TextDomain":"gp-premium","DomainPath":"","Network":false,"Title":"GP Premium","AuthorName":"Tom Usborne"},"maintenance\/maintenance.php":{"Name":"Maintenance","PluginURI":"http:\/\/wordpress.org\/plugins\/maintenance\/","Version":"3.5.1","Author":"fruitfulcode","AuthorURI":"http:\/\/fruitfulcode.com","TextDomain":"maintenance","DomainPath":"","Network":false,"Title":"Maintenance","AuthorName":"fruitfulcode"},"regenerate-thumbnails\/regenerate-thumbnails.php":{"Name":"Regenerate Thumbnails","PluginURI":"http:\/\/www.viper007bond.com\/wordpress-plugins\/regenerate-thumbnails\/","Version":"2.3.1","Author":"Alex Mills (Viper007Bond)","AuthorURI":"http:\/\/www.viper007bond.com\/","TextDomain":"regenerate-thumbnails","DomainPath":"","Network":false,"Title":"Regenerate Thumbnails","AuthorName":"Alex Mills (Viper007Bond)"},"types\/wpcf.php":{"Name":"Toolset Types","PluginURI":"http:\/\/wordpress.org\/extend\/plugins\/types\/","Version":"2.2.16","Author":"OnTheGoSystems","AuthorURI":"http:\/\/www.onthegosystems.com","TextDomain":"types","DomainPath":"","Network":false,"Title":"Toolset Types","AuthorName":"OnTheGoSystems"}},"mu_plugins":[],"dropins":[]},"theme":{"Name":"GeneratePress","ThemeURI":null,"Author":"\u003Ca href=\u0022https:\/\/tomusborne.com\u0022\u003ETom Usborne\u003C\/a\u003E","AuthorURI":null,"Template":"generatepress","Version":"1.4","TextDomain":null,"DomainPath":null},"extra-debug":{"types":{"add_resized_images_to_library":0,"register_translations_on_import":1,"images_remote":0,"images_remote_cache_time":"36","help_box":"by_types","hide_standard_custom_fields_metabox":"show","postmeta_unfiltered_html":"on","usermeta_unfiltered_html":"on"}}}

#573394

Hi Mark,

Thank you for reporting this issue. We are aware of it and we are going to launch another beta with a fix for this issue.

Please keep following this ticket and I will notify you once we launch the new beta.

Thanks.

#573451

Thanks for the update Mohammed. I'm excited about this project and I look forward to testing the beta when the new one is ready.

#574098

Hi Mark,

Can you please test the issue in the new Beta release Views 2.5-b3 and Layouts 2.1-b4

Thanks.

#574303

I deleted the Views 2.4.1, and Layouts 2.0.3.

Then installed Views 2.5-b3 and Layouts 2.1-b4. Both these betas installed and this time they activated. But, when I tried to work with a template and a layout I got "500 errors" and was not able to go any further. Here is the debug info:
----------------------------
{"core":{"Wordpress":{"Multisite":"No","SiteURL":"http:\/\/www.marksgardens.ca","HomeURL":"http:\/\/www.marksgardens.ca","Version":"4.8.2","PermalinkStructure":"\/%postname%\/","PostTypes":"post, page, attachment, revision, nav_menu_item, custom_css, customize_changeset, wp-types-group, wp-types-user-group, wp-types-term-group, dd_layouts, generate_page_header, view, view-template, plant, test1, widget-area","PostSatus":"publish, future, draft, pending, private, trash, auto-draft, inherit"},"Server":{"jQueryVersion":"1.12.4","PHPVersion":"5.5.36","MySQLVersion":"5.5.50","ServerSoftware":"Apache"},"PHP":{"MemoryLimit":"256M","UploadMax":"128M","PostMax":"128M","TimeLimit":"30","MaxInputVars":"1000"}},"plugins":{"active_plugins":{"gp-premium\/gp-premium.php":{"Name":"GP Premium","PluginURI":"https:\/\/generatepress.com","Version":"1.4.3","Author":"Tom Usborne","AuthorURI":"https:\/\/tomusborne.com","TextDomain":"gp-premium","DomainPath":"","Network":false,"Title":"GP Premium","AuthorName":"Tom Usborne"},"layouts\/dd-layouts.php":{"Name":"Toolset Layouts","PluginURI":"https:\/\/toolset.com\/","Version":"2.1-b4","Author":"OnTheGoSystems","AuthorURI":"http:\/\/www.onthegosystems.com","TextDomain":"layouts","DomainPath":"","Network":false,"Title":"Toolset Layouts","AuthorName":"OnTheGoSystems"},"maintenance\/maintenance.php":{"Name":"Maintenance","PluginURI":"http:\/\/wordpress.org\/plugins\/maintenance\/","Version":"3.5.1","Author":"fruitfulcode","AuthorURI":"http:\/\/fruitfulcode.com","TextDomain":"maintenance","DomainPath":"","Network":false,"Title":"Maintenance","AuthorName":"fruitfulcode"},"types\/wpcf.php":{"Name":"Toolset Types","PluginURI":"http:\/\/wordpress.org\/extend\/plugins\/types\/","Version":"2.2.16","Author":"OnTheGoSystems","AuthorURI":"http:\/\/www.onthegosystems.com","TextDomain":"types","DomainPath":"","Network":false,"Title":"Toolset Types","AuthorName":"OnTheGoSystems"},"wp-views\/wp-views.php":{"Name":"Toolset Views","PluginURI":"https:\/\/toolset.com\/?utm_source=viewsplugin\u0026utm_campaign=views\u0026utm_medium=plugins-list-full-version\u0026utm_term=Visit plugin site","Version":"2.5-b3","Author":"OnTheGoSystems","AuthorURI":"http:\/\/www.onthegosystems.com","TextDomain":"wp-views","DomainPath":"","Network":false,"Title":"Toolset Views","AuthorName":"OnTheGoSystems"}},"mu_plugins":[],"dropins":[]},"theme":{"Name":"GeneratePress","ThemeURI":null,"Author":"\u003Ca href=\u0022https:\/\/tomusborne.com\u0022\u003ETom Usborne\u003C\/a\u003E","AuthorURI":null,"Template":"generatepress","Version":"1.4","TextDomain":null,"DomainPath":null},"extra-debug":{"types":{"add_resized_images_to_library":0,"register_translations_on_import":1,"images_remote":0,"images_remote_cache_time":"36","help_box":"by_types","hide_standard_custom_fields_metabox":"show","postmeta_unfiltered_html":"on","usermeta_unfiltered_html":"on"},"layouts":{"ddl_layouts_css_framework_options":"bootstrap-3","framework_setup":true},"views":{"views_template_loop_blog":0,"wpv_bootstrap_version":1,"wpv_custom_conditional_functions":[],"wpv_custom_inner_shortcodes":[],"wpv_debug_mode":"","wpv_debug_mode_type":"compact","wpv_map_plugin":0,"wpv_show_edit_view_link":1,"wpv_show_hidden_fields":"","wpv_saved_auto_detected_framework":"","wpv_codemirror_autoresize":"","wpv_enable_pagination_manage_history":true,"wpv_enable_parametric_search_manage_history":true,"views_template_for_plant":0}}}

#574444

@markh-16 I suspect you have fatal error in your install, you can see that once you enable WP Debug in WordPress:
https://codex.wordpress.org/WP_DEBUG

The Error 500 is a 'catch-all' error generated by the Web server. Basically, something has gone wrong, but the server can not be more specific about the error condition in its response to the client. In addition to the 500 error notified back to the client, the Web server should generate some kind of internal error log which gives more details of what went wrong.

With WP Debug, you should be able to see that error.

Eventually (I am not sure), you run PHP 5.5.36 or similar, and there is a conflict with that version.
The error is:

Fatal error: Arrays are not allowed in class constants in wp-content/plugins/layouts/vendor/toolset/toolset-theme-settings/compatibility-modules/controllers/toolset-theme-integration-settings-abstract-controller.php on line 5

We will release a fix for this in form of a new beta very soon (eventually today).

Thank you a lot for the cooperation and patience.

#574589

Thanks @mark for reporting this and sorry for any inconvenience.

I need to check your website myself.
And to avoid many replies here because the purpose of this ticket is mainly to gather the issues and suggestions.
I'm kindly asking you to open a new ticket and assign it to me so that I can check your website.

You will be allowed to provide the access credentials of your website in the new ticket.So, I will be thankfull if you provided the credentials there.

Thanks.

#576305

After using GP with the Views and Layouts beta I can say it is working well for me. No issues after updating my server to PHP 5.6.24.

I like using the GP Premium feature, Page Header. Would like to see it added to the Layouts and Templates options with the rest of the Theme Options.

I haven't explored GP enough to know which of the other Premium features I want. Still new to GP.

#577590

Hi Mark,

Thank you for your suggestion. I already forwarded it to the management but FYI, our plan now is to offer a complete integration with the free version of GeneratePress but of course, we will take this into account.

Thanks.

#589840

We close this thread.

If you have Bugs or Suggestions to report between GeneratePress and Toolset, please open a new ticket for the topic.

Thank you all for the feedbacks!