Skip Navigation

[Resolved] Issue with images updating

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 10 replies, has 2 voices.

Last updated by Pete 3 weeks, 3 days ago.

Assigned support staff: Shane.

Author
Posts
#2176917
aaa see 44.png

Hi there,

We've just started using a system we've been using for you couple of years on other sites of ours...but not on our sites that use Toolset.

We are using WP All Import: hidden link

This doing its job, it creates exports based on what we add daily. Smaller import sites import specific data at a set time.

All works exactly as it should however on our Toolset grids, the images take their time updating.

This a grid where 4 properties were imported overnight: hidden link

First 4, (Birch House, 2 Remera, 7 Four Seasons, 8 Fernhill) the feature images aren't showing. Now after some time, they eventually do appear. However I have cleared the cache on the site and our browsers.

It is as if, Toolset is caching something itself, or???

Any ideas please? Thank you, Pete

#2177213

Hi there, an UPDATE!

I added cached="off" to the shortcode used by the View on the specific page....this cleared the issue immediately!

[wpv-form-view name="holidays-sub-feat-pages" wpv-area="cornwall" cached="off" target_id="self"]

I guess I have two questions:

- Is this affecting the page speed in anyway?
- If this is the correct thing to do, is there a way of making this work side wide rather than me having to edit 'every' shortcode?

Many thanks, Pete

#2177435

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Pete,

Thank you for getting in touch.

Our views normally works better with caching especially if you are loading a lot of data. You can clear the view cache by going to Toolset -> Views and you should see the clean cache button.

Thanks,
Shane

#2177439
aa see here.png

Hi there Shane,

Hope you are well. This I thought the case and disabling caching never usually something I ever wish to do.

The problem is, our sites now update daily...this all done using cron over night.
We can't go into every site and manually clear every View that these updates may effect...we'd be here for ages.
Also the 'clean cache' button does not come on.

Any other suggestion?

#2177463

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Pete,

What you can do is to try clearing the custom fields cache at Toolset -> Settings -> Frontend and then scroll to Cache.

Usually Toolset will automatically clear the cache at times, however it can be manually cleared at any time.

Please try this and let me know if it helps.
Thanks,
Shane

#2177501
aaa see two.png

Hmmm, ok I see this (see pic attached)

So to be clear, our updates happen daily, 2AM. If we don't get to the sites, all of them and we'll have 10 shortly, first thing in the morning, visitors will see gird items with empty images...making the site in places look broken.

When it says: Toolset will manage this cache and clear it automatically

Are there no options, settings or clever code we can add than means we can set this ourselves.

It's not going to be practical moving forward to have to clear this manually, every day of the week.

#2177613

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Pete,

Unfortunately the solution here is to leave the cache off as there isn't any option to specify the frequency of clearing the cache as well as to when the cache is cleared.

You will perhaps need to edit each of the view shortcodes and turn off the cache given that we don't have a solution for your specific requirements.

Thanks,
Shane

#2177617

Hi Shane,

Thanks for the reply.

This annoying as I know the Toolset cache clears...the images aren't there initially however they appear later in the day...even if we do nothing.
So clearly something triggers the cache in Toolset, its just when!

Hmmm this isn't great. We can't be the only ones who use Toolset and update the site using WP All Import.

Goodness, there's always 'something' to battle with...more often with Toolset.

#2178673

Shane
Supporter

Languages: English (English )

Timezone: America/Jamaica (GMT-05:00)

Hi Pete,

I understand your concern.

I've checked in our code to see if there is a way to assist here but I wasn't able to craft a solution for this one.

Perhaps what you can do is to create a feature request in the form below so that our development team can look at add some form of trigger API or better yet allow for custom scheduling for the cache clearing.

The feature request can be filed by using the link below.
https://toolset.com/home/contact-us/suggest-a-new-feature-for-toolset/

Thanks,
Shane

#2180725

Hey Shane,
Hope you had a nice weekend.

Yep, appreciate Toolset can't accommodate 'everyone' needs however clearing caches etc seems one of the more basics 🙂
That said we've worked around this. I will make a suggestion on Toolset...thanks for the link.

And thank you for your time as always.

Take care, Pete

#2180735

My issue is not resolved, however requested this as a Toolset Feature. Thank you!