Skip Navigation

[Closed] Importing a custom post no longer auto-publishes

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Our next available supporter will start replying to tickets in about 8.41 hours from now. Thank you for your understanding.

This topic contains 11 replies, has 2 voices.

Last updated by Jamal 1 month, 2 weeks ago.

Assigned support staff: Jamal.

Author
Posts
#2123713

We are using WordPress Import combined with the WordPress Importer Plugin to import custom posts from one multi-site sub-directory to other sub-directory sites w/in the same domain. All sites utilize Toolset. We have done this many, many times over many years w/o issue. Today though, the custom posts will not display until each post is individually Published.

Previously, if we import 100 posts in (AND as long as the Content Template of the receiving site had the Usage correctly identified with the proper Post Type), all imported posts were immediately live and working. The problem initially appeared as if the Content Template was not properly specified within the Edit page. Your Toolset overwrote our specified Content Template everywhere with Template Dynamically Assigned By Toolset.

But that doesn't appear to be the issue. Once we Publish, the Post loads perfectly fine, regardless whether we leave the Content Template Dynamically Assigned or select the proper Template.

The rest API is working. All plugins were turned off during testing. For some reason, importing custom posts will not go live without re-publishing which we never had to do before. The import is working fine as I can see our content on the backend with all the fields and taxonomies, etc.

Side note: I imported a WordPress standard post from one site to another, and the imported post was immediately live without having to re-publish/save.

#2123911

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello and thank you for contacting Toolset support.

I am trying to reproduce this issue, but I could not get a multisite working on our platform. I'll work on it and get back to you as soon as possible.

#2123925

Thank you, Jamal. We have to import those 100 custom posts into many sub-directories. So we did a few yesterday manually. Meaning once imported, we then had to go to each custom post and Update to make live. That's the 1st error.

However,on some sites, we also had to reset the Content Template as it was showing a random template (not the one required, or your Dynamic). This is the 2nd error. Previously, we used to be able to go to the Content Template and usage assign Post Types to a Template. While we still can check the box, it doesn't do anything in relation to the 100 imported custom posts.

Previously with Toolset, there seemed to be an option where it would ask if we wanted to change ALL posts of that particular Post Type, to that specific Content Template. That option is missing and I see no way to assign all 100 imported posts to a Content Template. Perhaps this 2nd problem is due to the first error of not auto-updating on import?

#2125195

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Well, recently, Toolset has introduced a new way of assigning content templates to custom post types. Previously, we could only assign ONE content template, and it was saved as a custom field on each post. Now, we can assign multiple content templates, with conditions and priorities. The content template with the highest priority is used.

I don't think it is the issue behind importing the posts and founding them unpublished.

So, I run a new Multisite site and I created a simple custom post type without any custom fields. Then, I exported the only post on the custom post type. Then, I created another subsite that has the same post type, and I was able to import the post and get it published without issues.

You can check my test site with the following credentials:
- hidden link
- hello@wpml.org / d22GnCj84D

So, my assumption, is that something else interfering with the import. Most probably, a theme or another plugin. Can you try a new subsite that has only Toolset plugins and a default theme? If the import succeeds, I would say, it is the theme or a plugin, and in that case, please activate the theme and plugins, one at a time, and perform the import each time to check which one is causing the issue.

If that does not help find the cause of the issue, I'll need to take a copy of your multisite and analyze it locally. Let me know if that's fine with you.

#2125349

"So, my assumption, is that something else interfering with the import." Without you using Blocks with no Content Template, Views or Fields ... the test appears to simulate my test of simply using a standard WordPress Page ... which too, works on my site.

Your test Matrix Post does not display on your original site (page not found, although appearing in its Post Type list).

"Now, we can assign multiple content templates, with conditions and priorities. The content template with the highest priority is used." HOW... w/ respect to conditions and priorities?

Can you write a quick cron plugin that can be activated when needed to UPDATE all posts in a Post Type?

#2125473

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

You are right, I tested without activating Toolset Blocks, and without having any content template assigned to my custom post type. Would you like to reproduce the issue on it? Please create a content template, assign it to a custom post type, and perform the import. Let's see if Toolset Blocks is contributing to this issue.

The current Matrix post is published and is accessible on an incognito window(the guest user who can see only published posts) hidden link

Regarding the content templates usage, Toolset will determine what content templates are eligible to be used, based on conditions, then it will use the template with the highest priority. Conditions can be defined by taxonomy or custom fields. For example, a content template to be used for posts that have the category "Auto" assigned.

Regarding your last question(cron plugin), do you mean that will mark the posts as published?

#2125605

Your last reply does not show here in this thread (yes, refreshed and in different browser window). It was emailed to me but landed in my spam folder (odd, as others didn't). Plus now, each character I type in this replay box on your site, the page continually scrolls down my screen.
---
Your test site won't let me upload Toolset Views. Unknown if I can install other plugin blocking all Guttenberg crap. I do not use toolset blocks either, although that is all I see in your test site.

Regarding the content templates usage ... how do I assign in bulk, all 100 imported custom posts to a Template, if Toolset removed that feature (or is looking for 'conditions or priorities' that were never created / assigned?

"your last question(cron plugin), do you mean that will mark the posts as published?". When I import posts from one site to another, if the posts were previously published, the import is already published using same publish date (that is good). My problem is that for some reason now, to make those posts live, I must UPDATE them all individually, which never had to do before. I too, can't figure out how to do this in bulk (which would solve the problem as a work-around).

#2125607

I had to log out and log back in to see my reply, even though your system showed me still as logged in. All good now!

#2125613

Immediately after my last reply, your site will not auto-update the thread.

#2126435

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

I believe that you have encountered a cache issue with our website. Maybe a CDN or browser cache issue. As far as I know, we did not have any ongoing maintenance work.

Regarding Toolset Views, it is the same as Toolset Blocks. They are basically the same plugin, released with two different names. You can activate the legacy editor in Toolset->Settings->General(tab)->Editing experience.

However, if you insist on installing Toolset Views, you can use a file manager plugin such as WP File Manager, or Filester:
- https://wordpress.org/plugins/wp-file-manager/
- https://wordpress.org/plugins/filester/

Regarding updating all posts in bulk, you can, of course, implement a cron job to do it, or you can do it manually:
- Increase the number of posts in the admin's list. Check this screenshot hidden link
- Select the required posts, and bulk edit them, check this screenshot hidden link
- And this screenshot hidden link

On the other hand, if you want us to continue debugging why are the posts not published, please perform the test that I suggested in my previous reply https://toolset.com/forums/topic/importing-a-custom-post-no-longer-auto-publishes/#post-2125195

#2126707

If I'm understanding correctly, your previous suggestion was to me duplicate the issue on your system (as a test).
- Views is not installed on your system.
- Your system won't allow me to upload plugins.
- Without Views, I can't activate the legacy editor, as the editing experience does not exist.
- Your suggestion to fix was for me to upload a file manager plugin to upload Views ... your system won't allow me to upload plugins.
Now your last reply restates to do the above 'test' if I want you to 'continue debugging' ... ENOUGH!

Previously I asked, "Regarding the content templates usage ... how do I assign in bulk, all 100 imported custom posts to a Template, if Toolset REMOVED THAT FEATURE (or is looking for 'conditions or priorities' that were never created / assigned?)"
- I ask because when importing 100 custom posts, apparently I need to reset in BULK somehow, the Custom Post Type.
- Nor can I use your last suggestion, "updating all posts in bulk, manually", as assigning Content Templates is not an option.

As far as using that same suggestion, "updating all posts in bulk, manually", to at least UPDATE posts (although w/o a Content Template applied ...):
- This (per your 3 screenshots) does not work on Toolset Post Types (it does nothing). It works only on WordPress pages/posts. I tried that many times prior to asking for your support. It used to work a while back before Guttenburg and blocks took over WordPress and Toolset. Perhaps only affecting Multisite?

It seems Toolset is no longer compatible WordPress Multisite since G & Blocks were introduced. Especially for legacy users of Views. Yesterday, I installed two different import and 2 different export plugins to replace the WordPress Importer plugin. The error of Toolset custom posts not updating, keeping content template assigned after import, or bulk editing, did not go away. The functionality of WordPress seems to be working well, only outside of Toolset interactions, for some reason.

#2130331

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello and my apologies for the late reply, but I do not work on Wednesdays and Thursdays as you may check on my profile page https://toolset.com/forums/users/jamal-b/

I want to assure you that we'll do our best to assist you with any issue regarding Toolset. And my apologies for any misunderstanding.

Regarding content templates, the system has changed. It is no longer possible to assign a content template to posts in the old way. Now, the content templates are assigned with conditions and priorities. That's how it works now. And I prefer that we handle the publishing of posts before handling content templates. Please, let's focus on the publishing of the imported posts first, then we can work on the content template issue. Because, if a post is not published, it won't be visible to site visitors with any template.

Toolset is compatible with Multisite. If we find any bug regarding multisite, we'll fix it.

On my test site, I have installed Views, if you would like to reproduce the issue that would be awesome. Because, if it is reproduced, we can assume it is a bug, and I will escalate it to the developers. If it is not reproduced, it will mean that the issue is triggered by something else, that is present on your website(theme/plugin/etc.).

If the issue is not reproduced on my test site, we can debug it on a copy of your website. Let us log in to your website, we'll install Duplicator and take a copy of it to debug locally. Then, we'll need to know the exact steps you follow. A video recording would be perfect, so we can see the exact steps, without sending too many messages back and forth.

The topic ‘[Closed] Importing a custom post no longer auto-publishes’ is closed to new replies.