Skip Navigation

[Resolved] Toolset Maps not displaying markers

This thread is resolved. Here is a description of the problem and solution.

Problem: Toolest maps is not displaying any Markers. It displays a blue ocean part.

Solution: This will help. Please follow the isntructions carefully: https://toolset.com/forums/topic/google-map-is-not-created-with-marker-when-creating-post-with-cred/#post-430594

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

This topic contains 14 replies, has 2 voices.

Last updated by bhk-2 5 years, 2 months ago.

Assigned support staff: Beda.

Author
Posts
#429958

relating to this URL: https://toolset.com/forums/topic/google-maps-does-not-display-properly/

Existing maps are loaded successfully. However, the map on the newly created posts are displayed global map.

list page: hidden link

page without error: hidden link

page with error created newly: hidden link
hidden link

cred form edit page for creating new post: hidden link

please help me again.

Thanks.

#430061

As mentioned, this is a Google API issue.

You say, this happens only if you create the Post with CRED, but not so if you create the Post with the WP Admin, is this correct?

I tested this with our API as well and it works, as expected.

Please let me know if I misunderstand your issue, but to me it seems your API is not yet correctly set up.

#430124
스크린샷4.png
스크린샷3.png

Thanks for your prompt response.

Even if creating post with WP Admin, the result is the same.

The API was reset. But I'm not sure what went wrong.

Here are my API admin screenshots.

Thanks.

#430594

Then it is 99% sure the API.

I answered around 50 Threads the last two weeks regarding this.

I can offer what follows.

1. Steps that we can provide to add correct API Keys:

Please ensure that you followed this DOC exactly:
https://toolset.com/documentation/user-guides/display-on-google-maps

1. Create an Address Field with Types Plugin
2. Add Addresses to your Posts
3. Insert the Map and markers to a View or your Post (directly, do not use Layouts, for debug purposes)
4. call the View on a page or view your Post.

==> Very important is to know, that Google did change its API rules.

==> You now NEED an API key and here is described how that API must be set up:
https://toolset.com/documentation/user-guides/display-on-google-maps > Creating a Google Maps API Key

==> I would "overkill" it a bit and delete the current API, so to create a new one.

==> Also, wildcard URL restricting of the API, or any other form of restriction of the API, is tricky.
Please try first without restrictions, in case it still does not work.

2. General Troubleshooting:

If then all this did not solve the problem, please check if the issue also persist with a WordPress Default Theme and NO Plugins BUT the Toolset Plugins?

3. I can also test our own API on your Site, to show you that it is working properly:

If the issue still persists, please let me know and I will get a Internal Google API Key, and test it on your site to see if that works.

#431073

API Referrer restrictions are tricky, Google does not illustrate really how to use them.

We succeeded by adding a referrer restriction like this:

*.site.com/*

You might try different syntaxes, and it's important to know that if your Site is a sub site or not a "genuine" URL (like a redirect or such) it will most certainly not work.

Please let me know the outocome, and if possible, make tests in both CRED and Backend, just to exclude that one is working and the other not.

#431099

I added referrer restrictions like this:

*.kwanggotop.com/*, hidden link and hidden link
My Site is a "genuine" URL.

With other plugin(formidable forms), I added referrer restrictions like this: hidden link
It worked well.

And I tested both CRED and Backend with referrer restrictions, It is not working.

Thanks.

#431123

With this referrer restrictions: *.kwanggotop.com/*
In the View, I can not see all maps.

With this referrer restrictions: hidden link
In the View, I can see all maps.
I can creat post with both CRED and Backend, but map is not loading properly.

Thanks.

#431127

As I elaborated, referrer restrictions do work, our Internal Tester succesfully tested this with the above syntax.

We can not help with Google Issues.

This is not a Toolset Maps problem.
It's Google that creates those restrictions, not toolset Maps.

We do not modify any API or such. It can not be a cause of the software.

It might be that google does not like restrictions with the API we need (Maps API, such as geocoding API)

I don't think Formidable Forms uses Maps, correct?

I know of many users they had issues with the referrers.
But most solved it after trial and fail, and we also succeded with the above syntax.

Can you refer to Google for this issue?

It is not a BUG in Toolset Maps as far we can tell.

#431169

Thank you for your answer.
I will study more.
I tested with formidable forms, GMW and Formidable Geolocation.

Thanks.

#431574

I can creat post with both CRED and Backend using the same referrer restriction, but map is not loading properly.
A a result of testing my site, I can see all maps only with the same referrer restriction.
But I had created posts including goolge map with other plugin('Formidable Geolocation') using the same referrer restriction successfully.
If it is a Google API problem, I can not find a workaround. Because I am a free user of google map API, developing my site to test as far.
I can not really find a workaround with your help.

Thanks.

#432019

Document related to Developer's Gudie of Geocoding API: hidden link

Document related to get an API key: hidden link

If I get an API key, server key is created.

And relating to this document: hidden link
I don't know where to insert this key.

In addition to google map api key, do I need a Geocoding API key?
This approach to solve the problem is a right way?

Thanks.

#432369

All setups for the key you need are elaborated here:
https://toolset.com/documentation/user-guides/display-on-google-maps/ > Creating a Google Maps API Key, as linked previously.

- Google Maps Geocoding API
- Google Maps JavaScript API
- Google Places API Web Service

Working with referrers restrictions is tricky, and should be on the client relation with Google.

We offer a convenient way of displaying maps and markers, but the restrictions imposed by Google and their settings are out of our control.

If Toolset Maps works without restrictions, and adding a restriction to the Google developers console breaks it, we think it should be Google support who offers insight about the root cause.

Besides this, It seems, you have been asking to the Formidable Geolocation guys why your autocomplete was not working:
hidden link
Is this correct?

Perhaps, your setup has a kind of issue we do not know or can not control.

Once you set the referrer restriction in the Google developers console, it is not on us anymore.

We do nothign on that, we do not have any internal code or management for it.

We make a call and get a response, and if the call is performed from within the allowed referrer, which it should be, it just should work.

On the initially linked errora page I can see the Markers:
hidden link

Have you meanwhile solved this issue?

#432385

Thank you for your answer.

If I delete the referer restriction, since then error pages are displayed correctly .

I think API setting is correct. Is that right?

If API setting is correct and referrer restriction does not work, I have to contact with google. Is that right?

Thanks.

#432891

Yes, this is not on our hands, unfortunately I can not help with this.

I suggest to go once over the steps and perhaps re-creating the API key as per the instructions on our DOC that I linked above.

#435443

...