Skip Navigation

[Resolved] Fatal Error trying to use WP-cli

This is the technical support forum for Toolset - a suite of plugins for developing WordPress sites without writing PHP.

Everyone can read this forum, but only Toolset clients can post in it. Toolset support works 6 days per week, 19 hours per day.

Sun Mon Tue Wed Thu Fri Sat
- 10:00 – 13:00 10:00 – 13:00 10:00 – 13:00 10:00 – 13:00 10:00 – 13:00 -
- 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 -

Supporter timezone: Asia/Kolkata (GMT+05:30)

This topic contains 5 replies, has 2 voices.

Last updated by Minesh 1 year, 1 month ago.

Assigned support staff: Minesh.

Author
Posts
#2241929

I am trying to:
Use WP-cli, if I have the Toolset Views plugin activated I get a Fatal error in the console and I can't use WP-cli.

[root@sd-1522309-l /home/ricciard/public_html] # wp plugin list
PHP Fatal error: Uncaught Error: Class 'WPV_Api_Handler_Is_views_lite' not found in /home/ricciard/public_html/wp-content/plugins/wp-views/application/controllers/api.php:207
Stack trace:
#0 /home/ricciard/public_html/wp-includes/class-wp-hook.php(303): WPV_Api->__call('callback_is_vie...', Array)
#1 /home/ricciard/public_html/wp-includes/plugin.php(189): WP_Hook->apply_filters(false, Array)
#2 /home/ricciard/public_html/wp-content/plugins/wp-views/inc/wpv-plugin.class.php(963): apply_filters('wpv_is_views_li...', false)
#3 /home/ricciard/public_html/wp-includes/class-wp-hook.php(303): WP_Views_plugin->wpv_register_assets('')
#4 /home/ricciard/public_html/wp-includes/class-wp-hook.php(327): WP_Hook->apply_filters(NULL, Array)
#5 /home/ricciard/public_html/wp-includes/plugin.php(470): WP_Hook->do_action(Array)
#6 /home/ricciard/public_html/wp-settings.php(578): do_action('init')
#7 hidden link): require('/home/ricciard/...')
#8 hidden link): WP_CLI in /home/ricciard/public_html/wp-content/plugins/wp-views/application/controllers/api.php on line 207
Fatal error: Uncaught Error: Class 'WPV_Api_Handler_Is_views_lite' not found in /home/ricciard/public_html/wp-content/plugins/wp-views/application/controllers/api.php:207
Stack trace:
#0 /home/ricciard/public_html/wp-includes/class-wp-hook.php(303): WPV_Api->__call('callback_is_vie...', Array)
#1 /home/ricciard/public_html/wp-includes/plugin.php(189): WP_Hook->apply_filters(false, Array)
#2 /home/ricciard/public_html/wp-content/plugins/wp-views/inc/wpv-plugin.class.php(963): apply_filters('wpv_is_views_li...', false)
#3 /home/ricciard/public_html/wp-includes/class-wp-hook.php(303): WP_Views_plugin->wpv_register_assets('')
#4 /home/ricciard/public_html/wp-includes/class-wp-hook.php(327): WP_Hook->apply_filters(NULL, Array)
#5 /home/ricciard/public_html/wp-includes/plugin.php(470): WP_Hook->do_action(Array)
#6 /home/ricciard/public_html/wp-settings.php(578): do_action('init')
#7 hidden link): require('/home/ricciard/...')
#8 hidden link): WP_CLI in /home/ricciard/public_html/wp-content/plugins/wp-views/application/controllers/api.php on line 207
Error: Ha habido un error crítico en esta web.Aprende más sobre el diagnóstico de WordPress. Ha habido un error crítico en esta web.
[root@sd-1522309-l /home/ricciard/public_html]

#2243163

Minesh
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello. Thank you for contacting the Toolset support.

Can you please make sure that all Toolset requirements especially "mbstring" is enabled on your server?
- https://toolset.com/toolset-requirements/

#2243513

They are:
hidden link

#2244159

Minesh
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Can you please tell me what PHP version you are using while you run the WP CLI commands?

Does it uses the same version and with that PHP version is all server requirements are setup?
- https://toolset.com/toolset-requirements/

#2244267

I checked, it's not, it's PHP7.3 no clue how to enable mbstring or eval() there.

#2244357

Minesh
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

You will require to edit php.ini file for the php version you are using and make sure the server requirement is configured accordingly.

More info:
=> hidden link